42re diagnosis - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > 42re diagnosis

Black Friday Sale - Deep Discounts from ExtremeTerrain.com6th Annual, Beat Your Wife to the Credit Card Sale!FS: Wrangler RGB Multicolor Fog Light LEDs: Awesome Effect

Reply
Unread 01-30-2014, 03:03 AM   #1
clute75
Registered User
2000 WJ 
 
Join Date: Aug 2013
Location: gloversville, NY
Posts: 19
Unhappy 42re diagnosis

so i just put another engine in my jeep and when i started it up and checked for leaks i had tranny fluid leaking out of the bell housing. i did replace the pump seals and torque converter prior to putting the motor in and the motor and trans went in at once. the torque converter was fully seated in the tranny before putting the two together and the motor started and ran high idle due to timing issues but besides that normal. what did i do wrong? any ideas?

clute75 is offline   Reply With Quote Quick reply to this message
Unread 01-30-2014, 08:20 AM   #2
88yjproject
Registered User
2002 WJ 
 
Join Date: Feb 2010
Location: Wyoming, Michigan, Michigan
Posts: 1,078
Could be a seal not installed properly or a bad converter sealing surface. also the transmission vent is on the pump and fluid could be too full. Try cleaning it out and running it and see what happens.
__________________
2002 WJ 4.0 3" IRO, ES9000 shocks. Midland CB. 245/75R16 Dunlop M/T.
HydroLocked Offroad
88yjproject is offline   Reply With Quote Quick reply to this message
Unread 01-30-2014, 04:25 PM   #3
clute75
Registered User
2000 WJ 
 
Join Date: Aug 2013
Location: gloversville, NY
Posts: 19
i pulled the tranny and pump today and checked all the gaskets and seals they were all good . when it starts it sounds like the torque converter clunks into place so we are going to go back and make sure we got the converter for the 42re not the 44
clute75 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.