4.7 HO Oil Sending Unit Which One? - JeepForum.com

 
LinkBack Thread Tools
post #1 of 6 Old 09-26-2013, 02:48 PM Thread Starter
TheShadow9079
Registered User
1996 ZJ 
 
Join Date: Jun 2013
Location: Severance
Posts: 12
Wj 4.7 HO Oil Sending Unit Which One?

2004 Jeep WJ Limited 4.7HO

Okay so I am getting two different Mopar part numbers for my oil sending unit.
Mopar 5149097AA:
This is what O'Reilly Auto Parts and my local Dodge dealer said

Mopar 4868672AA:
This is what Mopar's website said.


I tried calling Mopar's support number and they wanted my vin number. I'm like, yes, I just have that memorized. I don't have the vehicle with me right now. It shouldn't be this difficult.

TheShadow9079 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 09-26-2013, 02:56 PM
briandor
Registered User
2004 WJ 
 
Join Date: Feb 2013
Location: Sinking Spring
Posts: 255
briandor is offline  
post #3 of 6 Old 09-26-2013, 02:57 PM
briandor
Registered User
2004 WJ 
 
Join Date: Feb 2013
Location: Sinking Spring
Posts: 255
BTW, the number you got from the Mopar site is an old part number that looks to be replaced by this one.
briandor is offline  
 
post #4 of 6 Old 09-26-2013, 10:33 PM
rdkendrick
Registered User
2003 WJ 
 
Join Date: Jan 2013
Location: Cincinnati
Posts: 3,150
Quote:
Originally Posted by TheShadow9079 View Post
2004 Jeep WJ Limited 4.7HO Okay so I am getting two different Mopar part numbers for my oil sending unit. Mopar 5149097AA: This is what O'Reilly Auto Parts and my local Dodge dealer said Mopar 4868672AA: This is what Mopar's website said. I tried calling Mopar's support number and they wanted my vin number. I'm like, yes, I just have that memorized. I don't have the vehicle with me right now. It shouldn't be this difficult.
Your VIN should be on your insurance card, which, I know I keep one in my billfold.

Sent from my iPad using my fingers
rdkendrick is offline  
post #5 of 6 Old 09-27-2013, 01:17 PM Thread Starter
TheShadow9079
Registered User
1996 ZJ 
 
Join Date: Jun 2013
Location: Severance
Posts: 12
Thumbs up

Thanks! Yeah, that site is right briandor. The Mopar site's part number is just an old part number. The funny thing is I called them and they gave me the current part number. But on their site, they say that the new part number is not compatible with my Jeep. And the old part number that is matched with my Jeep is $7 less than the new part number, but it would ultimately ship the same part as the new part number. lol, wow.

Yeah, rdkemdrick, I don't keep all my insurance cards with me. My wallet is too fat as is, and it ain't cause I'm rich. lol
TheShadow9079 is offline  
post #6 of 6 Old 09-29-2013, 04:09 PM
Jaspah
Registered User
2002 WJ 
 
Join Date: Oct 2012
Location: Hamilton
Posts: 258
I'm pretty sure this is the part that they changed after the 2002 model year. The newer one is a "dumby" gauge that is either good or bad. The prior part actually read the correct oil pressure.
Jaspah is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome