4.0 knocking tapping? - JeepForum.com
 
LinkBack Thread Tools
post #1 of 11 Old 09-12-2017, 04:57 PM Thread Starter
maxxedout
Registered User
 
Join Date: Jan 2013
Location: kannapolis
Posts: 9
4.0 knocking tapping?

Got a 99 4.0, it started with a tapping sound which I thought was the lifters , so installed new ones. Then thought it was a rod ,replaced rod bearings and checked piston skirts still same sound. Checked fly wheel bolts and still the same sound, could it be cam bearings??? Have access to rebuilt engine for 800 dollars should I just ditch it and get the engine and cut my losses....

maxxedout is offline  
Sponsored Links
Advertisement
 
post #2 of 11 Old 09-12-2017, 11:10 PM
Squarecat
Member
1993 XJ Cherokee 
 
Join Date: May 2013
Location: Lakewood
Posts: 143
4.0 knocking tapping?

How bad/loud is it?

Though it is well-known that it's just something a 4.0 might do and I wouldn't suggest blatantly ignoring a potential problem however, from the repairs you've already done (which address the most common sources of that noise), I'm wondering how much more you should worry about it.

Seems like a bigger loss to ditch an otherwise good engine you've improved key areas of over a noise they are known to make.


Sent from my iPhone using Tapatalk
Squarecat is offline  
post #3 of 11 Old 09-13-2017, 03:33 PM Thread Starter
maxxedout
Registered User
 
Join Date: Jan 2013
Location: kannapolis
Posts: 9
This is not a normal knock, hits hard. Can hear it coming up the drive way from the house and its about 50 yards long...It had the normal jeep sounds before but this just started and has gotten real bad and loud, still runs great just running me nuts....
maxxedout is offline  
 
post #4 of 11 Old 09-13-2017, 06:32 PM
MOTOWN
Registered User
2001 WJ 
 
Join Date: Nov 2016
Location: ATLANTA
Posts: 177
I bet your exhaust manifold is cracked and leaking.
MOTOWN is online now  
post #5 of 11 Old 09-14-2017, 07:07 AM
seabee26
Registered User
2000 WJ 
 
Join Date: Sep 2003
Location: Chaplin
Posts: 142
It may sound funny, but pull codes. Mine ONLY knocks (sounds EXACTLY like a rod) when it's throwing a P0301 thru P0306 and missing like crazy... no codes, no miss, no knock.
Just something else to look at.
seabee26 is offline  
post #6 of 11 Old 09-14-2017, 05:35 PM Thread Starter
maxxedout
Registered User
 
Join Date: Jan 2013
Location: kannapolis
Posts: 9
Also changed intake exhaust gasket and checked for cracks, found nothing .
It has no miss and runs and idles fine no codes active or pending??

RUNNING ME NUTS......
maxxedout is offline  
post #7 of 11 Old 09-14-2017, 10:48 PM
rep-tile
Cash 4 Clunkers Survivor
 
rep-tile's Avatar
2004 WJ 
 
Join Date: Jul 2013
Location: bakersfield
Posts: 1,260
Quote:
Originally Posted by maxxedout View Post
It had the normal jeep sounds before
^ I'd like to know what that is.

Maybe you can try narrowing down where exactly it is coming from with a stethoscope.

04 WJ 4.0 - Avital 4103, DB-ALL
91 XJ 4.0 - Avital 4103, Stage-2 aFe intake system, BBK high flow Throttle Body, Jones Exhaust A3518M-5
rep-tile is offline  
post #8 of 11 Old 09-15-2017, 02:03 PM
new2site
Registered User
2002 WJ 
 
Join Date: Jan 2012
Location: Orange county
Posts: 1,087
This is probably going to sound stupid, but since most other possibilities have been brought up / exhausted..... and although loud, maybe not as loud as your noises.....but if, for whatever reason, a spark plug indexing washer failed, or was not tightened just quite enough, you WILL get a loud continuous tapping noise (mimicking bad lifter sound etc) from compression sneeking by washer failure .....but engine will not miss being spark plug is in enough still. Ask me how I know..
new2site is offline  
post #9 of 11 Old 09-24-2017, 06:53 PM Thread Starter
maxxedout
Registered User
 
Join Date: Jan 2013
Location: kannapolis
Posts: 9
Worth a check, been thru everything else. Be sorta funny if thats all it is. Will check this week ...Thanks
maxxedout is offline  
post #10 of 11 Old 09-24-2017, 07:09 PM
Spotthejeep
Registered User
2004 WJ 
 
Join Date: May 2015
Location: Saskatoon
Posts: 58
Quote:
Originally Posted by maxxedout View Post
Worth a check, been thru everything else. Be sorta funny if thats all it is. Will check this week ...Thanks


I've read somewhere that it could be a bad injector. My 4.0 has a tick but goes away if turn engine off then restart. Suspecting #3


Sent from my iPhone using Tapatalk
Spotthejeep is offline  
post #11 of 11 Old 09-24-2017, 10:44 PM
Vvrjrlaw
Registered User
 
Join Date: Jul 2017
Posts: 4
I had a 4.0 that had a banging sound that appeared to be coming from deep within the engine. Oil pressure was low. You don't say how many miles are on it but I would check the crank bearings. Mine was a crank bearing but from loss of pressure it scored the rod bearings so I replaced the rods and crank bearings after I had the crank cut. Good luck.
Vvrjrlaw is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome