2004 WJ relocating evap canister and associated parts - Page 2 - JeepForum.com
Reply
 
LinkBack Thread Tools
post #16 of 26 Old 08-07-2013, 10:27 AM
elcorvino
Registered User
2003 WJ 
 
Join Date: Jul 2011
Location: Fort Lauderdale
Posts: 1,243
Also, is it common for these to go bad after quite a few (200K) miles?

elcorvino is offline  
Sponsored Links
Advertisement
 
post #17 of 26 Old 08-07-2013, 01:22 PM Thread Starter
silentbob21
Registered User
2004 WJ 
 
Join Date: Jan 2007
Location: San Diego
Posts: 716
Quote:
Originally Posted by elcorvino
Also, is it common for these to go bad after quite a few (200K) miles?
Common... I dunno, common enough for myself to have read about it haha. Now that I have a new pump my old pump was not near as "tight" so I would say yea, with heat and weathering springing a leak or all together shutting down seems very logical

2004 WJ SE 4.0L I6, NV242, IRO 6.5 LAs D44a Spartan locked, 4.88s, BFG KM2s 35/12.5/15


silentbob21 is offline  
post #18 of 26 Old 08-07-2013, 07:15 PM
ultimo
Registered User
2002 WJ 
 
Join Date: Oct 2009
Location: Asia
Posts: 657
Silentbob...can I ask how you unclipped the old hoses that was running along the sides of the fuel tank? They seem to be secured with clips. I cant reach in...so my old hoses are still hanging there LOL

Build Thread-- http://www.jeepforum.com/forum/f197/ultimos-build-1477712/
ultimo is offline  
post #19 of 26 Old 08-07-2013, 11:59 PM Thread Starter
silentbob21
Registered User
2004 WJ 
 
Join Date: Jan 2007
Location: San Diego
Posts: 716
I believe they had some zip ties on them... I just cut and pulled them all out, was pretty easy. Helps having the jeep lifted 6.5"s haha makes for lots of room!

2004 WJ SE 4.0L I6, NV242, IRO 6.5 LAs D44a Spartan locked, 4.88s, BFG KM2s 35/12.5/15


silentbob21 is offline  
post #20 of 26 Old 08-08-2013, 04:37 AM
elcorvino
Registered User
2003 WJ 
 
Join Date: Jul 2011
Location: Fort Lauderdale
Posts: 1,243
Hmmmm... So if all the lines are up to par... It would be pretty safe to say its time to replace the canister?
elcorvino is offline  
post #21 of 26 Old 08-08-2013, 10:30 AM Thread Starter
silentbob21
Registered User
2004 WJ 
 
Join Date: Jan 2007
Location: San Diego
Posts: 716
There are several components that can fail other than the rubber hoses. LDP failing for P0455 is pretty common from what I gather, but it could also be the vent valve or the purge solenoid up front. I have read about a possible canister leak as well...

I didn't want to keep throwing parts at it so I had the smoke test performed once I knew all my rubber lines were not leaking. Also need to check the little elbows up front on the intake manifold. Mine have cracked several times I'm guessing from the heat

2004 WJ SE 4.0L I6, NV242, IRO 6.5 LAs D44a Spartan locked, 4.88s, BFG KM2s 35/12.5/15


silentbob21 is offline  
post #22 of 26 Old 08-08-2013, 04:37 PM
kc2mrg
Web Wheeler
 
kc2mrg's Avatar
2004 WJ 
 
Join Date: Sep 2008
Location: Poca
Posts: 1,169
subscribed .. need to do this on my wj before the CEL bulb burns out lol

2004 Grand Cherokee Laredo 4.0
Rusty's 2.5" coil/shock lift
265/70/16 General Grabber AT2's
Superchips 3875 Flashpaq
Flowmaster exhaust


West Virginia Jeep Club member
JEEPINWV.COM
kc2mrg is offline  
post #23 of 26 Old 08-08-2013, 08:05 PM
ultimo
Registered User
2002 WJ 
 
Join Date: Oct 2009
Location: Asia
Posts: 657
The last time my ABS bulb came on I ripped it out. Problem solved. LOL

Build Thread-- http://www.jeepforum.com/forum/f197/ultimos-build-1477712/
ultimo is offline  
post #24 of 26 Old 08-09-2013, 02:21 PM Thread Starter
silentbob21
Registered User
2004 WJ 
 
Join Date: Jan 2007
Location: San Diego
Posts: 716
Quote:
Originally Posted by ultimo
The last time my ABS bulb came on I ripped it out. Problem solved. LOL
Haha I did the same for my check engine a couple years ago, but CA smog won't let that fly anymore haha

2004 WJ SE 4.0L I6, NV242, IRO 6.5 LAs D44a Spartan locked, 4.88s, BFG KM2s 35/12.5/15


silentbob21 is offline  
post #25 of 26 Old 10-10-2013, 10:41 PM Thread Starter
silentbob21
Registered User
2004 WJ 
 
Join Date: Jan 2007
Location: San Diego
Posts: 716
I never updated this thread... but after replacing the LDP I have no more check engine light

The Jeep passed Cali smog no problems, now if I can figure out how to get around swapping my exhaust out and still passing haha.

2004 WJ SE 4.0L I6, NV242, IRO 6.5 LAs D44a Spartan locked, 4.88s, BFG KM2s 35/12.5/15


silentbob21 is offline  
post #26 of 26 Old 10-11-2013, 08:56 PM
kodiakwj
Registered User
2003 WJ 
 
Join Date: Jun 2011
Location: BROOKINGS
Posts: 812
That's easy you put in a flange and bolt it up, then at smog time you replace with the factory exhaust. Ask me how I know?!?!?!?!
kodiakwj is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome