2004 Jeep Grand Cherokee won't start :( - JeepForum.com

 
LinkBack Thread Tools
post #1 of 3 Old 01-23-2011, 06:27 PM Thread Starter
jennybugz
Registered User
 
Join Date: Jan 2011
Location: Charleston
Posts: 1
2004 Jeep Grand Cherokee won't start :(

Hi everyone,

We have a 2004 Jeep Grand Cherokee that is setting in our driveway right now because we can not get it to start. We have changed the fuel pump, fuel filter, all the filters in the tank, throttle position sensor, crankshaft position sensor. We have checked the battery, everything is fine.

My dad said that he can't get gas from the main line to the injectors. We can't tell if the fuel pump is getting any power.

This summer it started hesitating while you were driving. Not every time that you drove it, probably every 30 to 40 miles and then it would run fine. It would also blow black smoke. Took it to the repair shop couldn't find anything wrong with it. So we brought it home and changed the spark plugs. The car ran like a dream for a couple more months.

A week before Christmas it started stalling while we were driving it, blowing the black smoke again, and jumping like it was gas starved. We took it to autozone and they hooked it up to the diagnostic. It showed that it was the throttle position sensor. We bought that and changed it. It ran great for a day or so. Then it started the same thing all over again. We took it back to autozone and they still said it was the throttle position sensor. So we took it back off and took it back to autozone and they gave us another one. Installed the new one, ran fine. My dad took it out for a test drive, he got about 9 miles from the house and it started it again. He got it halfway home and it completely stopped. He couldn't get it started again, had to have it towed. That is when we started changing everything that we could think of.

Please help!!!! We have no idea what else to try. It is a 2004 Jeep Grand Cherokee with a 4.0L engine.

jennybugz is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 01-24-2011, 09:24 AM
Double E
2000 Laredo V8
 
Double E's Avatar
2000 WJ 
 
Join Date: Oct 2003
Location: Raleigh, NC
Posts: 4,697
This sounds like need for an OEM TPS first, then (if still happening) you might do a search for the PCM connector problem that's been described in previous threads.

The PCM issue has to do with poor or marginally stable connections at the plug at the PCM and some internal contacts that just need to be freshened and repaired.

Disclaimer: My response only comes from being on this forum for a long time, not personal experience.

2000 Laredo 4.7L Selec-Trac. 177K miles, Leather, 245 tires, tow package, crappy CD changer, full size spare, roof cross-rails & sunroof.
Changes & fixes: Rear Addco sway bar & greasble bushings, upgraded headlights, upgraded tail lights, new hood struts (replaced 2X), new rear hatchglass struts, new radiator (replaced 3X), new oil pressure sending unit (replaced 4X), 2 new speed sensors, 2 new door lock actuators, new ignition key cylinder, chrome front tow hooks, Mobil 1 Synthetic 5/30, Purolator Pure One oil filter, EBC slotted & dimpled rotors, EBC Greenstuff pads, new front shocks (replaced 3X), new rear shocks (replaced 2X), new IRO steering stabilizer, new timing chain cover, new water pump, thermostat, new thermostat housing, new high pressure power steering hose, Michelin-X radials, new sunroof assembly, new single-piece lug nuts, new exhaust manifold studs & gasket on driver's side, new Durango alternator. Jeepforum.com sticker, Visit cobaltboatsforum.com when you can!
Double E is offline  
post #3 of 3 Old 10-16-2012, 08:33 PM
gerardrford
Registered User
2004 CJ2A 
 
Join Date: Sep 2012
Location: Houston
Posts: 2
Get an OEM Fuel filter the Autozone fuel filter does not have the fuel regulator. Try getting the dealer fuel pump and install it.
gerardrford is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
2004 Jeep Grand Cherokee Overland 4.7L HO Loss of Performance / Acceleration Problem DHewes WJ Grand Cherokee Forum 69 02-21-2015 11:26 AM
Just bought my 3rd Jeep! 2004 Jeep Grand Cherokee! drew8742 WJ Grand Cherokee Forum 7 11-11-2010 04:13 PM
2004 Jeep Grand Cherokee---Overheating after water pump replacement! Thoughts? Hundoracer WJ Grand Cherokee Forum 2 07-05-2010 03:22 PM
2004 Jeep Grand Cherokee (WJ) Tire Question paulcicero WJ Grand Cherokee Forum 8 06-30-2010 05:42 PM
Headlights on the 2004 Jeep Grand Cherokee boyandhisjeep WJ Grand Cherokee Forum 1 10-21-2003 01:38 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome