2004 Grand cherokee stalling - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > 2004 Grand cherokee stalling

Engo winches available at www.rockridge4wd.com! Free shippThe Original 3/8" Ruffstuff Diff Cover!The Ruffstuff NOT Universal 4 Link Kit!

Reply
Unread 06-27-2013, 06:30 PM   #1
toates89
Registered User
1989 XJ Cherokee 
 
Join Date: Jan 2006
Location: long island, new york
Posts: 2,190
2004 Grand cherokee stalling

90k miles

Just recently it shut off while stopped while in drive stopped at a light. today it started stalling at a light pulling away, didnt shut off though.

it also doesnt down shift as it should. you really need to press the pedal down.


sound like the tps?

new plugs and no vacuum leaks.

toates89 is offline   Reply With Quote
Unread 06-28-2013, 07:48 AM   #2
toates89
Registered User
1989 XJ Cherokee 
 
Join Date: Jan 2006
Location: long island, new york
Posts: 2,190
BUMP, FOR the 1000 mile trip next wed
toates89 is offline   Reply With Quote
Unread 06-28-2013, 03:14 PM   #3
cjcyr8
Registered User
2004 WJ 
 
Join Date: Dec 2010
Location: St. Louis, Missouri
Posts: 141
I had this EXACT same problem a couple years ago......If you have a 4.0 I-6, carefully check the fuel injector wiring harness; follow it from the front of the valve cover to the rear of the engine....There is a cylinder head stud/bolt at the very back of the engine (drivers side behind valve cover) this stud/bolt threads rubs through the harness, short circuits the wires and causes rough idle, bucking, misfires, hesitation and stalling. The symptoms sometimes begin after the engine is hot or has been running on the highway for awhile, and often come and go...It will take more than just a quick visual inspection....If the harness is resting upon this stud (or near it for that matter), if you don't allready have this problem eventually you will. I repaired the wire, wrapped the entire in harness in nylon loom, and put piece of vacuum hose over that stud...problems solved...

below is link to a picture from Swifty, scroll down a bit you'll see what I'm talking about:

http://www.jeepforum.com/forum/f310/...issue-1488591/
cjcyr8 is offline   Reply With Quote
Unread 06-28-2013, 04:47 PM   #4
doityourselfMM
Senior Member
 
doityourselfMM's Avatar
1999 WJ 
 
Join Date: Dec 2010
Location: manassas, va
Posts: 748
Mine had the same issues. It turned out to be the inexpensive but PITA to install, Crank Position Sensor.



Quote:
Originally Posted by toates89 View Post
90k miles

Just recently it shut off while stopped while in drive stopped at a light. today it started stalling at a light pulling away, didnt shut off though.

it also doesnt down shift as it should. you really need to press the pedal down.


sound like the tps?

new plugs and no vacuum leaks.
doityourselfMM is offline   Reply With Quote
Unread 06-28-2013, 10:32 PM   #5
lance-tek
Registered User
2001 WJ 
 
Join Date: Aug 2012
Location: Indianapolis, IN
Posts: 251
Quote:
Originally Posted by doityourselfMM View Post
Mine had the same issues. It turned out to be the inexpensive but PITA to install, Crank Position Sensor.
Man... this is the second thread I have found tonight that appears to be the CKP. Anyway, I agree... and it's not that bad if you go through the floorboard/firewall.
__________________
I am a novice and will eagerly accept any advice or help I can get.

[CENTER][URL="http://www.jeepforum.com/forum/groups/built-not-bought/"]Built Not Bought # 736[/URL][/CENTER]

[color=red][B][CENTER]What WJ parts do you want from the JY? Send me a PM and I will let you know what's in stock[/CENTER][/B][/color]
lance-tek is offline   Reply With Quote
Unread 06-29-2013, 12:48 AM   #6
sprocket1200
Registered User
2001 WJ 
 
Join Date: Aug 2007
Location: bc canada
Posts: 172
crankshaft position sensor, fixed mine and no issues since very long time ! haha
sprocket1200 is offline   Reply With Quote
Unread 06-29-2013, 12:51 AM   #7
SeminoleEMT
Registered User
2004  
 
Join Date: May 2013
Location: Tallahassee, Florida
Posts: 6
I'm having the same problem (thread "Jeep Shutting Off")
__________________
'04 black Jeep Grand Cherokee special edition
SeminoleEMT is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.