2004 4.0L Engine runs rough after sitting idle for more than 20 minutes. - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > 2004 4.0L Engine runs rough after sitting idle for more than 20 minutes.

Rampage Bowless Soft Top Oconee offroadAlloy USA Still AvailableAdvance Adapters SYE Kits

Reply
Unread 08-22-2013, 06:20 PM   #1
sclarktay4
Registered User
2004 WJ 
 
Join Date: Aug 2013
Location: Conway, Arkansas
Posts: 1
2004 4.0L Engine runs rough after sitting idle for more than 20 minutes.

Hello all,
I am experiencing a rough running engine when I am sitting idle with the A/C on. First, the radiator fan went out about 3 years ago and I finally got it replaced. But before I got the fan replaced, I noticed that when I would sit idle and the engine temperature would go above 220 degrees the engine would start to run rough. I would shut the engine off and then try to restart but it would hardly turn over. I would have to smash the gas just to keep it sputtering. Most of the time it would try to run with a sputtering sound and then turn off. Now, I have replaced the radiator fan so the engine no longer overheats. It will sit idle and then follow the same symptoms like the engine was overheating but the temperature gauge showed that it was at normal operating temp. I turned the car off for about 15 minutes then tried to restart. It did the sputter start and would shut off. I would keep trying to start with my foot on the gas until it did start. I had to hold down the gas to keep it running and after about 30 seconds of pumping the gas, then engine would finally rev up. Only then would I be able to attempt to drive, but once i put it in to reverse or drive there is a clanking/ringing sound. The car will only go about 25 mph. It will finally go away after some driving and accelerate normally and wont happen again until I sit idle for a while. I have changed the spark plugs, got the spark plug coil checked, replaced radiator fan. Again, these symptoms only happen after sitting idle for about 20+ minutes. I do not have any issues while driving. Was thinking of replacing the Engine Crankshaft Position Sensor but I do not want to just keep replacing parts and the problem not go away. Any suggestions will be much appreciated.

sclarktay4 is offline   Reply With Quote Quick reply to this message
Unread 08-22-2013, 07:09 PM   #2
chrism1367
Registered User
2003 WJ 
 
Join Date: Dec 2009
Location: Ohio
Posts: 707
First its not a good idea to let it idle with the ac on that long, its not good for an engine. Second it sounds like vapor lock, where your fuel lines get so hot from idling that long it affects the flow of gas to your engine to the point of running roughly and misfiring, then as it cools it will run better. I'd suggest not letting it idle that long and I'm betting that will solve your problems.
chrism1367 is offline   Reply With Quote Quick reply to this message
Unread 08-23-2013, 10:13 AM   #3
chrism1367
Registered User
2003 WJ 
 
Join Date: Dec 2009
Location: Ohio
Posts: 707
You're welcome
chrism1367 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.