post #1 of Old 05-07-2013, 04:47 AM Thread Starter
natesxj
Registered User
 
Join Date: Oct 2009
Location: nova scotia
Posts: 50
2003 Grand 4.7 FUEL PUMP NOT GETTING POWER

Thought my fuel pump was bad , spent $$$$$$ getting a new pump.

Still didn't work , jeep turns over , gets no pressure at rail.

I checked the fuse AND the relay , swapped the relays out AND tried jumping the relay.


So far from what i can tell... there is no POWER getting to the fuel pump relay because jumping it does not throw my test light on , and does not kick the fuel pump on either.

Any ideas? it ran fine , parked it at the store for a minute came back out and had no fuel all of a sudden.

natesxj is offline  
post #2 of Old 05-07-2013, 05:46 AM
berndog67
Registered User
2003 WJ 
 
Join Date: Nov 2011
Location: fort edward
Posts: 480
i would check the length of the fuel pump wiring, guessing theres a short somewhere, or a break in the wiring itself, check the wires where there are hard bends, overtime the strands can break inside

2003 WJ Overland, 4.7HO, D30 & D44A (1 tons going in now!), RC Long Arm, lifted 4" Front 6" Rear, RC 2.2 4" Shocks, JKS track bar, custom hi-steer, 35" Procomp M/T's on JK rims, beefed up Overland rock rails, custom skids and dif gaurds, Rugged Ridge 8500 synthetic winch in custom hidden mount
berndog67 is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome