2002 grand 4.0l Cruise control buttons turn off/kills engine - JeepForum.com

 
LinkBack Thread Tools
post #1 of 5 Old 03-02-2013, 06:25 PM Thread Starter
02grandy
Senior Member
 
02grandy's Avatar
1999 XJ Cherokee 
 
Join Date: Mar 2011
Location: roseland
Posts: 661
Wj 2002 grand 4.0l Cruise control buttons turn off/kills engine

i have another thread up related to this but seeing if this symptom alone has 100% fix. im having a rough idle problem and cruise control is related to it ..... if you hit pretty much any of the cruise control buttons it will make the engine stutter more or kill it and if you hold it down it turns off the engine.

what ya think?

02grandy is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 03-02-2013, 08:22 PM Thread Starter
02grandy
Senior Member
 
02grandy's Avatar
1999 XJ Cherokee 
 
Join Date: Mar 2011
Location: roseland
Posts: 661
i think its the clockspring i unplugged it and the idle and operation seems to be back to normal . i gas it and it comes back down to normal idle and stays there without surging and stuttering . oem or aftermarket clockspring is the next question
02grandy is offline  
post #3 of 5 Old 03-07-2013, 01:56 PM Thread Starter
02grandy
Senior Member
 
02grandy's Avatar
1999 XJ Cherokee 
 
Join Date: Mar 2011
Location: roseland
Posts: 661
just got new clockspring today from dorman off ebay.installed... good and bad news. the cruise control buttons dont kill the engine anymore like they didnt when i had it disconnected but they also dont light up on the dash to use them . expect almost once but its like its nonresponsive . the idle is steady instead of surging which is good . but high around 1000 rpm. when you put it in gear it comes down to normal idle. driving at idle it still 1000 rpm. the battery was disconected so i dont know if the mil has to reprogram itself. ive driven about 10 miles . there is still one code which is the p0121 which could be a couple things. ive only tried to earse it once so i will try again. i hope not a short.
02grandy is offline  
post #4 of 5 Old 03-07-2013, 11:10 PM
ultimo
Registered User
2002 WJ 
 
Join Date: Oct 2009
Location: Asia
Posts: 660
Quote:
Originally Posted by 02grandy View Post
i have another thread up related to this but seeing if this symptom alone has 100% fix. im having a rough idle problem and cruise control is related to it ..... if you hit pretty much any of the cruise control buttons it will make the engine stutter more or kill it and if you hold it down it turns off the engine.

what ya think?
You sure you werent driving your Ferrari? The ignition button is on the wheel too

Build Thread-- http://www.jeepforum.com/forum/f197/ultimos-build-1477712/
ultimo is offline  
post #5 of 5 Old 03-09-2013, 08:19 AM Thread Starter
02grandy
Senior Member
 
02grandy's Avatar
1999 XJ Cherokee 
 
Join Date: Mar 2011
Location: roseland
Posts: 661
ferrari is just got traded in for 2014 diesel grand lol
02grandy is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome