2002 grand 4.0l Cruise control buttons turn off/kills engine - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > 2002 grand 4.0l Cruise control buttons turn off/kills engine

Introducing MONSTALINERô UV Permanent DIY Roll On Bed LineRockridge 4WD IS Taking Zone Offroad Suspension Lift Kits Rough Country Jeep Suspension Deals at Rockridge 4WD!

Reply
Unread 03-02-2013, 06:25 PM   #1
02grandy
Member
 
02grandy's Avatar
1999 XJ Cherokee 
 
Join Date: Mar 2011
Location: roseland, NJ
Posts: 448
Wj 2002 grand 4.0l Cruise control buttons turn off/kills engine

i have another thread up related to this but seeing if this symptom alone has 100% fix. im having a rough idle problem and cruise control is related to it ..... if you hit pretty much any of the cruise control buttons it will make the engine stutter more or kill it and if you hold it down it turns off the engine.

what ya think?

02grandy is offline   Reply With Quote
Unread 03-02-2013, 08:22 PM   #2
02grandy
Member
 
02grandy's Avatar
1999 XJ Cherokee 
 
Join Date: Mar 2011
Location: roseland, NJ
Posts: 448
i think its the clockspring i unplugged it and the idle and operation seems to be back to normal . i gas it and it comes back down to normal idle and stays there without surging and stuttering . oem or aftermarket clockspring is the next question
02grandy is offline   Reply With Quote
Unread 03-07-2013, 01:56 PM   #3
02grandy
Member
 
02grandy's Avatar
1999 XJ Cherokee 
 
Join Date: Mar 2011
Location: roseland, NJ
Posts: 448
just got new clockspring today from dorman off ebay.installed... good and bad news. the cruise control buttons dont kill the engine anymore like they didnt when i had it disconnected but they also dont light up on the dash to use them . expect almost once but its like its nonresponsive . the idle is steady instead of surging which is good . but high around 1000 rpm. when you put it in gear it comes down to normal idle. driving at idle it still 1000 rpm. the battery was disconected so i dont know if the mil has to reprogram itself. ive driven about 10 miles . there is still one code which is the p0121 which could be a couple things. ive only tried to earse it once so i will try again. i hope not a short.
02grandy is offline   Reply With Quote
Unread 03-07-2013, 11:10 PM   #4
ultimo
Registered User
2002 WJ 
 
Join Date: Oct 2009
Location: Asia
Posts: 629
Quote:
Originally Posted by 02grandy View Post
i have another thread up related to this but seeing if this symptom alone has 100% fix. im having a rough idle problem and cruise control is related to it ..... if you hit pretty much any of the cruise control buttons it will make the engine stutter more or kill it and if you hold it down it turns off the engine.

what ya think?
You sure you werent driving your Ferrari? The ignition button is on the wheel too
__________________
Build Thread-- http://www.jeepforum.com/forum/f197/ultimos-build-1477712/
ultimo is offline   Reply With Quote
Unread 03-09-2013, 08:19 AM   #5
02grandy
Member
 
02grandy's Avatar
1999 XJ Cherokee 
 
Join Date: Mar 2011
Location: roseland, NJ
Posts: 448
ferrari is just got traded in for 2014 diesel grand lol
02grandy is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.