2000 WJ stalls out fuel tanks says empty - JeepForum.com

Reply
 
LinkBack Thread Tools
post #1 of 92 Old 08-06-2014, 11:01 PM Thread Starter
2000_JeepWJ_505
Registered User
2000 WJ 
 
Join Date: Aug 2014
Location: Albuquerque
Posts: 280
Wj 2000 WJ stalls out fuel tanks says empty

Hi, i have a 2000 Jeep Grand Cherokee V8 4.7L 4x4. I have been having random stall out problems. Ill be driving sometimes for 10 minutes or 2 hours, than my Jeep just stalls out. When i try to start it, it cranks real strong but wont turn over, plus my gas gauges says I'm on empty. I replaced my fuel pump, fuel filter, spark plugs, my oil pressure sensor and my battery. I just replaced my battery today. After i replaced it, my Jeep started strong and fast. I let it idle for about 15 minutes and it shut off. It didn't buck or shake, it just shut off like i shut it off?? I tried to start it and it started right up.. I took a drive for about 30 minutes and it shut off again on me. The first time I cranked it over it started, but my fuel gauges says I'm on empty. I know i had at least 4 gallons.. I then drove my Jeep home about 20 minutes away and it drove good other then my fuel gauges not working.. When i got home i shut it off and restarted it and the gauges worked fine! CAN ANYONE PLEASE HELP ME OUT!!!
THANKS


505 WJ SLICK
J.E.E.P. -Just Empty Every Pocket- J.E.E.P.
2000_JeepWJ_505 is offline  
Sponsored Links
Advertisement
 
post #2 of 92 Old 08-06-2014, 11:39 PM
new2site
Registered User
2002 WJ 
 
Join Date: Jan 2012
Location: Orange county
Posts: 1,058
These symptoms caused you to just recently install the new fuel pump??...or you installed it a few months ago and just now are getting symptoms? ...if the latter it could be a cheapy remanuf fuel pump already failing due to subpar overseas parts. --- double whammy - pump and sending unit going out.
Otherwise maybe the wiring / connection feeding them is in need of attention.
new2site is offline  
post #3 of 92 Old 08-06-2014, 11:45 PM Thread Starter
2000_JeepWJ_505
Registered User
2000 WJ 
 
Join Date: Aug 2014
Location: Albuquerque
Posts: 280
Wj

I only replaced my fuel pump and fuel filter because i was having this problem, my old fuel pump was probably good..

505 WJ SLICK
J.E.E.P. -Just Empty Every Pocket- J.E.E.P.
2000_JeepWJ_505 is offline  
post #4 of 92 Old 08-06-2014, 11:48 PM Thread Starter
2000_JeepWJ_505
Registered User
2000 WJ 
 
Join Date: Aug 2014
Location: Albuquerque
Posts: 280
Wj Infamous stall problems

I have been reading a lot of treads and it comes down to Cps, CKS or PCM, i took my jeep to a mechanic and he couldnt find anything wrong with anything, and he told me my PCM was kinda new, it wasn't 14 years old like my jeep is.. Im lost and in need of HELP

505 WJ SLICK
J.E.E.P. -Just Empty Every Pocket- J.E.E.P.
2000_JeepWJ_505 is offline  
post #5 of 92 Old 08-07-2014, 12:03 AM Thread Starter
2000_JeepWJ_505
Registered User
2000 WJ 
 
Join Date: Aug 2014
Location: Albuquerque
Posts: 280
Before i replaced my fuel pump and fuel filter i was stalling out randomly. Today 8-7-14 i replaced my battery and it run good but it still stalled out. It started on the first crank but my fuel gauges said i was on empty, and i know i had 1/4 tank,
Thanks for the help!

505 WJ SLICK
J.E.E.P. -Just Empty Every Pocket- J.E.E.P.
2000_JeepWJ_505 is offline  
post #6 of 92 Old 08-07-2014, 06:09 AM
86cj74.2L
Web Wheeler
 
86cj74.2L's Avatar
2004 WJ 
 
Join Date: Jul 2006
Location: Stouchsburg, PA
Posts: 9,863
If you have a reman PCM I don't hold much faith in them.
86cj74.2L is offline  
post #7 of 92 Old 08-07-2014, 08:53 AM Thread Starter
2000_JeepWJ_505
Registered User
2000 WJ 
 
Join Date: Aug 2014
Location: Albuquerque
Posts: 280
Wj

I dont know if the PCM was bought at Jeep or a after market?? Will the PCM say reman anywhere?? My gas gauges were messed up last night, when my Jeep shut off at the stop light my guage said i was on empty? Then my guages started working when i shut off my Jeep and restarted it.. ??? Ill drive around today at see what happens. When my Jeep stalled out, it started on the first crank, usually it would take anywhere between 5 minutes to 24 hours.. I dont know how to take off my PCM? I know i have to take off the coolant tank but the harness doesnt want to come off? Is there a certain way to take them off?? Thanks for replying and thanks for the Help! I appeticate everything..

505 WJ SLICK
J.E.E.P. -Just Empty Every Pocket- J.E.E.P.
2000_JeepWJ_505 is offline  
post #8 of 92 Old 08-08-2014, 01:06 PM
new2site
Registered User
2002 WJ 
 
Join Date: Jan 2012
Location: Orange county
Posts: 1,058
This guy was having same problem as you and just reported back that the problem WAS the PCM:

"OK here is a fallow up. Went ahead and took it to a shop for diagnoses turns out the pcm was shorting out internally. Some thing to do with auto shut off switch. Purchased a reman'd Cardone pcm. Got it programed after installing it and so far so good. "

Link: (Resolution comment on bottom of page 2):
http://www.jeepforum.com/forum/f310/...shuts-2558130/
new2site is offline  
post #9 of 92 Old 08-09-2014, 05:53 PM
perfeng702
Registered User
1999 WJ 
 
Join Date: Jul 2011
Location: Las Vegas
Posts: 153
I had similar issues. new pcm fixed it.

1999 WJ 4.7, 242HD, IRO 4" Long Arm, IRO Adj Track Bar, JKS BPE, JKS Quick Disco, 15" Cragar D-Window, 32" BFG KM2, V3 Projectors, DDM Tuning 55w 5k HIDs
perfeng702 is offline  
post #10 of 92 Old 08-09-2014, 06:20 PM
TURNER76
Registered User
1999 WJ 
 
Join Date: Jan 2014
Location: HAZARD
Posts: 607
Do you have any codes?
TURNER76 is offline  
post #11 of 92 Old 08-10-2014, 02:28 PM
Jeephulk
Registered User
2000 WJ 
 
Join Date: Aug 2014
Location: Dracut
Posts: 33
I got something very similar. The thing is though, I think the PCM resets after the stall and the codes are wiped. When i try to pull code with the key trick, it won't even display "DONE", until I'm able to start the engine again at that point, it will say "Done". Idk how to fix it, just putting it out there.
Jeephulk is offline  
post #12 of 92 Old 08-10-2014, 04:59 PM
perfeng702
Registered User
1999 WJ 
 
Join Date: Jul 2011
Location: Las Vegas
Posts: 153
Quote:
Originally Posted by Jeephulk View Post
I got something very similar. The thing is though, I think the PCM resets after the stall and the codes are wiped. When i try to pull code with the key trick, it won't even display "DONE", until I'm able to start the engine again at that point, it will say "Done". Idk how to fix it, just putting it out there.
this is exactly what mine did. new pcm fixed it.

http://www.jeepforum.com/forum/f310/...lling-1411942/

1999 WJ 4.7, 242HD, IRO 4" Long Arm, IRO Adj Track Bar, JKS BPE, JKS Quick Disco, 15" Cragar D-Window, 32" BFG KM2, V3 Projectors, DDM Tuning 55w 5k HIDs
perfeng702 is offline  
post #13 of 92 Old 08-10-2014, 06:13 PM
86cj74.2L
Web Wheeler
 
86cj74.2L's Avatar
2004 WJ 
 
Join Date: Jul 2006
Location: Stouchsburg, PA
Posts: 9,863
If it won't say done with the key dance then the PCM is temporally dead or the PCI buss is bad.
86cj74.2L is offline  
post #14 of 92 Old 08-12-2014, 08:20 PM Thread Starter
2000_JeepWJ_505
Registered User
2000 WJ 
 
Join Date: Aug 2014
Location: Albuquerque
Posts: 280
Wj

When i try to turn the key 3xs to read the codes it just says DONE, and when i stall out randomly ill try to turn the key 3xs and it doesnt work, it only displays the milage which is 162,300 miles.
*****Last night my Jeep died and i tired cranking it about 10-15 times, then my battery completely died! There was a constant clicking in my cluster panel. I just had my altornator checked and its good.. Ill probably have to get a new PCM i found a place called "Car Computer Exchange" does anyone know if there a good company?? Does anyone have any suggestions on where to buy a new PCM?

505 WJ SLICK
J.E.E.P. -Just Empty Every Pocket- J.E.E.P.
2000_JeepWJ_505 is offline  
post #15 of 92 Old 08-12-2014, 08:26 PM Thread Starter
2000_JeepWJ_505
Registered User
2000 WJ 
 
Join Date: Aug 2014
Location: Albuquerque
Posts: 280
Wj Any suggestions on where to buy a PCM?

Quote:
Originally Posted by perfeng702 View Post
this is exactly what mine did. new pcm fixed it.

http://www.jeepforum.com/forum/f310/...lling-1411942/
Where did u get the PCM? How much was it?
****THANK YOU TO EVERYONE WHO HAS REPLIED

505 WJ SLICK
J.E.E.P. -Just Empty Every Pocket- J.E.E.P.
2000_JeepWJ_505 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome