2000 jeep turn signal issues - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > 2000 jeep turn signal issues

ANOTHER Rockridge4wd Creation!! Spare Tire Carrier Delete The Original 3/8" Ruffstuff Diff Cover!Even Better Heim Pricing! From Ruffstuff

Reply
Unread 08-13-2010, 01:20 AM   #1
pagarciaz4
Registered User
 
Join Date: Aug 2010
Location: mcallen texas
Posts: 2
Wj 2000 jeep turn signal issues

Hi I just bought a 2000 Jeep Grande Cherokee and the turn signals works fine but when i turn on my brights the right hand turn siganl on the dash stays turned on and the actuall light is off. then when i turn off my brights and drive for a bite i get a warning on the command center thingy (that tells you your miles per gallons and what direction your going) that the right hand blink is still on and only when i turn on the left signal that it will go away. please help.

pagarciaz4 is offline   Reply With Quote Quick reply to this message
Unread 08-15-2010, 02:57 AM   #2
relgawly
Registered User
2010 WK 
 
Join Date: Sep 2006
Location: Boston, MA
Posts: 25
Jeeps usually give you a warning if you've left any turn signal on too long, it will beep on the command center, just turn of the turn signal, bring the arm back to the normal position. The problem seems to be with your turn signal, thats quite normal for the command center.
relgawly is offline   Reply With Quote Quick reply to this message
Unread 12-28-2010, 08:26 PM   #3
pacastro
Registered User
2011 WK 
 
Join Date: Aug 2008
Location: Chile
Posts: 6
Hi, i'm having the same problem with my Jeep: "Right turn signal on" warning on the EVIC... without any turn signal switched on...

Did you solve your problem??? if yes... how???

Thanks,

Pablo
pacastro is offline   Reply With Quote Quick reply to this message
Unread 09-26-2013, 10:58 PM   #4
wsrivers
Registered User
2000 WJ 
 
Join Date: Apr 2013
Location: Brooklyn, NY
Posts: 46
I'm having a similar issue only thing that's different is it started today while driving on the highway. I turned my hazards on quickly and turned them off. This turned the warning notification off temporarily. Wondering if this is a sensor going bad. Or could it have something to do with the LED conversion in the signal and parking lights.
wsrivers is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.