1999 WJ makes loud screeching when starting - JeepForum.com

 
LinkBack Thread Tools
post #1 of 2 Old 10-05-2013, 12:05 PM Thread Starter
eek142
Registered User
2015  
 
Join Date: Feb 2008
Location: NYC
Posts: 37
1999 WJ makes loud screeching when starting

The starter on our WJ died a few years ago and I replaced it with a part from Advance Auto. Lately, it has been making a loud screeching noise right after it starts. It only lasts for a split second, like the starter is sticking.

The other day, it stalled while waiting at a traffic light. It wouldn't even turn over when I tried to get it going again. After a few minutes, I gave it one more shot and it started. Now I know conventional wisdom says the starter has nothing to do with keeping a car running, but could something have shorted and caused the car to stall? I really want to say this was caused by the starter.

eek142 is offline  
Sponsored Links
Advertisement
 
post #2 of 2 Old 10-05-2013, 03:47 PM
snoWJ
Registered User
1999 WJ 
 
Join Date: Sep 2011
Location: Steamboat Springs
Posts: 81
Check your battery terminals, both Neg and Pos. take them off and clean the tops and make sure the connection is firm and clean. I've had issues with starting in the past where it wouldn't turn over but I would wiggle the battery terminals and it would come back to life. If youre on the east coast like me (30 miles off shore on an island) you get a lot of corrosion from salty air and salted roads so just keep everything clean. Good luck!
snoWJ is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome