1999 WJ fan issues, concerned its the fan modes malfunctioning..help? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WJ Grand Cherokee Forum > 1999 WJ fan issues, concerned its the fan modes malfunctioning..help?

FS: Wrangler RGB Multicolor Fog Light LEDs: Awesome EffectFS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitRockridge 4WD IS Taking Zone Offroad Suspension Lift Kits

Reply
Unread 08-23-2014, 02:27 PM   #1
RyanXVII
Registered User
1999 WJ 
 
Join Date: Aug 2014
Location: Edmonton, Alberta
Posts: 24
Wj 1999 WJ fan issues, concerned its the fan modes malfunctioning..help?

Hey guys, I'm new here but happy to find a dedicated forum to this vehicle.

I just got this vehicle last month, it's got 248k on it. Surprisingly when i took it in for a full inspection not much needed to be done in terms of repairs, just a blower motor needed replacing and some other minor fixes that are cheap and easy to do, other than that i love the vehicle so far.

Now i have this really weird problem happening, i've been doing an insane amount of research over the past couple days trying to figure out what may be the issue...I live in Edmonton, Alberta Canada so our winters get pretty cold and if there's one thing i need working properly it's the fan and temperature systems.

So here's what's got me stumped:
80% of the time i turn my fans on, they work as they should. the blend doors work, i get heat and AC on command and driver and passenger seem to work just fine. the recirc door also seems to be working as intended. Although the problem is, maybe 20% of the time or randomly throughout the day i will turn the fans on to the dashboard/foot area mode and i'll only get air from the foot area. as if the modes are getting confused or malfunctioning? which is concerning because I have the mode set to dashboard vents but it's blowing out the foot area instead. then i switched to another mode until the right vents were blowing, then switched back and it somehow cured itself, and sometimes it won't and for a long time too. and during the cold winters...this cannot happen especially before work in the mornings.

fortunately i did stumble across the blend door issues and recirc door issues, to my dismay none of those seem to be the issue. I've taken down the glovebox and checked to see if the recirc door was busted, it's still intact and seems to be operating as normal. the blend doors and actuators seem to be fine and working as intended.

the only thing i can think of at this point is, the board could be malfunctioning? it's not shooting air out of the right vents on the correct mode 20% of the time of my experiences. in fact as i was checking out the recirc door, it was working very well and then suddenly for about 30 seconds, the recirc door wouldn't respond to the button being on or off, then magically it started working again.

so at this point, i'm almost confident nothing is wrong with the fans or doors, but i have a good feeling the fan modes/board/electronics could be malfunctioning...any ideas on how i could further troubleshoot or fix this?

ps: i'd like to not have to take the dashboard apart, that just looks

if it's any help i have ran the diagnostic and it's giving me error numbers saying the blend doors are messing up, but that's not true at all, they do work just fine.

thanks in advance for any help/advice/solutions

RyanXVII is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.