1999 grand cherokee laredo 4wd problems - JeepForum.com
 
LinkBack Thread Tools
post #1 of 3 Old 02-06-2014, 12:09 PM Thread Starter
X275racer
Registered User
 
Join Date: Feb 2014
Location: Rochester
Posts: 2
1999 grand cherokee laredo 4wd problems

I recently bought a 99' grand cherokee laredo, knowing that the 4wd doesn't work. Well it's snowing a lot lately and would be nice to fix it. I know that when trying to put it in 4wd it makes a noise and just doesn't sound healthy. Possibly a stretched chain? Or what? Anything common with these? First timer. Please help thanks

X275racer is offline  
Sponsored Links
Advertisement
 
post #2 of 3 Old 02-06-2014, 12:12 PM
braddf
Registered User
2001 WJ 
 
Join Date: Aug 2012
Location: clinton
Posts: 854
what kind of four wheel drive do you have? Selec-trac, quadra drive? What does it say on the bezel thats going to help us help you.

Build thread: http://bit.ly/1puFzZm
Stock rims for sale: http://bit.ly/1kMw7k5
braddf is offline  
post #3 of 3 Old 02-06-2014, 12:39 PM Thread Starter
X275racer
Registered User
 
Join Date: Feb 2014
Location: Rochester
Posts: 2
Select-trac
X275racer is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome