JeepForum.com

JeepForum.com (http://www.jeepforum.com/forum/)
-   WJ Grand Cherokee Forum (http://www.jeepforum.com/forum/f310/)
-   -   04 jeep grand cherokee just dies (http://www.jeepforum.com/forum/f310/04-jeep-grand-cherokee-just-dies-1570379/)

cmberges 09-02-2013 12:46 PM

04 jeep grand cherokee just dies
 
So I have read about 30 threads and trying everything but the damn thing still dies.

Where to start? It an 04 limited V8 with about 180G on it. Sounds like a lot but the damn thing is perfect (excepting the dying issue). I turn the key and it fires right up and prss like a kitten.

I started driving it after I got it and went out 4wheeling, camping and general running around.....No issues.

Then one day it got really hot outside (about 110+) and I was driving with ac on full (not working well either) and it just died at a stop sign. All the gauges 0ed out and it seemed like it was out of gas. I was only down the block from my place so I went and got a gas can and pulled off the gas cap (no pressure) and then shoved the can hose into the tank and there was a ton of pressure. Got in the jeep and fired right up. Now what made me go hmmmmmmm is I put about half a gallon gas in and when I fired it up, I still have half a tank......

So now im wondering what it could be, no codes, no nothing. I went ahead and did some easy suggestions I found on this site (02 sensors, cps) that seems to help everyone else but not me.

I just replaced the cps and drove it down the street last night (cool and 80 outside) to the store and turned it off. Got back in and fired right up, drove home, backed it into it spot and put it in park.....died....again:mad::confused: I tried to fire it up and it just sits and turns (like its out of gas or something) and nothing on the gauges. Go out this morning and it fires right up.

I'm afraid to drive this thing very far as it acts up so sporadically I don't want to be stranded.

Now my mechanical level and knowledge, limited but can turn a wrench and watch you tube and pictures.....lmao

Just wondering if anyone has ANY suggestions on where to go next (besides a shop who would love to charge me hour after hour to figure it out). The jeep isn't worth that much money so sticking a ton into it doesn't seem really smart but.............

Thanks for any help you can offer, I NEED IT!!!!!!:cheers::cheers:

new2site 09-02-2013 01:45 PM

Fuel pump going out ...?

cmberges 09-02-2013 04:13 PM

I'm not really sure. When it drives its like a dream but then just dies. Would a dying fuel pump run good for 10-15 minutes then give up and run good again after about an hour?

I also tried something I read somewhere else about cycling the key on and off to get a code and nothing came up. Would an auto zone scan tell me if there are codes stored even if the check engine light didn't come on?

This thing is pissing me OFF!

new2site 09-02-2013 04:41 PM

I haven't dealt with a fuel pump going out on a Jeep but way back when one went out on another vehicle it worked sporadically before it completely gave out..
Maybe your PCM could be on the brink... symptoms match this too...sounds like more of your issue.
READ this thread to end:
http://www.jeepforum.com/forum/f310/...-help-1547063/

Just throwing out possibility's ..

cykaaro 09-02-2013 07:34 PM

I'm kinda curious that you took the cap off and there was no pressure, then there was. (other than thinking maybe gas cap needs replacing but will typically throw a code as my g/f's WJ did. Have you check fuel to the rail when it dies? Wondering if there's a drop in pressure so you're not getting fuel that cause it to stall.

rdkendrick 09-02-2013 07:40 PM

I was thinking PCM, too, after reading Zephyr's thread. Perhaps clean and reseat the connectors on the PCM?

Sent from my iPad using my fingers

cmberges 09-03-2013 09:13 AM

So im going to start trying a few things it mentioned in zephers thread and report back. Also how do I check the fuel to the rail? Like I said my skills are somewhat limited.....lol ;-)

cykaaro 09-03-2013 09:45 AM

Well, on the 4.0 on the front of the rail, there's a valve with a black cap on it to test for fuel pressure. Not sure about the 4.7, but would think it'd have something similar.

OffroadOran 09-03-2013 10:56 PM

Quote:

Originally Posted by cykaaro
Well, on the 4.0 on the front of the rail, there's a valve with a black cap on it to test for fuel pressure. Not sure about the 4.7, but would think it'd have something similar.

The OP may not have a rail with the black cap, my 04(with the 4.0) doesnt for whatever reason

cykaaro 09-03-2013 11:14 PM

Interesting. I've never seen a 4.0 without it.

OffroadOran 09-04-2013 06:36 AM

Quote:

Originally Posted by cykaaro
Interesting. I've never seen a 4.0 without it.

Yea i found that out when i went to check the fuel pressure since the jeep would not start. I couldnt find it and i thought i was looking in the wrong area, so i had my mechanic friend come over and he said it does not have one. I am the second owner so it could have been replaced before i bought it.

cykaaro 09-04-2013 04:49 PM

It is possible. When I come across an '04 will definitely check it out and see.

mckinjc 09-04-2013 07:47 PM

Could also be a clogged fuel filter or possibly a vacuum leak.

daniel78621 09-04-2013 08:05 PM

Mine was doing the same thing. I changed the crank shaft sensor it worked great.

cmberges 09-06-2013 03:23 PM

Quote:

Originally Posted by mckinjc (Post 15872960)
Could also be a clogged fuel filter or possibly a vacuum leak.

Remember im slow, how would I test a vacuum leak???
Thanks


The time now is 12:53 AM.

Powered by vBulletin Version 3.8.4
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.