Who's logged 10K trouble free miles? - Page 4 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK2 Grand Cherokee Forum > Who's logged 10K trouble free miles?

Want to be able to SEE? DOT Approved Headlights for under Coil Spring Options from Ruffstuff!Flush Mount LED Bumper Lights, CREE

Reply
Unread 07-28-2012, 09:38 PM   #46
nathantw
Registered User
2012 WK 
 
Join Date: Nov 2011
Location: San Francisco, CA
Posts: 171
Quote:
Originally Posted by ourlee View Post
Curious if anyone has driven 10K + miles without having to visit the dealer for a problem, big or small. I'm getting a diesel WK2 when they become available to tow our boat and I'd like to hear some positive feedback.

Rick
I didn't bring mine in until 17000 miles. It went in for the stupid vibrating glovebox and a smell. Both were never resolved. Other than that no problems.

nathantw is offline   Reply With Quote Quick reply to this message
Unread 07-29-2012, 03:45 AM   #47
GrantFromOz
Registered User
2012 WK 
 
Join Date: Jul 2012
Location: Adelaide, SA, Australia
Posts: 1
2012 Overland with 3.0 CRD (Export Model since I'm an Aussie). Only done about 8000 kms so far but no real problems. Minor hassle was a suspension noise caused by a loose bolt which was fixed under warranty when they also put in the Sat Nav accuracy fix (which was not a problem as far as I was concerned). Very happy with vehicle - the limited off road stuff I have done so far was fine. The sealed and unsealed road handling is excellent. I'm a former rusted on Toyota Land Cruiser fan and the only thing I am missing is the larger storage space but the handling is much much better! Also very pleased with the diesel engine - goes like a rocket and whilst technically I cant tell you about the emission the exhaust fumes are nothing like some older diesel's I've been near! The 28mpg economy also beats the you know what out of my old cruisers 16-18 mpg. Petrol here is ranges from $1.20 to $1.50 per litre and diesel around $1.40-$1.50 but I'm saving money!

1st post here by the way!
GrantFromOz is offline   Reply With Quote Quick reply to this message
Unread 07-29-2012, 06:24 AM   #48
Dannyboy83
Registered User
 
Join Date: Nov 2011
Location: Santander, Spain
Posts: 14
21k km so far and no issues. Running the diesel too, and mileage is absolutely amazing!
Dannyboy83 is offline   Reply With Quote Quick reply to this message
Unread 07-29-2012, 06:40 AM   #49
dmaccioc
Registered User
2011 WK 
 
Join Date: Aug 2011
Location: Brooklyn, NY
Posts: 49
15k miles Laredo X V6 not one problem. Oil changes and tire rotations only.
dmaccioc is offline   Reply With Quote Quick reply to this message
Unread 07-30-2012, 11:26 AM   #50
gdk927
Registered User
2012 WK 
 
Join Date: Dec 2011
Location: Ipswich, MA
Posts: 3
Just passed 10K this morning on the way to work. No issues at all.
gdk927 is offline   Reply With Quote Quick reply to this message
Unread 07-30-2012, 09:15 PM   #51
azjack
Registered User
2011 WK 
 
Join Date: Oct 2011
Location: tucson, AZ
Posts: 18
34000 miles on 2011 2 wheel

At 8000 miles a pin in the door latch broke, nothing since.
Jack of Tucson
azjack is offline   Reply With Quote Quick reply to this message
Unread 07-31-2012, 06:07 AM   #52
Fellows
Registered User
2011 WK 
 
Join Date: Aug 2011
Location: Summerville, South Carolina
Posts: 164
2011 2wd V6 Overland Summitt, 15k no issues.
Fellows is offline   Reply With Quote Quick reply to this message
Unread 07-31-2012, 08:47 AM   #53
Heroun
Registered User
2011 WK 
 
Join Date: Jan 2012
Location: Newton, Massachusetts
Posts: 2
Just turned 30,000 miles, not a single issue to report, it's been great. Routinely getting 19.6 to 20 mpg highway.
Heroun is offline   Reply With Quote Quick reply to this message
Unread 07-31-2012, 10:06 AM   #54
phos1
Registered User
 
Join Date: Mar 2012
Location: Milwaukee, wi
Posts: 17
2012 JGC with X package + tow and nav. 10K no issues.
phos1 is offline   Reply With Quote Quick reply to this message
Unread 09-18-2012, 09:27 PM   #55
ColoradoGrand
Registered User
2012 WK 
 
Join Date: Apr 2012
Location: Colorado Springs, Colorado
Posts: 53
Just hit 10 K this past week.

The only issues that I have experienced are:

Blue smoke when starting up after the engine is warm and the GC is parked on a hill. No oil consumption issues though.

Slight surging when cruising at highway speeds in 6th gear. I notice this when applying light throttle on a slight incline. I had an 06 Pacifica that exhibited similar symptoms albeit much worse.

I will wait until permanent solutions are available to correct both items.
ColoradoGrand is offline   Reply With Quote Quick reply to this message
Unread 09-18-2012, 09:37 PM   #56
MonteJeep
Registered User
2012 WK 
 
Join Date: Jan 2012
Location: , New York
Posts: 92
2012 Limited V6. Have 10,500 miles No problems...2 oil changes. Only complaint is 16.5 mpg but im starting to think its my driving...
__________________
2012 Grand Cherokee Limited - True Blue/Light Frost Interior - V6 Pentastar
MonteJeep is offline   Reply With Quote Quick reply to this message
Unread 09-18-2012, 11:02 PM   #57
toymandarrell
Registered User
 
Join Date: Jun 2012
Posts: 13
6500 v8 4x4. . Bad front stut and sway bar link . Replaced under warrenty.
toymandarrell is offline   Reply With Quote Quick reply to this message
Unread 09-19-2012, 01:34 AM   #58
Mike7680
Registered User
2011 WK 
 
Join Date: Mar 2005
Location: San Antonio, Texas
Posts: 21
Nearly 18K miles and no visits to the dealer. Routine service at 3, 6, 12, and 15K miles without drama. Will take care of the 18 and 24K service myself. The 30K service to take care of Hemi-specific items will go to dealer.
__________________
2000 Grand Cherokee Laredo
2006 Grand Cherokee Laredo
2011 Grand Cherokee Laredo X
Mike7680 is offline   Reply With Quote Quick reply to this message
Unread 09-19-2012, 10:06 AM   #59
kkreit01
Registered User
2011  
 
Join Date: Dec 2011
Location: Olathe, KS
Posts: 633
Almost 11k in 10 months. 0 trips back to dealer except for free oil change. No ticking. I do have the clunky self-leveling shocks, but I can live with them until a real fix is found/made.
kkreit01 is offline   Reply With Quote Quick reply to this message
Unread 09-19-2012, 12:44 PM   #60
jgiuliani
Registered User
2012  
 
Join Date: Nov 2011
Location: Apex, NC
Posts: 108
So 7 of the last 15 posts reported issues ranging from a vibrating glove box, a smell, failed break lights, broken door latch, blue smoke, bad strut, to loose suspension bolts and clunky shocks. That's 45% of the last 15 posts with issues (big or small) as the OP stated.
jgiuliani is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.