uConnect 8.4AN 14.25.5 Issues - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK2 Grand Cherokee Forum > uConnect 8.4AN 14.25.5 Issues

The Cure for your Tie Rod Roll!FS: Wrangler RGB Multicolor Fog Light LEDs: Awesome EffectIntroducing MONSTALINER™ UV Permanent DIY Roll On Bed Line

Reply
Unread 02-28-2015, 01:17 PM   #1
Helios909
Registered User
2014 WK 
 
Join Date: Apr 2007
Location: Edmonton, AB
Posts: 23
uConnect 8.4AN 14.25.5 Issues

Not that the update helped any from what the vehicle came with, but I have searched these forums and not found the help I'm looking for. I'm wondering if anyone has found a solution to the system having many missing options (that the vehicle should have) from the uConnect menus. I have tried the factory reset option and this nullifies most options I have and I have to reload the latest update. I have a 2014 Overland built in September of 2013. Is this something that only the dealer can rectify? I also have the problem where I will set a default, and then within a few seconds the check-mark I have placed will disappear on a selected option (can't get my blind spot indicators to stay on in the options for example).

Missing options that should be available:

-entry/exit ride height options
-heated/ventilated seat auto-on options
-interior lighting options
-compass settings
-parksense volume settings

Interestingly after I did the update once it displayed the SRT logo and the menus were totally different. After a while it reverted to different appearances and settings. Additionally I had an "apps" icon instead of the system icon at one time, now that's gone as well. Anyway it seems like something isn't right - probably a dealer thing but they are quite useless most of the time so if there's any way to fix this I'd really appreciate your knowledge. Thanks.

Helios909 is offline   Reply With Quote Quick reply to this message
Unread 02-28-2015, 01:21 PM   #2
ksavona
Registered User
2001 XJ Cherokee 
 
Join Date: Feb 2015
Location: White Lake, MI
Posts: 1
Hi my name is Karl....I own a 2001 jeep grand cherokee ltd...I am wondering if anyone has put coil over load adjusting shocks on theres and what that requires.....is it nessesary for more aggressive tire tread...dont really want to lift the truck????
ksavona is offline   Reply With Quote Quick reply to this message
Unread 02-28-2015, 07:47 PM   #3
SouthDakota
Member
 
SouthDakota's Avatar
2014 WK 
 
Join Date: Aug 2010
Location: Sioux Falls, SD
Posts: 291
Helios909: Something definitely not right that a dealership will most likely have to fix, especially if still under warranty. Your display should not change from startup to startup, not to mention this missing options. I've performed two software updates on ours so far at different times, and each time the software looked identical. The only thing I noticed that changed with ours was that originally, our backup camera was having some stuttering, and the latest update solved that.

ksavona: This is the section of the forum for 2011+ Grand Cherokees (WK2). You'd be better off starting a new thread or searching the threads for 1999-2004 Grand Cherokees, and changing your model on your profile to Grand Cherokee (it currently says 2001 XJ Cherokee, which is a different vehicle). Maybe a moderator can move it there for you.
__________________
-Jason

2014 Jeep Grand Cherokee Limited 4x4
5.7L Hemi V8, Luxury Group II, Navigation
SouthDakota is offline   Reply With Quote Quick reply to this message
Unread 03-02-2015, 06:37 AM   #4
JeepCACares
Member
 
Join Date: Oct 2014
Location: Windsor, Ontario
Posts: 267
Quote:
Originally Posted by Helios909 View Post
Not that the update helped any from what the vehicle came with, but I have searched these forums and not found the help I'm looking for. I'm wondering if anyone has found a solution to the system having many missing options (that the vehicle should have) from the uConnect menus. I have tried the factory reset option and this nullifies most options I have and I have to reload the latest update. I have a 2014 Overland built in September of 2013. Is this something that only the dealer can rectify? I also have the problem where I will set a default, and then within a few seconds the check-mark I have placed will disappear on a selected option (can't get my blind spot indicators to stay on in the options for example).

Missing options that should be available:

-entry/exit ride height options
-heated/ventilated seat auto-on options
-interior lighting options
-compass settings
-parksense volume settings

Interestingly after I did the update once it displayed the SRT logo and the menus were totally different. After a while it reverted to different appearances and settings. Additionally I had an "apps" icon instead of the system icon at one time, now that's gone as well. Anyway it seems like something isn't right - probably a dealer thing but they are quite useless most of the time so if there's any way to fix this I'd really appreciate your knowledge. Thanks.
Helios909,

I'm sorry to hear about your Uconnect concern. I agree with SouthDakota, the symptoms you're describing should be examined by your Jeep dealer. If there is an issue with your system, a diagnosis will determine the root cause. Demonstrating the symptoms for the service dept. would be of benefit as well.

Dave P.
Top Care Specialist
FCA Canada
JeepCACares is offline   Reply With Quote Quick reply to this message
Unread 03-02-2015, 07:02 AM   #5
lurtonk
Drive it like u stole it
2015 WK 
 
Join Date: Dec 2014
Location: Ridgetop, Tn
Posts: 361
There is a uConnect update 14.47.1 available
lurtonk is offline   Reply With Quote Quick reply to this message
Unread 03-02-2015, 07:55 AM   #6
Rdrakea
Registered User
2011 WK 
 
Join Date: Aug 2011
Location: Atlanta, Ga
Posts: 77
Quote:
Originally Posted by lurtonk View Post
There is a uConnect update 14.47.1 available
I'm guessing this is available only via dealers at the time? I still show 14.25.05 on the Uconnect site.

Edit: Never mind. 14.47.1 is only for MY15.
Rdrakea is offline   Reply With Quote Quick reply to this message
Unread 03-02-2015, 04:22 PM   #7
MattXJ
Registered User
2014 WK 
 
Join Date: Oct 2003
Location: Canada
Posts: 281
Is it typical that they stop releasing software updates for Uconnect once the model year has passed, even if the unit remains the same in the current MY?
__________________
89 XJ (Ltd): RE 3.5", full leafs, 3/4" coil spacers, RE monotubes, JKS Adj trac, tcase drop, OME steering stab., BFG AT 31x10.5xR15s on 15x8 3.75bs, Borla cat-back
14 WK2 SRT: DiabloSport catch can, Borla S-Type
MattXJ is offline   Reply With Quote Quick reply to this message
Unread 03-02-2015, 10:42 PM   #8
14summithemi
Web Wheeler
2014 WK 
 
Join Date: Sep 2013
Location: Bay Village, OHIO
Posts: 1,391
Quote:
Originally Posted by MattXJ View Post
Is it typical that they stop releasing software updates for Uconnect once the model year has passed, even if the unit remains the same in the current MY?
An important question for those of us who plan on keeping them until near dead.
14summithemi is offline   Reply With Quote Quick reply to this message
Unread 03-03-2015, 01:06 AM   #9
n666z
Registered User
 
Join Date: May 2011
Location: Melville, New York
Posts: 92
The unit is no longer the same. MY15 Uconnect 8.4a and 8.4an had hardware changes making them incompatible with MY14 firmware. MY14's cannot update to MY15 firmware because of the hardware difference.
n666z is offline   Reply With Quote Quick reply to this message
Unread 03-03-2015, 05:53 PM   #10
Tweezer19
Registered User
2014 WK 
 
Join Date: Apr 2014
Location: , Colorado
Posts: 94
Quote:
Originally Posted by MattXJ View Post
Is it typical that they stop releasing software updates for Uconnect once the model year has passed, even if the unit remains the same in the current MY?
I hope not. I would really, really love to see breadcrumbs added to music browsing. With today's device storage sizes music libraries can be very large. It's a pain having to browse the entire library each time you want to change to a different album of an artist already playing. I want to be able to click the "back" button and back out to the previous level.
Tweezer19 is offline   Reply With Quote Quick reply to this message
Unread 03-04-2015, 11:39 PM   #11
ChrisCicc
Registered User
 
Join Date: Jan 2014
Location: Boston, MA
Posts: 45
Quote:
Originally Posted by n666z View Post
The unit is no longer the same. MY15 Uconnect 8.4a and 8.4an had hardware changes making them incompatible with MY14 firmware. MY14's cannot update to MY15 firmware because of the hardware difference.
The versioning indicates otherwise.

I'm still upset that after 14 months, I don't have my promised turn-by-turn instructions in the instrument cluster. They only show up in the center console. Jeep told me it should be there, promised me a software update to fix it, and it never came.
ChrisCicc is offline   Reply With Quote Quick reply to this message
Unread 03-10-2015, 12:02 PM   #12
Helios909
Registered User
2014 WK 
 
Join Date: Apr 2007
Location: Edmonton, AB
Posts: 23
No update for my 2014 on uConnect website past 14.25.5. Took it to the dealership, and they said there are a bunch of "new flashes" that "may" fix the issues. They wouldn't even listen to what I had to say about it as they said these might be fixed, and if it isn't fixed (after they do the flashes and return the vehicle) I can bring it in again and have them look at it again. No one I talked to in the service department said they knew anything about this type of issue - they all scratched their heads (typical). Might be a multi-service endeavour to get this fixed, but I expect nothing less from dealerships.
Helios909 is offline   Reply With Quote Quick reply to this message
Unread 03-10-2015, 05:55 PM   #13
MattXJ
Registered User
2014 WK 
 
Join Date: Oct 2003
Location: Canada
Posts: 281
Keep us posted, I'm particularly interested because you are in Canada as well, and our dealerships here seem to have access to only a subset of TSBs and "flashes" (as they're calling them) compared to our US friends. Or at very least we seem to get them much later than when they're released south of the border.


Did they say specifically they had software updates available for Uconnect beyond what we can download ourselves, or are they referring to other updates?


14.25.5 is the latest available for my 2014 as well, on the website.
__________________
89 XJ (Ltd): RE 3.5", full leafs, 3/4" coil spacers, RE monotubes, JKS Adj trac, tcase drop, OME steering stab., BFG AT 31x10.5xR15s on 15x8 3.75bs, Borla cat-back
14 WK2 SRT: DiabloSport catch can, Borla S-Type
MattXJ is offline   Reply With Quote Quick reply to this message
Unread 03-11-2015, 08:16 AM   #14
Jurassic_Jeep
Registered User
2014 WK 
 
Join Date: Nov 2014
Location: Edmonton, Alberta
Posts: 104
im also interested in knowing whether an update is available to make those features present (or perhaps some who has those features could tell me where to look for them?). I have 14.25.05 also

It could be a US Vs. Canada version as I'm still baffled that we don't have internet/apps.

edit: meant to say I have 14.25.5

Last edited by Jurassic_Jeep; 03-11-2015 at 08:18 AM.. Reason: version number
Jurassic_Jeep is offline   Reply With Quote Quick reply to this message
Unread 03-11-2015, 11:14 AM   #15
lurtonk
Drive it like u stole it
2015 WK 
 
Join Date: Dec 2014
Location: Ridgetop, Tn
Posts: 361
Wk

Quote:
Originally Posted by ChrisCicc View Post
The versioning indicates otherwise.

I'm still upset that after 14 months, I don't have my promised turn-by-turn instructions in the instrument cluster. They only show up in the center console. Jeep told me it should be there, promised me a software update to fix it, and it never came.
I am not very impressed with the Nav turn indicator in the instrument cluster.
It is just a picture of a road with a big orange arrow bending to the left or the right.
It is the same thing that is at the top left of the Nav screen, just bigger.
As soon as you turn, the display reverts back to the previous monitor screen, TP, oil life, oil pressure......
lurtonk is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.