Tranny "Kick" when not letting car warm up from cold start - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK2 Grand Cherokee Forum > Tranny "Kick" when not letting car warm up from cold start

FS: Wrangler RGB Multicolor Fog Light LEDs: Awesome EffectSavvy Aluminum Gas Tank SkidFS: 2007-2013 Jeep Wrangler "HALO" Angel Eye Kit

Reply
Unread 02-20-2013, 09:27 AM   #1
mortifer
Registered User
2011 WK 
 
Join Date: Jan 2011
Location: Saint Louis, MO
Posts: 33
Tranny "Kick" when not letting car warm up from cold start

I have noticed that if I start the Jeep and attempt to put it in gear (Drive or Reverse) without giving the car 15-30 seconds to warm up, it will take 1-3 seconds before fully engaging the gear and give a fairly violent kick when fully engaged. It drives fine after this kick. If I let the car idle for 30 seconds or more it goes into gear without a fuss.

I know there are multiple complaints and TSBs on the WK2 transmission - is there one that specifically addresses this issue? I have a 2011 Overland with 5.7L Hemi.

Thanks guys!

mortifer is offline   Reply With Quote
Unread 02-20-2013, 01:47 PM   #2
avalys
Registered User
2014 JK Wrangler 
 
Join Date: Jan 2012
Location: Colorado Springs, CO
Posts: 100
Yes, mine does this too, sometimes. I sort of like it. It reminds me I am operating a real machine and not playing some kind of video game.
avalys is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.