T Stat issue on 2011 Jeep grand Cherokee - JeepForum.com

 
LinkBack Thread Tools
post #1 of 9 Old 11-19-2014, 08:41 AM Thread Starter
kidkotic2001
Registered User
2011 WK 
 
Join Date: May 2013
Location: El Paso
Posts: 49
Wk T Stat issue on 2011 Jeep grand Cherokee

Hello Everyone,

My wife was driving our 2011 Jeep and said that she noticed the check engine light or an orange light (lol). She took it to O'rilies and they gave her an error code P0128 seems to be the T stat. I didint look at it since it was night already. I will check to make sure that there is coolant today and check for leaks but if not should I just replace the Thermostat. The jeep does have about 76k on it we travel a lot in it, also has anybody done it and is it hard to do. I am pretty sure I will have to make sure I take out any air pockets. Any help with this would be great.

Thank you in advance.

kidkotic2001 is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 11-19-2014, 11:04 AM Thread Starter
kidkotic2001
Registered User
2011 WK 
 
Join Date: May 2013
Location: El Paso
Posts: 49
Anyone ?
kidkotic2001 is offline  
post #3 of 9 Old 11-19-2014, 12:39 PM
GreatDaneLvr
Registered User
2011 WK 
 
Join Date: Jul 2014
Location: Nashville
Posts: 287
Got a 3.6 or 5.7? And did the vehicle run hot? Also, is the heat working?

2011 JGC Overland Summit Rugged Brown/Saddle OFII 5.7 HEMI
GreatDaneLvr is offline  
post #4 of 9 Old 11-19-2014, 02:32 PM Thread Starter
kidkotic2001
Registered User
2011 WK 
 
Join Date: May 2013
Location: El Paso
Posts: 49
Its the 3.6 not running hot did not ask about heater.
kidkotic2001 is offline  
post #5 of 9 Old 11-19-2014, 03:07 PM Thread Starter
kidkotic2001
Registered User
2011 WK 
 
Join Date: May 2013
Location: El Paso
Posts: 49
To answer yes heater and ac work. Coolant temp stays constant 185
kidkotic2001 is offline  
post #6 of 9 Old 11-19-2014, 03:12 PM Thread Starter
kidkotic2001
Registered User
2011 WK 
 
Join Date: May 2013
Location: El Paso
Posts: 49
Coolant levels are good to reservoir is good to. Oils is nice and brown just changed about a month ago. It's not milky so I ruled out headphones leak
kidkotic2001 is offline  
post #7 of 9 Old 11-19-2014, 06:03 PM
Fastback89
Registered User
2015 WK 
 
Join Date: Oct 2014
Location: Media
Posts: 30
Thermostat is opening too early and engine temps are too cool, I get a lot of those codes this time of year
Fastback89 is offline  
post #8 of 9 Old 11-19-2014, 06:08 PM
GreatDaneLvr
Registered User
2011 WK 
 
Join Date: Jul 2014
Location: Nashville
Posts: 287
Yep, I would just change out the stat.

2011 JGC Overland Summit Rugged Brown/Saddle OFII 5.7 HEMI
GreatDaneLvr is offline  
post #9 of 9 Old 11-19-2014, 09:08 PM Thread Starter
kidkotic2001
Registered User
2011 WK 
 
Join Date: May 2013
Location: El Paso
Posts: 49
I will change it this weekend. Thank You guys for the help
kidkotic2001 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome