Starting issues? 2012 Summit - taking several tries to engage starter, bad battery? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK2 Grand Cherokee Forum > Starting issues? 2012 Summit - taking several tries to engage starter, bad battery?

Bds fox ipf 2.0 racing series shocks now available at rockThe Original 3/8" Ruffstuff Diff Cover!Ruffstuff Axle Simple Swap Kit!

Reply
Unread Today, 08:24 AM   #1
shudog
Registered User
2012 WK 
 
Join Date: Nov 2004
Posts: 345
Starting issues? 2012 Summit - taking several tries to engage starter, bad battery?

Last 2 weeks my Jeep has not started when I push the brake & hit the "start" button. Takes 3-4 attempts to cycle through the on/off, start, off & retry before it finally tries to start. When the engine turns over, it always starts but it's just not engaging the starter. I think this little heat wave we are experiencing is killing the battery. Jeep is a 2012 with 60k miles, original battery. Thoughts?

What's everyone suggest for a battery?

__________________
Previously owned jeeps:
'06 Grand Cherokee Limited w/4.7L V8 & QD2
'98 Grand Cherokee Limited w/5.2L V8 & Quadra Trac - sold at 230k miles
shudog is offline   Reply With Quote Quick reply to this message
Unread Today, 11:03 AM   #2
wyat72
Registered User
2011 WK 
 
Join Date: Dec 2014
Location: Sioux City, Iowa
Posts: 202
Sounds like the TIPM is starting to fail. Has the recall been performed?
__________________
2011 Grand Cherokee Laredo X, Pentastar, Qudra Trac I.
wyat72 is offline   Reply With Quote Quick reply to this message
Unread Today, 01:43 PM   #3
MidLifeinMI
Registered User
2012 WK 
 
Join Date: Jun 2015
Location: West Bloomfield, MI
Posts: 9
Don't think it's the TIPM, since the engine *will* crank with that issue (just won't get any fuel). Sounds like it's likely the battery. When it fails to start, does it do anything at all when you press the start button? Any noise?
__________________
2012 GC Limited, 3.6L, QuadraTrac II
MidLifeinMI is offline   Reply With Quote Quick reply to this message
Unread Today, 05:43 PM   #4
wyat72
Registered User
2011 WK 
 
Join Date: Dec 2014
Location: Sioux City, Iowa
Posts: 202
Quote:
Originally Posted by MidLifeinMI View Post
Don't think it's the TIPM, since the engine *will* crank with that issue (just won't get any fuel). Sounds like it's likely the battery. When it fails to start, does it do anything at all when you press the start button? Any noise?
Yep, I agree. I didn't read his thread close enough.
__________________
2011 Grand Cherokee Laredo X, Pentastar, Qudra Trac I.
wyat72 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.