Need head replaced Again! - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK2 Grand Cherokee Forum > Need head replaced Again!

ARTEC JK UNDER ARMOR - 4 door Bellypan KitsPoison Spyder DeFender Inner Fender KitsCess Recovery Gear Snatch Tow Strap OffRoad @ ROCKRIDGE4WD

Reply
Unread 06-17-2013, 11:03 AM   #1
Mopar4Life2k12
Registered User
2012  
 
Join Date: Jun 2013
Location: Whitinsville, MA
Posts: 4
Need head replaced Again!

My 2012 Grand Cherokee is at the dealer now for it's second head(same side as the first), this happen to anyone else? The dealer said they are on their 3rd re-design for the heads.

Mopar4Life2k12 is offline   Reply With Quote
Unread 06-17-2013, 10:07 PM   #2
Texasreb
Registered User
2013 WK 
 
Join Date: Jan 2013
Location: San Antonio, Texas
Posts: 7
I would start checking for yellow primer...
Texasreb is offline   Reply With Quote
Unread 06-18-2013, 08:20 AM   #3
kkreit01
Registered User
2011  
 
Join Date: Dec 2011
Location: Olathe, KS
Posts: 538
Oh my. Good luck. Ours is still running great, but we're still under 20k miles.
kkreit01 is offline   Reply With Quote
Unread 06-18-2013, 12:33 PM   #4
WvTaco
Registered User
2011 WK 
 
Join Date: Apr 2011
Location: Logan, Wv
Posts: 493
Quote:
Originally Posted by Texasreb View Post
I would start checking for yellow primer...
used cars?





not an issue for mine either.
what was the symptoms this time?
WvTaco is offline   Reply With Quote
Unread 06-18-2013, 01:53 PM   #5
Dabitz
Registered User
2011  
 
Join Date: Aug 2006
Location: NJ
Posts: 400
Mine happened at 45K miles, oh boy! Now I'm nervous. It runs smooth like butter now though.
Dabitz is offline   Reply With Quote
Unread 06-18-2013, 04:49 PM   #6
Mopar4Life2k12
Registered User
2012  
 
Join Date: Jun 2013
Location: Whitinsville, MA
Posts: 4
Same symptoms as when it happened the first time. Dropped it off Monday morning without an appointment and had it back by 5pm! Running like a champ again(for a year anyway! lol)
Mopar4Life2k12 is offline   Reply With Quote
Unread 06-19-2013, 08:20 AM   #7
zr2s10
Registered User
2012 WK 
 
Join Date: Feb 2012
Location: Butler, PA
Posts: 189
I take it this is the 3.6? And that's pretty impressive that your dealer can swap out a head that fast, with no appt. The ones around here aren't that good, lol. Of course, practice makes perfect, and this is a known issue.
zr2s10 is offline   Reply With Quote
Unread 06-19-2013, 09:59 AM   #8
Mopar4Life2k12
Registered User
2012  
 
Join Date: Jun 2013
Location: Whitinsville, MA
Posts: 4
3.6, The dealer said they have had a lot of practice!
Mopar4Life2k12 is offline   Reply With Quote
Unread 06-19-2013, 12:37 PM   #9
nyrhockey23
Registered User
 
Join Date: Feb 2011
Location: , ct
Posts: 210
Quote:
Originally Posted by Dabitz View Post
Mine happened at 45K miles, oh boy! Now I'm nervous. It runs smooth like butter now though.
was it covered by warranty even though it was past the 3/36 period? if not, how much was it?

Our '12 Laredo already had the replacement but concerned it may happen again (like with the OP) after the warranty period is over.
nyrhockey23 is offline   Reply With Quote
Unread 06-19-2013, 12:40 PM   #10
zr2s10
Registered User
2012 WK 
 
Join Date: Feb 2012
Location: Butler, PA
Posts: 189
Quote:
Originally Posted by nyrhockey23 View Post
was it covered by warranty even though it was past the 3/36 period? if not, how much was it?

Our '12 Laredo already had the replacement but concerned it may happen again (like with the OP) after the warranty period is over.
Powertrain is 5/100, isn't it?
zr2s10 is offline   Reply With Quote
Unread 06-19-2013, 01:59 PM   #11
nyrhockey23
Registered User
 
Join Date: Feb 2011
Location: , ct
Posts: 210
Quote:
Originally Posted by zr2s10 View Post
Powertrain is 5/100, isn't it?
Good point. I guess i need to better understand what "powertrain" entails.
nyrhockey23 is offline   Reply With Quote
Unread 06-19-2013, 09:10 PM   #12
Chris9674T
Registered User
2011 WK 
 
Join Date: Mar 2013
Location: Western Mass.
Posts: 18
When was your first replacement? Mine was done last October at 16k miles...
Chris9674T is offline   Reply With Quote
Unread 06-20-2013, 01:14 AM   #13
Mopar4Life2k12
Registered User
2012  
 
Join Date: Jun 2013
Location: Whitinsville, MA
Posts: 4
First one was done around 18k and 2nd around 34k.
Mopar4Life2k12 is offline   Reply With Quote
Unread 06-20-2013, 05:20 AM   #14
zr2s10
Registered User
2012 WK 
 
Join Date: Feb 2012
Location: Butler, PA
Posts: 189
Man, I hope we don't have any issues! Ours is a 2012, but I think the build date was later than the suspected problem ones. Of course, that's if they really fixed the problem in the later builds, lol.
zr2s10 is offline   Reply With Quote
Unread 06-20-2013, 08:34 AM   #15
MickinNY
Registered User
2013 WK 
 
Join Date: Sep 2012
Location: Churchville, NY
Posts: 479
Quote:
Originally Posted by zr2s10 View Post
Man, I hope we don't have any issues! Ours is a 2012, but I think the build date was later than the suspected problem ones. Of course, that's if they really fixed the problem in the later builds, lol.
Mines a '13 & I'm wondering the same thing about the fix. I guess only time will tell on that, along with the long term reliability of the Pentastar. (fingers crossed) But I'm not laughing.
MickinNY is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.