Key detection problem - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK2 Grand Cherokee Forum > Key detection problem

Halloween Savings to die for!The Original 3/8" Ruffstuff Diff Cover!The Ruffstuff NOT Universal 4 Link Kit!

Reply
Unread 08-09-2011, 03:25 PM   #1
GatorMike
Registered User
2011 WK 
 
Join Date: Jun 2008
Location: FL
Posts: 8
Key detection problem

Have had about 4 instances in the past week where a passenger opens the door with the Jeep running and then I get the message that the Key has left the vehicle, when it has not. After opening and closing both the passenger and driver side doors a couple of times I've been able to clear the message. Any idea what's causing this? Thanks in advance!

GatorMike is offline   Reply With Quote Quick reply to this message
Unread 08-09-2011, 06:12 PM   #2
JoeSchmoe007
Registered User
 
Join Date: Sep 2010
Location: New York
Posts: 148
I had exactly the same problem once. Also had "key is not detected" when trying to start the car multiple times.

There is TSB that I hope will fix this - I plan to get it done:

http://www.wk2jeeps.com/tsb/tsb_wk2_0802411a.pdf
JoeSchmoe007 is offline   Reply With Quote Quick reply to this message
Unread 08-10-2011, 01:33 PM   #3
GatorMike
Registered User
2011 WK 
 
Join Date: Jun 2008
Location: FL
Posts: 8
Greatly appreciate the info! Anybody found another way to clear this message, other than opening and closling the doors?
GatorMike is offline   Reply With Quote Quick reply to this message
Unread 08-28-2011, 04:02 PM   #4
rlj
Registered User
 
Join Date: Jun 2006
Location: Atlanta
Posts: 446
Mine did this a few months back, dealer ordered a new key and issue was solved. It's a key issue.
__________________
"The problem with socialism is that eventually, you run out of other people's money."

2011 Jeep Grand Cherokee Overland
2007 Jeep Wrangler Sahara Unlimited
3.25" Rough Country lift
Nitto Trail grapplers 35-12.50R 17
AEV Pintler 17x9 Silver Wheels
AirAid CAI
Superchips @ 93 Tune
and a bunch of other stuff......
rlj is offline   Reply With Quote Quick reply to this message
Unread 08-28-2011, 08:19 PM   #5
hur1ey02
Registered User
2011 WK 
 
Join Date: Mar 2010
Location: Abingdon, VA, Virginia
Posts: 167
hit unlock on your fob.. that always recognizes it for me.
__________________
Current - 2011 WK2 Laredo X (Inferno Red)
2013 Scion FR-S (Raven Black)
Past - 2008 JK Unlimited Sahara (Black)
2004 TJ RME (Flame Red)
hur1ey02 is offline   Reply With Quote Quick reply to this message
Unread 09-01-2011, 06:42 PM   #6
mchassler
Registered User
2011 WK 
 
Join Date: Dec 2010
Location: Harford County, MD
Posts: 118
I switched key fobs when it started to not recognize... I'd be in the car with the key in my hand and it would indicate that it wasn't detected.
mchassler is offline   Reply With Quote Quick reply to this message
Unread 10-07-2011, 08:19 PM   #7
rudeney
Registered User
2014 WK 
 
Join Date: Sep 2011
Location: Birmingham, AL
Posts: 144
Last Sunday, after our first week of ownership, my wife called while out shopping and said the Jeep wouldn't start. The message "key not detected" was on the MFD, even though the key was in her purse on the passenger seat. She tried placoing the key next to the START button, but no luck. I told her to use the fob to lock and unlock the doors and that triggered it to work. Then, every other day, this same thing happened. Yesterday morning, it seemed nothing we did would get it to recognize the key to start. One time when pressing the START button, I saw the message "Remote start not possible" on the MFD. I finally did something to get it started and took it to the dealer. They kept it overnight and were able to duplicate the problem. They fixed it by reprogramming the keys and the car electronics. Oddly enough, ours is a June 2011 build, and the referenced bulletin above notes that it's only for April and earlier builds. I hope what they did was a permanent fix.
rudeney is offline   Reply With Quote Quick reply to this message
Unread 04-10-2013, 02:09 PM   #8
bobbyjo
Registered User
2011 XJ Cherokee 
 
Join Date: Apr 2013
Location: Thunder Bay, ON
Posts: 2
I have a 2011 Jeep Grand Cherokee and have problems with key recognition from day one when I purchased it brand new from the dealer. I consistantly have issues where the key is not recognized and a sensor says that the key has left the vehicle. Obviously it has not, and this happens while I am driving, in park, sitting at a light, etc. Now it has happened when using the remote start, I cannot enter the car or unlock the door, and once inside, the sensor goes off, with the alarm and I cannot turn the car off or get the alarm to stop for several minutes. I brought it to the dealer again (this is #8) and they say it is just the battery in my key fob. But they have the wrong key - this one wasn't the one we had in the car at the time. They have exchanged one key fob, reset the sensor numerous times, changed key battery and it keeps happening. I need help...any suggestions?
bobbyjo is offline   Reply With Quote Quick reply to this message
Unread 04-10-2013, 03:14 PM   #9
gabbagabba
Registered User
2014 WK 
 
Join Date: Jan 2013
Location: Southwest, NH
Posts: 391
Quote:
Originally Posted by bobbyjo View Post
I have a 2011 Jeep Grand Cherokee and have problems with key recognition from day one when I purchased it brand new from the dealer. I consistantly have issues where the key is not recognized and a sensor says that the key has left the vehicle. Obviously it has not, and this happens while I am driving, in park, sitting at a light, etc. Now it has happened when using the remote start, I cannot enter the car or unlock the door, and once inside, the sensor goes off, with the alarm and I cannot turn the car off or get the alarm to stop for several minutes. I brought it to the dealer again (this is #8) and they say it is just the battery in my key fob. But they have the wrong key - this one wasn't the one we had in the car at the time. They have exchanged one key fob, reset the sensor numerous times, changed key battery and it keeps happening. I need help...any suggestions?
go to a new dealer. I went through the same song and dance with my 2011, took it there like 5 times, and then took it somewhere else for an oil change and they fixed it on the spot. said the other guys did not reprogram it right? no issues since
gabbagabba is offline   Reply With Quote Quick reply to this message
Unread 04-11-2013, 10:19 PM   #10
SPL170db
Registered User
2011  
 
Join Date: Nov 2010
Location: Northern, NJ
Posts: 284
Goes without saying but in addition to the TSBs also be sure to keep a fresh battery in the fob
SPL170db is offline   Reply With Quote Quick reply to this message
Unread 04-24-2013, 09:15 AM   #11
Trespasser
Registered User
1999 TJ Wrangler 
 
Join Date: Dec 2012
Location: Hatboro, PA
Posts: 138
Also, don't forget you can pop the start button off and insert the key physically! I've had to do that on rare occasion when it glitches out.

My issue with Enter-N-Go is sometimes it takes 5 seconds to recognize I've left the car when I try to lock it from the outside button. I just stand there like an idiot hitting the button again and again until it locks. Dealer gave me a new set of keys a while back, but now that it has started up again and I'm out of warranty I just deal with it.
Trespasser is offline   Reply With Quote Quick reply to this message
Unread 04-27-2013, 06:29 PM   #12
tubbyzj
Registered User
1990 XJ Cherokee 
 
Join Date: Aug 2007
Location: staten island ny an NEPA
Posts: 316
Just happen to me the dealer had lost the keys so they programmed one key today I went to get my second key now the new key does work with the push button thank god I read on the thread about the button coming out an being able to start
__________________
Its an 87
tubbyzj is offline   Reply With Quote Quick reply to this message
Unread 04-27-2013, 06:29 PM   #13
tubbyzj
Registered User
1990 XJ Cherokee 
 
Join Date: Aug 2007
Location: staten island ny an NEPA
Posts: 316
But the remote works locks an unlocks an starts the car just doesn't work with push start or button on doors
__________________
Its an 87
tubbyzj is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.