iPhone 4 / UConnect issues - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK2 Grand Cherokee Forum > iPhone 4 / UConnect issues

Jeep Tweaks at JeepHutIntroducing MONSTALINER™ UV Permanent DIY Roll On Bed LineJeep speedometer gears at rockridge4wd

Reply
Unread 01-31-2011, 08:56 AM   #1
john3r
Registered User
2011 WK 
 
Join Date: Aug 2010
Location: Annapolis
Posts: 14
iPhone 4 / UConnect issues

I am not sure if this has already been discussed and/or solved, however i couldnt readily locate a thread thus I am starting this one....

It is a widely known issue that the iphone4 and uconnect system do not like each other. In my daily driving experience, I cannot jump in my car, call someone within the first few minutes of driving (since Uconnect is unsuccesfully trying to pair my phone book), and after the phone book pairing fails...(all while I cannot make/recieve phone calls)...the bluetooth icon finally appears. At this point in time a phone call works via bluetooth sometimes, sometimes doesnt work, and SOMETIMES works - then shuts off -which at that point I have to transfer the call to my phone...all while missing parts of conversation.

I know that was hard to follow, but i think we all get the point...there is a flaw that needs fixing asap. I'm sure I am not the only one of us who makes phone calls for work in our jeeps and gets pissed off that it is such brain-damage to use bluetooth with your iPhone (4).

Does anyone know if apple or uconnect has/is issuing a fix? I thought the iOS 4.2 firmware was going to fix it, but it did not.

Any thoughts are much appreciated!
Thanks in advance


And with that i will conclude the post with this cool avatar-thing

john3r is offline   Reply With Quote Quick reply to this message
Unread 02-04-2011, 01:40 AM   #2
hobbie1
Registered User
2011 WK 
 
Join Date: May 2010
Location: Brentwood CA
Posts: 215
Got the same issues with an iphone 4 - called Jeep - there is a software update coming..... you should call the 800 number and complain. There are other links on the site about all of the problems with I-phones I'm going to switch to the Sprint EVO
__________________
2011 Overland 4X4 QDII QLII 5.7 - Adventure II
2012 RAM 2500 Cummins 4X4 Laramie Crew Cab
2005 Mercedes C-240 4-Matic
2013 Ford Mustang GT and 1966 Ford Mustang 289 5-SPD 289
hobbie1 is offline   Reply With Quote Quick reply to this message
Unread 02-17-2011, 12:47 PM   #3
Aquaforest
Registered User
 
Join Date: Jan 2011
Location: , NY
Posts: 125
Just called Jeep Uconnect. Not very helpful just that apple and jeep are working on a solution. BTW they said the car will have to be brought into the dealer for the software update. Does that sound right?
Aquaforest is offline   Reply With Quote Quick reply to this message
Unread 02-17-2011, 01:34 PM   #4
boldd
Registered User
 
Join Date: Jan 2011
Location: Edmonton, AB
Posts: 67
Anyone try the Ipod Touch 4G? Is it working?
boldd is offline   Reply With Quote Quick reply to this message
Unread 02-17-2011, 02:56 PM   #5
charheep
Registered User
2011 WK 
 
Join Date: Sep 2010
Location: Aurora
Posts: 53
Not that it helps you , but my Nokia E71x works everytime, and each time. By the time I get out of garage I get the tone that it is connected to the Jeep and caller ID works each time, as well as voice dialing. I tested a Windows 7 phone for a week and it seemed to be working the same as the Nokia. Maybe Apple/Jeep will come out with a update soon.
charheep is offline   Reply With Quote Quick reply to this message
Unread 02-17-2011, 03:43 PM   #6
Dabitz
Registered User
2011  
 
Join Date: Aug 2006
Location: NJ
Posts: 428
Droid X works fine as well. The only thing is I would like the uconnect to stop requesting access to the phone contact list. My contact list is way to huge for the uconnect to handle and it freezes it. When it sends the requests it pauses the music which I am playing thru the phone's Pandora app.
Dabitz is offline   Reply With Quote Quick reply to this message
Unread 02-17-2011, 11:59 PM   #7
poomobile
Registered User
2011 WK 
 
Join Date: Jan 2011
Location: , Canada
Posts: 33
Here is your fix

http://www.mediafire.com/?84a1dbj587p70gv

If not working, go to the mygig forums and look for the thread for 2.402
poomobile is offline   Reply With Quote Quick reply to this message
Unread 02-18-2011, 12:11 AM   #8
hobbie1
Registered User
2011 WK 
 
Join Date: May 2010
Location: Brentwood CA
Posts: 215
Quote:
Originally Posted by poomobile View Post
Here is your fix

http://www.mediafire.com/?84a1dbj587p70gv

If not working, go to the mygig forums and look for the thread for 2.402
I assume this a patch that has not been released by Jeep. Have you installed this patch?
__________________
2011 Overland 4X4 QDII QLII 5.7 - Adventure II
2012 RAM 2500 Cummins 4X4 Laramie Crew Cab
2005 Mercedes C-240 4-Matic
2013 Ford Mustang GT and 1966 Ford Mustang 289 5-SPD 289
hobbie1 is offline   Reply With Quote Quick reply to this message
Unread 02-18-2011, 08:26 AM   #9
Aquaforest
Registered User
 
Join Date: Jan 2011
Location: , NY
Posts: 125
Stupid question, but how do you download the patch to the jeep.
Aquaforest is offline   Reply With Quote Quick reply to this message
Unread 02-18-2011, 08:44 AM   #10
webspoke
Registered User
2013  
 
Join Date: Jan 2011
Location: DFW, TX
Posts: 110
There are download, burning, and install instructions on the lower left menu here: http://www.mofv.com/mygig/


One thing I do see after the patch - phone book entries with the number classified under 'main' (instead of work, mobile, etc) will not dial out.
webspoke is offline   Reply With Quote Quick reply to this message
Unread 02-18-2011, 09:13 AM   #11
poomobile
Registered User
2011 WK 
 
Join Date: Jan 2011
Location: , Canada
Posts: 33
The patch linked is a copy of the disc that came direct from jeep. I installed it last week and it works perfect with my iPhone 4. Also stopped the acquiring signal message when listening to Sirius!

Just download file and burn to a cd. Windows 7 will do it automatically when you click on the file. After burn, just put in your disc slot and follow the prompts. Make sure the truck is running when you do it
poomobile is offline   Reply With Quote Quick reply to this message
Unread 02-18-2011, 09:41 AM   #12
Aquaforest
Registered User
 
Join Date: Jan 2011
Location: , NY
Posts: 125
Thanks for all those directions. From what I could tell so far, my Uconnect in my GC is working for phone calling in/out, but I noticed when I streamed music from my iphone it was all choppy. Do you know if that patch will fix this as well.
Aquaforest is offline   Reply With Quote Quick reply to this message
Unread 02-18-2011, 05:35 PM   #13
IRSmart
Registered User
2011 MK Compass 
 
Join Date: Feb 2011
Location: Westminster, MD
Posts: 1,078
just for clarification, this "patch" is ONLY for GC with the 730N radio (chrysler nav, radio code RER in the lower right corner of the radio), and NOT the 430N garmin nav (radio code RHB).
IRSmart is offline   Reply With Quote Quick reply to this message
Unread 02-18-2011, 06:47 PM   #14
LiquidOxygen
Registered User
 
Join Date: Feb 2011
Location: Edmonton, Canada
Posts: 60
Quote:
Originally Posted by IRSmart View Post
just for clarification, this "patch" is ONLY for GC with the 730N radio (chrysler nav, radio code RER in the lower right corner of the radio), and NOT the 430N garmin nav (radio code RHB).
This is correct
LiquidOxygen is offline   Reply With Quote Quick reply to this message
Unread 02-18-2011, 07:21 PM   #15
Aquaforest
Registered User
 
Join Date: Jan 2011
Location: , NY
Posts: 125
Quote:
Originally Posted by IRSmart View Post
just for clarification, this "patch" is ONLY for GC with the 730N radio (chrysler nav, radio code RER in the lower right corner of the radio), and NOT the 430N garmin nav (radio code RHB).
Thanks for clarifying. I would have been wasting my time with the patch since I have the 430N. BTW how do you find out what current version of the software you are currently running?
Aquaforest is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.