iPhone 4 / UConnect issues - JeepForum.com

Reply
 
LinkBack Thread Tools
post #1 of 37 Old 01-31-2011, 07:56 AM Thread Starter
john3r
Registered User
2011 WK 
 
Join Date: Aug 2010
Location: Annapolis
Posts: 14
iPhone 4 / UConnect issues

I am not sure if this has already been discussed and/or solved, however i couldnt readily locate a thread thus I am starting this one....

It is a widely known issue that the iphone4 and uconnect system do not like each other. In my daily driving experience, I cannot jump in my car, call someone within the first few minutes of driving (since Uconnect is unsuccesfully trying to pair my phone book), and after the phone book pairing fails...(all while I cannot make/recieve phone calls)...the bluetooth icon finally appears. At this point in time a phone call works via bluetooth sometimes, sometimes doesnt work, and SOMETIMES works - then shuts off -which at that point I have to transfer the call to my phone...all while missing parts of conversation.

I know that was hard to follow, but i think we all get the point...there is a flaw that needs fixing asap. I'm sure I am not the only one of us who makes phone calls for work in our jeeps and gets pissed off that it is such brain-damage to use bluetooth with your iPhone (4).

Does anyone know if apple or uconnect has/is issuing a fix? I thought the iOS 4.2 firmware was going to fix it, but it did not.

Any thoughts are much appreciated!
Thanks in advance


And with that i will conclude the post with this cool avatar-thing

john3r is offline  
Sponsored Links
Advertisement
 
post #2 of 37 Old 02-04-2011, 12:40 AM
hobbie1
Registered User
2015 WK 
 
Join Date: May 2010
Location: Brentwood
Posts: 465
Got the same issues with an iphone 4 - called Jeep - there is a software update coming..... you should call the 800 number and complain. There are other links on the site about all of the problems with I-phones I'm going to switch to the Sprint EVO

15 Summit 4X4 Eco Diesel
14 RAM 2500 Cummins 4X4 Laramie CC
13 Mustang GT
66 Mustang Cp - 306 5sp
hobbie1 is offline  
post #3 of 37 Old 02-17-2011, 11:47 AM
Aquaforest
Registered User
 
Join Date: Jan 2011
Posts: 144
Just called Jeep Uconnect. Not very helpful just that apple and jeep are working on a solution. BTW they said the car will have to be brought into the dealer for the software update. Does that sound right?
Aquaforest is offline  
post #4 of 37 Old 02-17-2011, 12:34 PM
boldd
Registered User
 
Join Date: Jan 2011
Location: Edmonton
Posts: 67
Anyone try the Ipod Touch 4G? Is it working?
boldd is offline  
post #5 of 37 Old 02-17-2011, 01:56 PM
charheep
Registered User
2011 WK 
 
Join Date: Sep 2010
Location: Aurora
Posts: 53
Not that it helps you , but my Nokia E71x works everytime, and each time. By the time I get out of garage I get the tone that it is connected to the Jeep and caller ID works each time, as well as voice dialing. I tested a Windows 7 phone for a week and it seemed to be working the same as the Nokia. Maybe Apple/Jeep will come out with a update soon.
charheep is offline  
post #6 of 37 Old 02-17-2011, 02:43 PM
Dabitz
Registered User
2015 WK 
 
Join Date: Aug 2006
Location: NJ
Posts: 531
Droid X works fine as well. The only thing is I would like the uconnect to stop requesting access to the phone contact list. My contact list is way to huge for the uconnect to handle and it freezes it. When it sends the requests it pauses the music which I am playing thru the phone's Pandora app.
Dabitz is offline  
post #7 of 37 Old 02-17-2011, 10:59 PM
poomobile
Registered User
2011 WK 
 
Join Date: Jan 2011
Posts: 33
Here is your fix

http://www.mediafire.com/?84a1dbj587p70gv

If not working, go to the mygig forums and look for the thread for 2.402
poomobile is offline  
post #8 of 37 Old 02-17-2011, 11:11 PM
hobbie1
Registered User
2015 WK 
 
Join Date: May 2010
Location: Brentwood
Posts: 465
Quote:
Originally Posted by poomobile View Post
Here is your fix

http://www.mediafire.com/?84a1dbj587p70gv

If not working, go to the mygig forums and look for the thread for 2.402
I assume this a patch that has not been released by Jeep. Have you installed this patch?

15 Summit 4X4 Eco Diesel
14 RAM 2500 Cummins 4X4 Laramie CC
13 Mustang GT
66 Mustang Cp - 306 5sp
hobbie1 is offline  
post #9 of 37 Old 02-18-2011, 07:26 AM
Aquaforest
Registered User
 
Join Date: Jan 2011
Posts: 144
Stupid question, but how do you download the patch to the jeep.
Aquaforest is offline  
post #10 of 37 Old 02-18-2011, 07:44 AM
webspoke
Registered User
2013  
 
Join Date: Jan 2011
Location: DFW
Posts: 110
There are download, burning, and install instructions on the lower left menu here: http://www.mofv.com/mygig/


One thing I do see after the patch - phone book entries with the number classified under 'main' (instead of work, mobile, etc) will not dial out.
webspoke is offline  
post #11 of 37 Old 02-18-2011, 08:13 AM
poomobile
Registered User
2011 WK 
 
Join Date: Jan 2011
Posts: 33
The patch linked is a copy of the disc that came direct from jeep. I installed it last week and it works perfect with my iPhone 4. Also stopped the acquiring signal message when listening to Sirius!

Just download file and burn to a cd. Windows 7 will do it automatically when you click on the file. After burn, just put in your disc slot and follow the prompts. Make sure the truck is running when you do it
poomobile is offline  
post #12 of 37 Old 02-18-2011, 08:41 AM
Aquaforest
Registered User
 
Join Date: Jan 2011
Posts: 144
Thanks for all those directions. From what I could tell so far, my Uconnect in my GC is working for phone calling in/out, but I noticed when I streamed music from my iphone it was all choppy. Do you know if that patch will fix this as well.
Aquaforest is offline  
post #13 of 37 Old 02-18-2011, 04:35 PM
IRSmart
Registered User
2015 KL Cherokee 
 
Join Date: Feb 2011
Location: Westminster
Posts: 1,082
just for clarification, this "patch" is ONLY for GC with the 730N radio (chrysler nav, radio code RER in the lower right corner of the radio), and NOT the 430N garmin nav (radio code RHB).
IRSmart is offline  
post #14 of 37 Old 02-18-2011, 05:47 PM
LiquidOxygen
Registered User
 
Join Date: Feb 2011
Location: Edmonton
Posts: 60
Quote:
Originally Posted by IRSmart View Post
just for clarification, this "patch" is ONLY for GC with the 730N radio (chrysler nav, radio code RER in the lower right corner of the radio), and NOT the 430N garmin nav (radio code RHB).
This is correct
LiquidOxygen is offline  
post #15 of 37 Old 02-18-2011, 06:21 PM
Aquaforest
Registered User
 
Join Date: Jan 2011
Posts: 144
Quote:
Originally Posted by IRSmart View Post
just for clarification, this "patch" is ONLY for GC with the 730N radio (chrysler nav, radio code RER in the lower right corner of the radio), and NOT the 430N garmin nav (radio code RHB).
Thanks for clarifying. I would have been wasting my time with the patch since I have the 430N. BTW how do you find out what current version of the software you are currently running?
Aquaforest is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Keyless go/lock issues... UNCjeepWK2 WK2 Grand Cherokee Forum 31 02-01-2012 12:50 PM
730N and iPhone 4 Problems? daleklotz WK2 Grand Cherokee Forum 11 02-24-2011 03:45 PM
Transmission Issues BREJOLAW WK2 Grand Cherokee Forum 15 12-12-2010 05:17 PM
Need help, Noise issues in Jeep. dowdy85 WK2 Grand Cherokee Forum 2 12-07-2010 05:18 AM
Any Issues RB145 WK2 Grand Cherokee Forum 6 10-17-2010 09:16 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome