HVAC Fan cycles to low speed every minute or two - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK2 Grand Cherokee Forum > HVAC Fan cycles to low speed every minute or two

Stainless Steel Door Hinge PinsPoly Door Hinge BushingsFS: 2007-2013 Jeep Wrangler "HALO" Angel Eye Kit

Reply
Unread 06-19-2014, 12:25 PM   #1
RMFLMFRLF
Registered User
2013 WK 
 
Join Date: Jun 2014
Location: Charleston, West Virginia
Posts: 2
HVAC Fan cycles to low speed every minute or two

2013 JGC Limited - 40k miles - 3.6l Pentastar
The interior climate control fan cycles to low speed setting every minute or so, stays there for a few minutes, then goes back to the correct setting. The fan indicator bar graph does not change. Adjusting the controls has no effect - not even turning the HVAC on and off. Putting it in gear, and speeding up/slowing down has no effect.
UPDATE
After more investigation - the passenger side is blowing warm air at higher fan speeds - even though the temp is set to LO
This seems to be similar to some of the other posts about HVAC control problems that ended up having a TSB for updated software

I talked to the service manager at the dealer where I purchased and they say they have not heard of any similar problems. This just started last week and I have only used AC, not sure if it happens on vent or heat settings.


Last edited by RMFLMFRLF; 06-21-2014 at 02:15 PM..
RMFLMFRLF is offline   Reply With Quote
Unread 06-20-2014, 02:13 PM   #2
MarkSRT8
Registered User
2012 WK 
 
Join Date: Feb 2012
Location: Richmond Hts., OH
Posts: 54
I have noticed on my 2012 that the HVAC fan speed increases/decreases when the cooling fan cycles on/off.
MarkSRT8 is offline   Reply With Quote
Unread 07-09-2014, 08:00 AM   #3
RMFLMFRLF
Registered User
2013 WK 
 
Join Date: Jun 2014
Location: Charleston, West Virginia
Posts: 2
UPDATE
I ended up having the dealer look at the problem while there for the brake booster recall. It turns out the problem was the blend door issue that is talked about in other threads. It sounded like the fan speed would change when apparently it was the blend door opening and closing to block the air flow. The dealer charged $2 for the part and two hours labor at $75/hr for a total of $161 with tax. I consider that reasonable. However, I am not happy with JEEP as this is a very common problem (for many years) that should be considered a manufacturer defect and fixed for free. My 2013 is 5,000 miles out of warranty already.
RMFLMFRLF is offline   Reply With Quote
Unread 07-09-2014, 03:01 PM   #4
bluegrassguitar
Registered User
2011 WK 
 
Join Date: Oct 2010
Location: Woodruff
Posts: 233
I thought I had the blend door issue, too, with my 2011 Laredo. Only slightly cool air (80 deg) coming from the driver's vents, very warm air (90+ deg) on the passenger side, checked with a vent thermometer. Turned out to be a clogged filter and "slightly" low refrigerant level. After being fixed yesterday, it will freeze ice cream.
bluegrassguitar is offline   Reply With Quote
Unread 07-09-2014, 03:05 PM   #5
bluegrassguitar
Registered User
2011 WK 
 
Join Date: Oct 2010
Location: Woodruff
Posts: 233
Oh, yeah...my fan does speed up and slow down if the a/c is set to auto. I suppose that's normal to maintain the set temperature.
bluegrassguitar is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.