Horn randomly stops working - JeepForum.com
 
LinkBack Thread Tools
post #1 of 8 Old 03-27-2011, 01:42 PM Thread Starter
one11sgt
Registered User
 
Join Date: Mar 2011
Location: NY
Posts: 16
Horn randomly stops working

I am having a problem with my horn. It randomly stops working for about 30 seconds then will start again.
My service manager said it is a built in safety to protect the horn. I can understand this if I was pressing on the horn for minutes at a time. But Sometimes the horn will stop working after even a 2 or 3 second blow.
Driving in a metropolitan area, I have had 3 instances now, where I needed the horn at multiple times in close proximity to each other and it has failed to work. This is very dangerous.
I think there is something more to my problem since the "horn protection" seems random. While testing it to recreate the issue, sometimes it stops working in seconds, sometimes I can hold it in for over a minute before it stops.
Protection I can understand, if the protection kicked it at the same time every time, mine does not, and I never know if the horn is going to work when I need it.
Any one else experience this?

one11sgt is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 03-27-2011, 04:51 PM
silver04
Registered User
2011 WK 
 
Join Date: Apr 2005
Posts: 66
How did I know you were in new york without even looking.
silver04 is offline  
post #3 of 8 Old 03-28-2011, 11:07 PM
DennisU
Registered User
2011 WK 
 
Join Date: Dec 2010
Location: Ventura County
Posts: 4
If I had to guess, I would say you need to check for a loose ground wire in the horn circuit.
DennisU is offline  
post #4 of 8 Old 03-28-2011, 11:42 PM
volvite
Registered User
1999 WJ 
 
Join Date: Mar 2009
Location: Hill AFB / West Point
Posts: 1,934
you shouldn't have to look for a loose ground, but go to another dealership and let them know your problem. They should fix it.

His 99 WJ Limited 4.7
Hers 15 Overland EcoDiesel, ORAII
volvite is online now  
post #5 of 8 Old 03-29-2011, 07:42 AM
JeepOrvis97
Registered User
1997 ZJ 
 
Join Date: Feb 2008
Location: Hudson
Posts: 1,653
"horn protection" I'm pretty sure sounds like a made up answer.
JeepOrvis97 is offline  
post #6 of 8 Old 03-29-2011, 09:49 PM
LuckRider
Web Wheeler
 
LuckRider's Avatar
2004 TJ Wrangler 
 
Join Date: Apr 2009
Location: NY - 12550
Posts: 9,314
Time for a new dealership. If it were a safety function, it would do it the same way all the time.

Thanks to SuperWade2 For the 1 Year Upgrade!
Support Our Troops!
ALL WK2 Owners, Click Here
JFI Member #7: Helping out the Scammed
2004 Rubi: Ready to Kill the Chrome!
Totaled and Gone: Mostly Stock 2005 I6 Patriot Blue TJ: Monstaliner (Write-Up) BESRK Rear Bumper, Hella 500s
Do the Jeep Wave :D 0|||||||0 Take 95% of what I say as a joke/sarcasm!-Thomas
LuckRider is offline  
post #7 of 8 Old 03-30-2011, 08:41 PM Thread Starter
one11sgt
Registered User
 
Join Date: Mar 2011
Location: NY
Posts: 16
Thank you all. The dealership said thats what chrysler told them. I will push the issue and see what happens.
one11sgt is offline  
post #8 of 8 Old 03-30-2011, 09:09 PM
JeepOrvis97
Registered User
1997 ZJ 
 
Join Date: Feb 2008
Location: Hudson
Posts: 1,653
dealers definitely make things up quite often and usually its to cover up a lack of knowledge, sometimes it's not as bad when you talk directly to the tech.
JeepOrvis97 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Deals Are A Working fleuger99 WK2 Grand Cherokee Forum 15 02-19-2011 04:12 AM
Passive Entry Module not working - now fixed RRER WK2 Grand Cherokee Forum 3 10-27-2010 10:02 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome