Horn randomly stops working - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK2 Grand Cherokee Forum > Horn randomly stops working

Ruffstuff Axle Simple Swap Kit!ROCK BOTTOM prices on LIFT KITS at Rockridge4wd!! WANT TO Introducing MONSTALINER™ UV Permanent DIY Roll On Bed Line

Reply
Unread 03-27-2011, 02:42 PM   #1
one11sgt
Registered User
 
Join Date: Mar 2011
Location: NY, NY
Posts: 16
Horn randomly stops working

I am having a problem with my horn. It randomly stops working for about 30 seconds then will start again.
My service manager said it is a built in safety to protect the horn. I can understand this if I was pressing on the horn for minutes at a time. But Sometimes the horn will stop working after even a 2 or 3 second blow.
Driving in a metropolitan area, I have had 3 instances now, where I needed the horn at multiple times in close proximity to each other and it has failed to work. This is very dangerous.
I think there is something more to my problem since the "horn protection" seems random. While testing it to recreate the issue, sometimes it stops working in seconds, sometimes I can hold it in for over a minute before it stops.
Protection I can understand, if the protection kicked it at the same time every time, mine does not, and I never know if the horn is going to work when I need it.
Any one else experience this?

one11sgt is offline   Reply With Quote Quick reply to this message
Unread 03-27-2011, 05:51 PM   #2
silver04
Registered User
2011 WK 
 
Join Date: Apr 2005
Posts: 66
How did I know you were in new york without even looking.
silver04 is offline   Reply With Quote Quick reply to this message
Unread 03-29-2011, 12:07 AM   #3
DennisU
Registered User
2011 WK 
 
Join Date: Dec 2010
Location: Ventura County, CA
Posts: 4
If I had to guess, I would say you need to check for a loose ground wire in the horn circuit.
DennisU is offline   Reply With Quote Quick reply to this message
Unread 03-29-2011, 12:42 AM   #4
volvite
Registered User
1999 WJ 
 
Join Date: Mar 2009
Location: Hill AFB / West Point, Utah
Posts: 1,808
you shouldn't have to look for a loose ground, but go to another dealership and let them know your problem. They should fix it.
__________________
Proud member of PETA= People for Eating Tasty Animals
RC X-seris 4 inch lift/32 Inch tires/My Build: http://www.jeepforum.com/forum/f197/...hread-1158910/
08 Nissan Pathfinder LE
volvite is offline   Reply With Quote Quick reply to this message
Unread 03-29-2011, 08:42 AM   #5
JeepOrvis97
Registered User
1997 ZJ 
 
Join Date: Feb 2008
Location: Hudson, OH
Posts: 1,653
"horn protection" I'm pretty sure sounds like a made up answer.
JeepOrvis97 is offline   Reply With Quote Quick reply to this message
Unread 03-29-2011, 10:49 PM   #6
LuckRider
Web Wheeler
 
LuckRider's Avatar
2004 TJ Wrangler 
 
Join Date: Apr 2009
Location: NY - 12550
Posts: 9,318
Time for a new dealership. If it were a safety function, it would do it the same way all the time.
__________________
Thanks to SuperWade2 For the 1 Year Upgrade!
Support Our Troops!
ALL WK2 Owners, Click Here
JFI Member #7: Helping out the Scammed
2004 Rubi: Ready to Kill the Chrome!
Totaled and Gone: Mostly Stock 2005 I6 Patriot Blue TJ: Monstaliner (Write-Up) BESRK Rear Bumper, Hella 500s
Do the Jeep Wave :D 0|||||||0 Take 95% of what I say as a joke/sarcasm!-Thomas
LuckRider is offline   Reply With Quote Quick reply to this message
Unread 03-30-2011, 09:41 PM   #7
one11sgt
Registered User
 
Join Date: Mar 2011
Location: NY, NY
Posts: 16
Thank you all. The dealership said thats what chrysler told them. I will push the issue and see what happens.
one11sgt is offline   Reply With Quote Quick reply to this message
Unread 03-30-2011, 10:09 PM   #8
JeepOrvis97
Registered User
1997 ZJ 
 
Join Date: Feb 2008
Location: Hudson, OH
Posts: 1,653
dealers definitely make things up quite often and usually its to cover up a lack of knowledge, sometimes it's not as bad when you talk directly to the tech.
JeepOrvis97 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.