Hi idle RPM's at start up for V6 - JeepForum.com

LinkBack Thread Tools
post #1 of 3 Old 09-12-2010, 07:42 PM Thread Starter
Registered User
2011 WK 
Join Date: Sep 2010
Location: Renton
Posts: 31
Hi idle RPM's at start up for V6

Hey there.....

So my new GC Limited has fewer that 300 miles on it thus far and I absolutely love it, but one of the odd things I am noticing is, at start up, a seemingly hi idle of ~1500 RPM's while still parked. This last for about 10 seconds and then gradually mellows out to around 900... Anyone else notice this?


Qrex is offline  
Sponsored Links
post #2 of 3 Old 09-13-2010, 05:47 PM
Registered User
2014 WK 
Join Date: Aug 2010
Location: Texas
Posts: 55
My 5.7 does it and my 6.1 in my Challenger also. Its normal. I think its a warm up thing.
darkrt is offline  
post #3 of 3 Old 09-13-2010, 07:39 PM
smcginnis87's Avatar
2007 WK 
Join Date: Apr 2008
Location: Phoenix/Scottsdale
Posts: 1,398
yea man its just a motor warming thing... my 5.7 does it and my rotary did it

2015 WK2
smcginnis87 is offline  

Quick Reply

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
remote start question.... Dabitz WK2 Grand Cherokee Forum 31 11-11-2010 12:45 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome