HELP!!! 2011 Jeep Grand Cherokee... - JeepForum.com

 
LinkBack Thread Tools
post #1 of 9 Old 11-08-2013, 12:11 PM Thread Starter
sarahbwertz
Registered User
 
Join Date: Nov 2013
Location: birmingham
Posts: 5
HELP!!! 2011 Jeep Grand Cherokee...

Can someone offer their advice? I need help (AND I cannot get anyone at my local Jeep Dealership to help...go figure). Okay, so my problems started about 2 months ago. My GC all of a sudden started having problems starting up (to the point where it would make a clicking sound when I pushed to start) after about 2 tries it would finally start. It continued and worsened...So, I replaced the battery (had it tested and confirmed that battery was no longer good). Yay, I thought my problem was solved! A few days later, same thing started happening again....except it would start and then immediately cut off. Several tries later I would finally get it to start. Which bring me to my latest problem which happened yesterday, As I am leaving work I noticed my car would not unlock with the remote (I had to actually take the key out of the remote and manually unlock the door)- I put the key in the ignition and tried to start it- nothing happened and then my key wouldn't come out!!! It was stuck, I mean really stuck- I tried everything. Finally, someone jumped my car off and it finally started- the engine revved very loudly (and no one did it- it did that all on it's own). Can someone please tell me if they have had the same issue? I am sooooo angry with this car. I have had 5 cars (all different) and never have any problems with one of them!!!!! Is this a hard fix? Expensive??? HELP!! :confused


sarahbwertz is offline  
Sponsored Links
Advertisement
 
post #2 of 9 Old 11-08-2013, 12:22 PM
ArloGuthroJeep
Mr. Hyde!
 
ArloGuthroJeep's Avatar
2004 WJ 
 
Join Date: Mar 2005
Location: Boulder
Posts: 23,086
Have you had the alternator tested?
Have you tested how much draw is occurring when the car is off and the computer is asleep (turn off car with hood popped and wait "some time" for everything to sleep, then measure draw).

Sounds like either a bad battery (unlikely since just changed), alternator not charging or intermittently charging, or an abnormal power draw occurring when the engine is off.

What Jeep do you have?

'04 WJ, 6" Clayton LA's, 242 SYE, 35" BFG MT KM2's, 4.56 gears, & D44a locked
'14 WK2 Limited w/5.7L, ORAI, & Tow Package
ArloGuthroJeep is offline  
post #3 of 9 Old 11-08-2013, 12:26 PM Thread Starter
sarahbwertz
Registered User
 
Join Date: Nov 2013
Location: birmingham
Posts: 5
I have not had the alternator tested ( I will thought tomorrow). I didn't know I should test the draw ( I am not savy when it comes to cars). I have the 2011 Jeep Grand Cherokee Limited.
sarahbwertz is offline  
post #4 of 9 Old 11-08-2013, 12:31 PM
ArloGuthroJeep
Mr. Hyde!
 
ArloGuthroJeep's Avatar
2004 WJ 
 
Join Date: Mar 2005
Location: Boulder
Posts: 23,086
http://www.wikihow.com/Find-a-Parasitic-Battery-Drain

Cars with their modern electronics can be VERY picky if they have too little power and act unpredictably.

'04 WJ, 6" Clayton LA's, 242 SYE, 35" BFG MT KM2's, 4.56 gears, & D44a locked
'14 WK2 Limited w/5.7L, ORAI, & Tow Package
ArloGuthroJeep is offline  
post #5 of 9 Old 11-08-2013, 12:33 PM Thread Starter
sarahbwertz
Registered User
 
Join Date: Nov 2013
Location: birmingham
Posts: 5
What am I looking for when I measure the draw? See....I know nothing
sarahbwertz is offline  
post #6 of 9 Old 11-08-2013, 12:49 PM
ArloGuthroJeep
Mr. Hyde!
 
ArloGuthroJeep's Avatar
2004 WJ 
 
Join Date: Mar 2005
Location: Boulder
Posts: 23,086
See step 4 in the link I sent you

'04 WJ, 6" Clayton LA's, 242 SYE, 35" BFG MT KM2's, 4.56 gears, & D44a locked
'14 WK2 Limited w/5.7L, ORAI, & Tow Package
ArloGuthroJeep is offline  
post #7 of 9 Old 11-08-2013, 12:51 PM Thread Starter
sarahbwertz
Registered User
 
Join Date: Nov 2013
Location: birmingham
Posts: 5
Thank you!
sarahbwertz is offline  
post #8 of 9 Old 11-08-2013, 01:44 PM
ColdCase
My Reality Check Bounced
 
ColdCase's Avatar
2011 WK 
 
Join Date: Sep 2009
Location: New England
Posts: 7,861
There have been some reports of loose alternator wire/connection that exhibit similar issues. Some loose grounds can do this or a loose battery connection. Even a brand new battery go bad.

Current: 2011 Grand Cherokee Overland V8, 2009 Liberty Rocky Mt V6
Previous: 2000 Grand Cherokee Laredo I6, 1979 CJ7 I6 Quadratrac
ColdCase is offline  
post #9 of 9 Old 11-08-2013, 02:17 PM
Dealer24028
Registered User
 
Join Date: Nov 2013
Location: Cary
Posts: 39
I'd make sure this has been done. This issue is offen accompanied by intermittant RKE functions.
Attached Files
File Type: pdf 08-022-12.pdf (111.9 KB, 67 views)
Dealer24028 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome