Engine light on, ECO sign no longer displays - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK2 Grand Cherokee Forum > Engine light on, ECO sign no longer displays

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineSavvy Billet LED Tail LightsWant to be able to SEE? DOT Approved Headlights for under

Reply
Unread 02-24-2013, 10:04 PM   #1
nyrhockey23
Registered User
 
Join Date: Feb 2011
Location: , ct
Posts: 260
Engine light on, ECO sign no longer displays

Had that happen on the way home last night. I think (and hope) it's because the oil change is due? had never seen this before.

nyrhockey23 is offline   Reply With Quote Quick reply to this message
Unread 02-25-2013, 12:14 AM   #2
ColdCase
My Reality Check Bounced
 
ColdCase's Avatar
2011 WK 
 
Join Date: Sep 2009
Location: New England
Posts: 4,329
The check engine light does not come on when the oil change is due. You will get a text notice in the EVIC display area.

Could be something as simple as a loose gas cap, but can't tell without the fault code. You need to swing by an auto parts store and have them read the code, buy or borrow a ODB reader, or swing by the dealer.
__________________
2011 Grand Cherokee Overland V8, 2009 Liberty Rocky Mt V6, 2000 Grand Cherokee Laredo I6, 1979 CJ7 I6 Quadratrac
ColdCase is offline   Reply With Quote Quick reply to this message
Unread 12-10-2013, 10:33 AM   #3
2cobras
Registered User
 
Join Date: Jan 2013
Location: Richmond, Tx
Posts: 9
I have a 2013 Hemi with 14,000 miles on it and I am having the same issue.
I heard my check engine light come on last night & noticed the ECO sign no longer displays.
Any word on what the problem was with yours?
Jeff
2cobras is offline   Reply With Quote Quick reply to this message
Unread 12-10-2013, 10:38 AM   #4
OverlandSummitt
Registered User
 
Join Date: Mar 2013
Location: Albuquerque, NM
Posts: 31
Quote:
Originally Posted by 2cobras View Post
I have a 2013 Hemi with 14,000 miles on it and I am having the same issue.
I heard my check engine light come on last night & noticed the ECO sign no longer displays.
Any word on what the problem was with yours?
Jeff
There is an option in the Setup menu that can deactivate the ECO symbol from being displayed. Check that out first.
OverlandSummitt is offline   Reply With Quote Quick reply to this message
Unread 12-10-2013, 03:29 PM   #5
2cobras
Registered User
 
Join Date: Jan 2013
Location: Richmond, Tx
Posts: 9
Thanks, I will check it out but I never turned it off. It went off when the check engine light came on & the gas mileage has dropped.
2cobras is offline   Reply With Quote Quick reply to this message
Unread 12-10-2013, 05:05 PM   #6
ColdCase
My Reality Check Bounced
 
ColdCase's Avatar
2011 WK 
 
Join Date: Sep 2009
Location: New England
Posts: 4,329
What is the error code that is setting the check engine light? I'm not surprised that something wrong in the engine disables ECO mode, the check enging indicator means something is wrong..... unless I'm miss-reading the question.... .
__________________
2011 Grand Cherokee Overland V8, 2009 Liberty Rocky Mt V6, 2000 Grand Cherokee Laredo I6, 1979 CJ7 I6 Quadratrac
ColdCase is offline   Reply With Quote Quick reply to this message
Unread 12-11-2013, 07:54 AM   #7
2kg4u
Registered User
2014 WK 
 
Join Date: Nov 2013
Location: Windsor, Ontario
Posts: 443
If your check engine light is on you need to have the vehicle scanned to see what the problem is. Any other symptoms you are experiencing are secondary, and quite possibly caused by the condition that is setting the CEL. I am new to Chrylser products and not sure what the onboard diagnostice capabilities are. I thought you could read DTC's (diagnositic trouble codes) yourself without a scanner, but if that is not the case take your vehicle to Autozone. They will scan if for free. Post the DTC's and there are all sorts of people on the forum that can tell you if they are critical or not, and suggest possible fixes.
__________________
Roy
2014 Overland, 3.6 L
Fumoto Qwikvalve, Ionic CXV running boards, Michelin X-Ice Xi2 snow tires
2kg4u is offline   Reply With Quote Quick reply to this message
Unread 12-12-2013, 09:34 AM   #8
steveinaz
Registered User
2011 WK 
 
Join Date: Jun 2011
Location: Javelina, Arizona
Posts: 155
Try re-tightening the gas cap first, but it takes a few days to extinguish the check engine light---speaking from personal experience 1 week ago.
__________________
2011 Grand Cherokee Laredo 4X4
3.6L V-6 with Selec-Terrain
Off-Road Adventure package
Tow package
steveinaz is offline   Reply With Quote Quick reply to this message
Unread 12-12-2013, 09:48 AM   #9
nyrhockey23
Registered User
 
Join Date: Feb 2011
Location: , ct
Posts: 260
This was due to the cylinder head issue that's not uncommon to '12 JGC's. Had it fixed, then reappeared a few days later and had it replaced. Been fine since.
nyrhockey23 is offline   Reply With Quote Quick reply to this message
Unread 12-12-2013, 12:58 PM   #10
WvTaco
Registered User
2011 WK 
 
Join Date: Apr 2011
Location: Logan, Wv
Posts: 493
i had a air leak in the filler neck its self, on my only c/e light.

but c/e light = no eco light.

for reference your oil change at 6 months on mine( 11 v6) will not display, but at the mileage it will tell you this with a chime.( i usually hit time before mileage )
WvTaco is offline   Reply With Quote Quick reply to this message
Unread 12-12-2013, 02:28 PM   #11
2cobras
Registered User
 
Join Date: Jan 2013
Location: Richmond, Tx
Posts: 9
Well I dropped it off at the dealer this morning and I am waiting for a call to let me know the status.
I hope it isn't anything major.
2cobras is offline   Reply With Quote Quick reply to this message
Unread 12-13-2013, 03:38 PM   #12
2cobras
Registered User
 
Join Date: Jan 2013
Location: Richmond, Tx
Posts: 9
Well I just picked up my Jeep and they couldn't find anything wrong, they think it was just a glitch.
They reprogramed the PCM and A/C control module per TSB's.
2cobras is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.