Coolant leak - JeepForum.com
 
LinkBack Thread Tools
post #1 of 6 Old 09-28-2012, 09:45 AM Thread Starter
TheSiltSurfer
Registered User
2012 WK 
 
Join Date: Sep 2011
Location: Durango
Posts: 848
Just dropped my baby off at the dealership, noticed it leaking coolant this morning popped open the hood & it was dry in the reservoir. it appeared to be leaking from water pump? Possibly the thermostat housing ?fluid was everywhere . Anyhow Godbless warranties well have to wait till next week keep y'all posted


Infinite Patience Produces Immediate Results
TheSiltSurfer is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 09-28-2012, 12:18 PM Thread Starter
TheSiltSurfer
Registered User
2012 WK 
 
Join Date: Sep 2011
Location: Durango
Posts: 848
Dealer called me & said the water pump "had ***** the bed" ��so it failed in other words. Ordering me a new one should have her back Monday +) all praises to warranty. Then again I'm only at 10 thousand miles and it already went threw one water pump **** son!

Infinite Patience Produces Immediate Results
TheSiltSurfer is offline  
post #3 of 6 Old 09-28-2012, 03:28 PM
MaineJeep11
Registered User
2011 WK 
 
Join Date: Dec 2010
Posts: 278
Glad they caught it and fixed it now instead of when you're out in the mountains or in the dunes at least. Not fun to have such an important component fail at 10k though. Like you said, good thing for the warranty!

2011 Laredo V6, OR1, RR 2.5" lift, ProComp 7036 wheels, 265/70/17 Toyo Open Country AT's - SOLD
MaineJeep11 is offline  
post #4 of 6 Old 09-29-2012, 01:23 PM
padgett
Registered User
2012 WK 
 
Join Date: Feb 2012
Location: orlando
Posts: 582
That is an early failure but past the bathtub curve. Need to check for a belt misalignment, that can torque the water pump shaft and make the seal fail prematurely. If so should see wear on one edge of the sepentine belt. Other possibilities but is the most likely.


One of these is a turbo diesel.

We take in orphans. Notary Sojac y'all.
padgett is offline  
post #5 of 6 Old 09-29-2012, 01:40 PM Thread Starter
TheSiltSurfer
Registered User
2012 WK 
 
Join Date: Sep 2011
Location: Durango
Posts: 848
Quote:
Originally Posted by padgett
That is an early failure but past the bathtub curve. Need to check for a belt misalignment, that can torque the water pump shaft and make the seal fail prematurely. If so should see wear on one edge of the sepentine belt. Other possibilities but is the most likely.


One of these is a turbo diesel.
Good points! I'll let them know Monday to check the belts ect, it's under warranty so doesn't bother me if I have to leave it a week and let them fix everything correctly besides I have a WJ and I can drive on the side so I'm good. Thanks !

Infinite Patience Produces Immediate Results
TheSiltSurfer is offline  
post #6 of 6 Old 04-06-2013, 11:10 PM
hobbie1
Registered User
2015 WK 
 
Join Date: May 2010
Location: Brentwood
Posts: 431
Interesting - mine is failing at 29,000 miles. Called the dealer and the water pumps are on hold - none available. They have to call Chrysler on Monday. Also found out that my left front CV axle boot has failed, grease is everywhere. This is my sixth Jeep and seems to be the worse. Transfer case, water pump and CV boot. Not good for a unit that is garaged and attended to.

15 Summit 4X4 Eco Diesel
14 RAM 2500 Cummins 4X4 Laramie CC
13 Mustang GT
66 Mustang Cp - 306 5sp
hobbie1 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome