Coolant leak - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK2 Grand Cherokee Forum > Coolant leak

Ruffstuff Axle Simple Swap Kit!ROCK BOTTOM prices on LIFT KITS at Rockridge4wd!! WANT TO Introducing MONSTALINER™ UV Permanent DIY Roll On Bed Line

Reply
Unread 09-28-2012, 10:45 AM   #1
TheSiltSurfer
Registered User
2012 WK 
 
Join Date: Sep 2011
Location: Durango, Colorado
Posts: 848
Just dropped my baby off at the dealership, noticed it leaking coolant this morning popped open the hood & it was dry in the reservoir. it appeared to be leaking from water pump? Possibly the thermostat housing ?fluid was everywhere . Anyhow Godbless warranties well have to wait till next week keep y'all posted

__________________
Infinite Patience Produces Immediate Results
TheSiltSurfer is offline   Reply With Quote Quick reply to this message
Unread 09-28-2012, 01:18 PM   #2
TheSiltSurfer
Registered User
2012 WK 
 
Join Date: Sep 2011
Location: Durango, Colorado
Posts: 848
Dealer called me & said the water pump "had ***** the bed" ��so it failed in other words. Ordering me a new one should have her back Monday +) all praises to warranty. Then again I'm only at 10 thousand miles and it already went threw one water pump **** son!
__________________
Infinite Patience Produces Immediate Results
TheSiltSurfer is offline   Reply With Quote Quick reply to this message
Unread 09-28-2012, 04:28 PM   #3
MaineJeep11
Registered User
2011 WK 
 
Join Date: Dec 2010
Location: , Maine
Posts: 278
Glad they caught it and fixed it now instead of when you're out in the mountains or in the dunes at least. Not fun to have such an important component fail at 10k though. Like you said, good thing for the warranty!
__________________
2011 Laredo V6, OR1, RR 2.5" lift, ProComp 7036 wheels, 265/70/17 Toyo Open Country AT's - SOLD
MaineJeep11 is offline   Reply With Quote Quick reply to this message
Unread 09-29-2012, 02:23 PM   #4
padgett
Registered User
2012 WK 
 
Join Date: Feb 2012
Location: orlando, florida
Posts: 582
That is an early failure but past the bathtub curve. Need to check for a belt misalignment, that can torque the water pump shaft and make the seal fail prematurely. If so should see wear on one edge of the sepentine belt. Other possibilities but is the most likely.


One of these is a turbo diesel.
__________________
We take in orphans. Notary Sojac y'all.
padgett is offline   Reply With Quote Quick reply to this message
Unread 09-29-2012, 02:40 PM   #5
TheSiltSurfer
Registered User
2012 WK 
 
Join Date: Sep 2011
Location: Durango, Colorado
Posts: 848
Quote:
Originally Posted by padgett
That is an early failure but past the bathtub curve. Need to check for a belt misalignment, that can torque the water pump shaft and make the seal fail prematurely. If so should see wear on one edge of the sepentine belt. Other possibilities but is the most likely.


One of these is a turbo diesel.
Good points! I'll let them know Monday to check the belts ect, it's under warranty so doesn't bother me if I have to leave it a week and let them fix everything correctly besides I have a WJ and I can drive on the side so I'm good. Thanks !
__________________
Infinite Patience Produces Immediate Results
TheSiltSurfer is offline   Reply With Quote Quick reply to this message
Unread 04-07-2013, 12:10 AM   #6
hobbie1
Registered User
2011 WK 
 
Join Date: May 2010
Location: Brentwood CA
Posts: 218
Interesting - mine is failing at 29,000 miles. Called the dealer and the water pumps are on hold - none available. They have to call Chrysler on Monday. Also found out that my left front CV axle boot has failed, grease is everywhere. This is my sixth Jeep and seems to be the worse. Transfer case, water pump and CV boot. Not good for a unit that is garaged and attended to.
__________________
2011 Overland 4X4 QDII QLII 5.7 - Adventure II
2012 RAM 2500 Cummins 4X4 Laramie Crew Cab
2005 Mercedes C-240 4-Matic
2013 Ford Mustang GT and 1966 Ford Mustang 289 5-SPD 289
hobbie1 is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.