Clicking noise coming from dash?? - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK2 Grand Cherokee Forum > Clicking noise coming from dash??

ECGS Black Friday Sale!!6th Annual, Beat Your Wife to the Credit Card Sale!Alloy usa heavy duty ball joint kits

Reply
Unread 12-06-2010, 09:41 AM   #1
JeremiahB
Registered User
 
Join Date: Nov 2010
Location: Williamsburg, Virginia
Posts: 210
Clicking noise coming from dash??

I keep getting this random clicking coming from somewhere near the left side of the dash. It sounds like the lights turning on and off in an older model car. This noise is completely random and will last for about 30 seconds at a time involving about 10 clicks....... Anybody else experience this?

JeremiahB is offline   Reply With Quote Quick reply to this message
Unread 12-06-2010, 10:09 AM   #2
CTO1
Registered User
2011 WK 
 
Join Date: Nov 2010
Location: Tempe, AZ
Posts: 120
Quote:
Originally Posted by JeremiahB View Post
I keep getting this random clicking coming from somewhere near the left side of the dash. It sounds like the lights turning on and off in an older model car. This noise is completely random and will last for about 30 seconds at a time involving about 10 clicks....... Anybody else experience this?
I seem to recall reading somewhere that it was the ESC calibrating or something like that. I can't seem to find where I read it but it was an owner's manual or something like that. It said that it will do that for a while (the first few thousand miles or so?) after you first start it up and drive it. If it's the same noise I've heard mine does it usually in the mornings on the way to work.
CTO1 is offline   Reply With Quote Quick reply to this message
Unread 12-06-2010, 10:24 AM   #3
UNCjeepWK2
Registered User
2011 WK 
 
Join Date: Nov 2010
Location: Salisbury, NC
Posts: 293
Mine did the same thing over the first couple thousand miles or so. It eventually becomes increasingly rare... until it stops altogether. I now have 5,200 miles on mine and can't remember the last time I heard it.

Jeep has acknowledged it and says it's normal... i.e., they don't know how to fix it, but since it stops after a couple thousand, they're not going to worry too much about it for this model.
UNCjeepWK2 is offline   Reply With Quote Quick reply to this message
Unread 12-06-2010, 10:26 AM   #4
JeremiahB
Registered User
 
Join Date: Nov 2010
Location: Williamsburg, Virginia
Posts: 210
Yep that sounds like the same thing as it only happens when I first start it, thanks for the reply! I'll be eagerly awaiting it to go away. One of my biggest peeves is strange noises coming from my cars.
JeremiahB is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.