Burnt rubber smell - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK2 Grand Cherokee Forum > Burnt rubber smell

FS: Jeep Fog Light LED Bulbs! Several Brightness Options! USA Standard Chromoly Front Axle Shaft Kits with Dana 30 4The Jeep Forum Discount is ON!

Reply
Unread 06-24-2015, 06:46 AM   #1
Rhfahma
Registered User
 
Join Date: Jun 2015
Posts: 2
Burnt rubber smell

i purchased a brand new Jeep Grand Cherokee first evening with it and I'm getting a burnt plastic/rubber smell coming through the air vents and the only way to shut it out is to recirculate the air inside.
Surely this isn't normal for a new car??!

Rhfahma is offline   Reply With Quote Quick reply to this message
Unread 06-24-2015, 10:33 AM   #2
JeepCACares
Member
 
Join Date: Oct 2014
Location: Windsor, Ontario
Posts: 282
Quote:
Originally Posted by Rhfahma View Post
i purchased a brand new Jeep Grand Cherokee first evening with it and I'm getting a burnt plastic/rubber smell coming through the air vents and the only way to shut it out is to recirculate the air inside.
Surely this isn't normal for a new car??!
Rhfahma,

I'm sorry to hear about the odor you're experiencing. Have you notified your Jeep dealer yet?
__________________
Dave
Top Care Specialist
FCA Canada
JeepCACares is offline   Reply With Quote Quick reply to this message
Unread 06-24-2015, 11:41 AM   #3
lurtonk
Drive it like u stole it
2015 WK 
 
Join Date: Dec 2014
Location: Ridgetop, Tn
Posts: 504
Look under the hood at the drive belts and see if something is rubbing.
lurtonk is online now   Reply With Quote Quick reply to this message
Unread 06-25-2015, 02:38 PM   #4
Blackshirts
Registered User
2012 WK 
 
Join Date: Apr 2015
Location: Media, PA
Posts: 60
Take it back!! Don't delay. Its brand new, take it back.
Blackshirts is offline   Reply With Quote Quick reply to this message
Unread 06-25-2015, 04:28 PM   #5
Lightninrod
Registered User
2013 WK 
 
Join Date: May 2015
Location: warner robins, GA
Posts: 54
That may be just the engine heat affecting the new rubber and plastic parts. May be 'normal' in other words.

Dan
Lightninrod is offline   Reply With Quote Quick reply to this message
Unread 07-08-2015, 10:23 AM   #6
tylerwhofishes
Registered User
2015 WK 
 
Join Date: Feb 2015
Location: New Braunfels, Texas
Posts: 30
Mine did the same thing, only it was after passing on the highway. Figured it was just the engine/tranny and driveline setting in. Check your owners manual, states that oil consumption is normal on new engines.
tylerwhofishes is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.