Another AC question - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK2 Grand Cherokee Forum > Another AC question

FS: Jeep Fog Light LED Bulbs! Several Brightness Options! Win a free set of 35" or 37" tires from Zone OffZone Offroad - Jeep Forum Promotion

Reply
Unread 04-11-2015, 06:10 PM   #1
HSTNJEEP
Registered User
2013 WK 
 
Join Date: Jul 2014
Location: Chelsea, AL
Posts: 159
Another AC question

Took a short trip today and used the AC...it could just be my imagination, but I swear the air (although it seems good and cold) does not seem to be blowing as hard from the vents as I remember it did last summer. Last summer was my first to own the Jeep. Blower has seven settings, and I don't remember ever going past 5. Even here in Alabama.

I think I went to setting 4 today: but again, I seemed to remember it blowing harder last summer.

What could cause that?

__________________
HSTNJEEP

2013 WK2 Laredo, 3.6, Mineral Gray
2004 WJ Special Edition, 4.0, Graphite Metallic
HSTNJEEP is online now   Reply With Quote Quick reply to this message
Unread 04-11-2015, 07:09 PM   #2
14summithemi
Web Wheeler
2014 WK 
 
Join Date: Sep 2013
Location: Bay Village, OHIO
Posts: 1,327
Quote:
Originally Posted by HSTNJEEP View Post
Took a short trip today and used the AC...it could just be my imagination, but I swear the air (although it seems good and cold) does not seem to be blowing as hard from the vents as I remember it did last summer. Last summer was my first to own the Jeep. Blower has seven settings, and I don't remember ever going past 5. Even here in Alabama.

I think I went to setting 4 today: but again, I seemed to remember it blowing harder last summer.

What could cause that?
Clogged or really dirty ac/cabin air filter could.
14summithemi is offline   Reply With Quote Quick reply to this message
Unread 04-12-2015, 05:41 AM   #3
HSTNJEEP
Registered User
2013 WK 
 
Join Date: Jul 2014
Location: Chelsea, AL
Posts: 159
I replaced it last August. That is another reason this is puzzling. Filter might have 9,000 miles on it at most.
__________________
HSTNJEEP

2013 WK2 Laredo, 3.6, Mineral Gray
2004 WJ Special Edition, 4.0, Graphite Metallic
HSTNJEEP is online now   Reply With Quote Quick reply to this message
Unread 04-12-2015, 08:43 AM   #4
kryogen
Registered User
2011 WK 
 
Join Date: Jul 2014
Location: Northern, Quebec
Posts: 814
Quote:
Originally Posted by HSTNJEEP View Post
Took a short trip today and used the AC...it could just be my imagination, but I swear the air (although it seems good and cold) does not seem to be blowing as hard from the vents as I remember it did last summer. Last summer was my first to own the Jeep. Blower has seven settings, and I don't remember ever going past 5. Even here in Alabama.

I think I went to setting 4 today: but again, I seemed to remember it blowing harder last summer.

What could cause that?
I have that same question. Sometimes this winter, I couldnt get it to blow hard enough to defrost the windows. Even at max, it was blowing really "medium-low at most".

There is an issue somewhere but I don't know what....
__________________
2011 Grand Cherokee Overland V8
kryogen is offline   Reply With Quote Quick reply to this message
Unread 04-12-2015, 09:10 AM   #5
14summithemi
Web Wheeler
2014 WK 
 
Join Date: Sep 2013
Location: Bay Village, OHIO
Posts: 1,327
Quote:
Originally Posted by kryogen View Post
I have that same question. Sometimes this winter, I couldnt get it to blow hard enough to defrost the windows. Even at max, it was blowing really "medium-low at most".

There is an issue somewhere but I don't know what....
IMHO, your problem is not a blower speed/force issue but more of a general lack of flow vents directed at the window surface. My point is that even a hyper turbo blower, with the current vents, would not be sufficient for northerners and their fogging issues. I know this is not a widely reported issue but I have to agree that my MY14 is far worse at defrosting than my '02 JGC was.

I had my '02 JGC dash out 4 times for heater core, blend door, recirc door and actuator probs and I was not impressed with the design of the whole setup as it relates to "installability". By that I mean that with all the foam tape, weird un-even matching channels, etc.. it was obvious that it was nearly impossible to install this unit 100% correctly even at the factory for tight airflow, etc...So much so that seeing these deficiencies I was able to vastly improve (better foam tape, taking my time to align everything) the airflow just by assembling and installing correctly.

I am willing to bet that the current hvac boxes share some of these deficiencies. Case in point, I can never get the faces vents to stop blowing some air. When I am on windshield and feet, for example, I also have to shut the actual face vent louvers to stop airflow from hitting my face. It was absolutely unbearable until I got the "hot box" fix done.
14summithemi is offline   Reply With Quote Quick reply to this message
Unread 04-12-2015, 02:39 PM   #6
Sondra3
Registered User
2014 WK 
 
Join Date: Nov 2014
Location: , CT
Posts: 132
Quote:
Originally Posted by 14summithemi View Post
I also have to shut the actual face vent louvers to stop airflow from hitting my face. It was absolutely unbearable until I got the "hot box" fix done.
Gives new meaning to the term 'hot head' doesn't it!

(sorry, I couldn't resist)
__________________
2014 GC Overland Hemi, Quadra II, Tech Package, Black Forest Green
2004 Laredo Columbia Edition
Sondra3 is offline   Reply With Quote Quick reply to this message
Unread 04-12-2015, 03:20 PM   #7
14summithemi
Web Wheeler
2014 WK 
 
Join Date: Sep 2013
Location: Bay Village, OHIO
Posts: 1,327
Quote:
Originally Posted by Sondra3 View Post

Gives new meaning to the term 'hot head' doesn't it!

(sorry, I couldn't resist)
Or...yours is the best I can come up with!
14summithemi is offline   Reply With Quote Quick reply to this message
Unread 04-12-2015, 06:18 PM   #8
JeepGC6855
Registered User
2014 WK 
 
Join Date: Oct 2013
Location: Lawrence, KS
Posts: 206
In my opinion, the 2013 and earlier Grand Cherokees had a much better climate control system
__________________
2002, 2004, 2005, 2009, 2014 Grand Cherokee Limited, 2014 Wrangler
JeepGC6855 is offline   Reply With Quote Quick reply to this message
Unread 04-12-2015, 06:51 PM   #9
HSTNJEEP
Registered User
2013 WK 
 
Join Date: Jul 2014
Location: Chelsea, AL
Posts: 159
Anyone get the hissing sound from the AC? Lasts about 1 to 2 seconds each time it does it. My 2004 WJ does it often. My 2013 WK2 does it mainly when you first turn the AC on (from off position). But occasionally will do it while in AC mode.
__________________
HSTNJEEP

2013 WK2 Laredo, 3.6, Mineral Gray
2004 WJ Special Edition, 4.0, Graphite Metallic
HSTNJEEP is online now   Reply With Quote Quick reply to this message
Unread 04-12-2015, 07:10 PM   #10
HVACNY
Web Wheeler
 
HVACNY's Avatar
2013 WK 
 
Join Date: Feb 2011
Location: East Meadow, NY
Posts: 1,269
Quote:
Originally Posted by HSTNJEEP View Post
I replaced it last August. That is another reason this is puzzling. Filter might have 9,000 miles on it at most.
Are the arrows on the filter going in the same direction as the air flow(down).If not it would restrict the airflow..
__________________
2000 Jeep Grand Cherokee 4.7 V8

2013 Jeep Grand Cherokee Overland 5.7 Hemi
HVACNY is offline   Reply With Quote Quick reply to this message
Unread 04-12-2015, 07:12 PM   #11
kryogen
Registered User
2011 WK 
 
Join Date: Jul 2014
Location: Northern, Quebec
Posts: 814
so far the jeep hvac system is the least reliable I ever had.

It fogs, fan speed varies, sometimes I get almost no hot air on the feet, sometimes I do.
Not clear enough to go to the dealership yet...

Generally I think that it's bad. Never had a car perform that bad in winter. The jeep is a fogging nightmare. I just keep it at max setting all winter....... defrost/feet.
In the maxima I could keep it at 4/8 and it wouldnt fog. In the jeep it's max fan speed or it fogs like hell. And sometimes it does fog anyway.

I have to use the remote start all winter to get it warm before I leave, or it will fog like crazy, even with max fan speed when cold. (no car did it as bad before).

Oh well.... I'll get rid of it before my extended warranty is over in 2017. Whatever.
__________________
2011 Grand Cherokee Overland V8
kryogen is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.