"Alice", my WK2 Laredo 4x4 - Page 2 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK2 Grand Cherokee Forum > "Alice", my WK2 Laredo 4x4

2014 Spartan Locker Special - While Supplies Last! Dana 3The Original 3/8" Ruffstuff Diff Cover!The RuffStuff "I can't go to EJS" Sale!

Reply
Unread 02-22-2012, 07:19 PM   #16
Jackal01
Moderator
 
Jackal01's Avatar
2012 WK 
 
Join Date: Jan 2012
Location: Houston, Texas, Texas
Posts: 2,157
Quote:
Originally Posted by Redealmaker View Post
What did the set of tires and wheels run?

Thanks. $800 for all 4 tires and wheels. I never sold stockers before but I wasn't looking for a huge profit. I just wanted to make a quick sale. I felt it was a good deal.

__________________

'12 Laredo V6 ORA1|Terra Grappler 265-70-17|MB TKO 17x8.5|Silverstar Ultra low beams|Mopar Front and Rear WK2 slush mats|RRO 2.5" lift
BWoody extended sway bar links|K&N 77 Series Intake|Gibson Exhaust | Viair OBA | RRO Combo Winch mount| Q9000S winch
Jackal01 is offline   Reply With Quote
Unread 02-22-2012, 08:47 PM   #17
Big50
Registered User
2012 WK 
 
Join Date: Feb 2012
Location: Vallejo, California
Posts: 235
Damn, that's a sick set up! I'm getting super anxious right now. I'm literally waiting for a call from pep boys to come pick up mine. Similar set up, black wheels and 275/65-18 good year duratracs. My RR lift will be in this Friday to.
__________________
2012 Laredo X 4X4, 5.7 Hemi, luxury package. Mods: 2.5" RR lift, ProComp 7036 wheels, 275/65-18 Wrangler Duratracs. Pics in my gallery
Mild wheeling in my WK2: http://www.youtube.com/watch?v=AueMXQvqCBE&list=UUzGUjoJwwUpCb5Ea05FVtPw&index=2&feature=plcp
Big50 is offline   Reply With Quote
Unread 02-24-2012, 08:30 AM   #18
Jackal01
Moderator
 
Jackal01's Avatar
2012 WK 
 
Join Date: Jan 2012
Location: Houston, Texas, Texas
Posts: 2,157
At the shop with my lift! Mofos wont let me watch.
__________________

'12 Laredo V6 ORA1|Terra Grappler 265-70-17|MB TKO 17x8.5|Silverstar Ultra low beams|Mopar Front and Rear WK2 slush mats|RRO 2.5" lift
BWoody extended sway bar links|K&N 77 Series Intake|Gibson Exhaust | Viair OBA | RRO Combo Winch mount| Q9000S winch
Jackal01 is offline   Reply With Quote
Unread 02-24-2012, 08:46 AM   #19
mike76CJ5
Member
 
mike76CJ5's Avatar
1976 CJ5 
 
Join Date: Apr 2010
Location: Houston
Posts: 375
looks good
__________________
"Know the rules well, so you can break them effectively"
-Dalai Lama XIV

1976 CJ5 Renedade Levis Edition
2012 WK2 Overland
mike76CJ5 is offline   Reply With Quote
Unread 02-24-2012, 04:29 PM   #20
Jackal01
Moderator
 
Jackal01's Avatar
2012 WK 
 
Join Date: Jan 2012
Location: Houston, Texas, Texas
Posts: 2,157
They cannot figure out why the warning lights are on. Install is done. Their partner jeep dealership was closed so couldn't read the computer. Ideas?

forumrunner_20120224_172619.jpg
__________________

'12 Laredo V6 ORA1|Terra Grappler 265-70-17|MB TKO 17x8.5|Silverstar Ultra low beams|Mopar Front and Rear WK2 slush mats|RRO 2.5" lift
BWoody extended sway bar links|K&N 77 Series Intake|Gibson Exhaust | Viair OBA | RRO Combo Winch mount| Q9000S winch
Jackal01 is offline   Reply With Quote
Unread 02-24-2012, 04:40 PM   #21
TheSiltSurfer
Registered User
2012 WK 
 
Join Date: Sep 2011
Location: Durango, Colorado
Posts: 847
Quote:
Originally Posted by Jackal01
They cannot figure out why the warning lights are on. Install is done except the alignment. Their partner jeep dealership was closed so couldn't read the computer. Ideas?

<img src="http://www.jeepforum.com/forum/attachment.php?attachmentid=352206"/>
Yikes! Maybe incorrect Re install of the axles? I hope I don't run into this scary, I'm praying for us
__________________
Infinite Patience Produces Immediate Results
TheSiltSurfer is offline   Reply With Quote
Unread 02-24-2012, 04:55 PM   #22
Jackal01
Moderator
 
Jackal01's Avatar
2012 WK 
 
Join Date: Jan 2012
Location: Houston, Texas, Texas
Posts: 2,157
Edit. Alignment is done. To 2011 Wk2 specs.

It drives great. Same as factory. Brake check said could be abs sensors not plugged in but I doubt that. Or a cycle of ignition on and off multiple times.
__________________

'12 Laredo V6 ORA1|Terra Grappler 265-70-17|MB TKO 17x8.5|Silverstar Ultra low beams|Mopar Front and Rear WK2 slush mats|RRO 2.5" lift
BWoody extended sway bar links|K&N 77 Series Intake|Gibson Exhaust | Viair OBA | RRO Combo Winch mount| Q9000S winch
Jackal01 is offline   Reply With Quote
Unread 02-24-2012, 05:22 PM   #23
TheSiltSurfer
Registered User
2012 WK 
 
Join Date: Sep 2011
Location: Durango, Colorado
Posts: 847
Quote:
Originally Posted by Jackal01
Edit. Alignment is done. To 2011 Wk2 specs.

It drives great. Same as factory. Brake check said could be abs sensors not plugged in but I doubt that. Or a cycle of ignition on and off multiple times.
Sweet mines done just drove her just needs alignment but no lights here! Probably going to start a thread for mine soon. Need tires next! Woot woot!!
__________________
Infinite Patience Produces Immediate Results
TheSiltSurfer is offline   Reply With Quote
Unread 02-24-2012, 06:05 PM   #24
grogie
Cell Block #4533
 
grogie's Avatar
2006 TJ Wrangler 
 
Join Date: Nov 2005
Location: Indy
Posts: 7,149
Quote:
Originally Posted by Jackal01 View Post
Here is the following day from the post above. I got Nitto Terra Grapplers tires 265/70/17 and MB TKO 17s 0 offset wheels from Discount Tire. I then sold my stock wheels and tires the following day to a local guy. I also removed the two front lower fascia pieces. What do they actually do?

Wow! That is sweet.
__________________

Red Jeep Club #345
2006 TJ Sport
2004 KJ Limited
2013 Off-Road Trailer

grogie is offline   Reply With Quote
Unread 02-24-2012, 06:22 PM   #25
Jackal01
Moderator
 
Jackal01's Avatar
2012 WK 
 
Join Date: Jan 2012
Location: Houston, Texas, Texas
Posts: 2,157
Quote:
Originally Posted by TheSiltSurfer View Post
Sweet mines done just drove her just needs alignment but no lights here! Probably going to start a thread for mine soon. Need tires next! Woot woot!!
Awesome. Glad you have no lights. I just disco my battery. Gonna see if that fixes. I am betting not.
__________________

'12 Laredo V6 ORA1|Terra Grappler 265-70-17|MB TKO 17x8.5|Silverstar Ultra low beams|Mopar Front and Rear WK2 slush mats|RRO 2.5" lift
BWoody extended sway bar links|K&N 77 Series Intake|Gibson Exhaust | Viair OBA | RRO Combo Winch mount| Q9000S winch
Jackal01 is offline   Reply With Quote
Unread 02-24-2012, 06:25 PM   #26
Jackal01
Moderator
 
Jackal01's Avatar
2012 WK 
 
Join Date: Jan 2012
Location: Houston, Texas, Texas
Posts: 2,157
Battery disconnect didn't fix it. At least disconnecting the ground at the battery didn't. Siltsurfer, you still haven't an alignment. The lights may have something to do with it since I have had one. Not sure just a guess.

forumrunner_20120224_192258.jpg



forumrunner_20120224_192323.jpg



forumrunner_20120224_192357.jpg



forumrunner_20120224_192421.jpg
__________________

'12 Laredo V6 ORA1|Terra Grappler 265-70-17|MB TKO 17x8.5|Silverstar Ultra low beams|Mopar Front and Rear WK2 slush mats|RRO 2.5" lift
BWoody extended sway bar links|K&N 77 Series Intake|Gibson Exhaust | Viair OBA | RRO Combo Winch mount| Q9000S winch
Jackal01 is offline   Reply With Quote
Unread 02-24-2012, 07:57 PM   #27
Mojo51
Registered User
2012 WK 
 
Join Date: Dec 2011
Location: Chicago, Illinois
Posts: 85
Looks good. Did u have any rubbing before the lift install with 0 offset?
Mojo51 is offline   Reply With Quote
Unread 02-24-2012, 08:11 PM   #28
Jackal01
Moderator
 
Jackal01's Avatar
2012 WK 
 
Join Date: Jan 2012
Location: Houston, Texas, Texas
Posts: 2,157
Quote:
Originally Posted by Mojo51 View Post
Looks good. Did u have any rubbing before the lift install with 0 offset?
Thanks, no. I read in other threads that my size will most likely fit even without 0 offset. I wanted 285s but I didnt want me speedo off that much nor wanted my MPG to drop more even though right now I am at 18.5 city with not being easy on the pedal the whole time.
__________________

'12 Laredo V6 ORA1|Terra Grappler 265-70-17|MB TKO 17x8.5|Silverstar Ultra low beams|Mopar Front and Rear WK2 slush mats|RRO 2.5" lift
BWoody extended sway bar links|K&N 77 Series Intake|Gibson Exhaust | Viair OBA | RRO Combo Winch mount| Q9000S winch
Jackal01 is offline   Reply With Quote
Unread 02-24-2012, 09:06 PM   #29
Jackal01
Moderator
 
Jackal01's Avatar
2012 WK 
 
Join Date: Jan 2012
Location: Houston, Texas, Texas
Posts: 2,157
Quote:
Originally Posted by grogie View Post
Wow! That is sweet.
Thanks
__________________

'12 Laredo V6 ORA1|Terra Grappler 265-70-17|MB TKO 17x8.5|Silverstar Ultra low beams|Mopar Front and Rear WK2 slush mats|RRO 2.5" lift
BWoody extended sway bar links|K&N 77 Series Intake|Gibson Exhaust | Viair OBA | RRO Combo Winch mount| Q9000S winch
Jackal01 is offline   Reply With Quote
Unread 02-25-2012, 08:54 AM   #30
Jackal01
Moderator
 
Jackal01's Avatar
2012 WK 
 
Join Date: Jan 2012
Location: Houston, Texas, Texas
Posts: 2,157
Dealership said a speed sensor went bad and it just affects other systems like that. Seems odd but whatever. I came home to eat since it will be about another hour before it is done. I will get an in depth explanation upon pickup.
__________________

'12 Laredo V6 ORA1|Terra Grappler 265-70-17|MB TKO 17x8.5|Silverstar Ultra low beams|Mopar Front and Rear WK2 slush mats|RRO 2.5" lift
BWoody extended sway bar links|K&N 77 Series Intake|Gibson Exhaust | Viair OBA | RRO Combo Winch mount| Q9000S winch
Jackal01 is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.