2014 Grand Cherokee - Electrical problems? - Page 3 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK2 Grand Cherokee Forum > 2014 Grand Cherokee - Electrical problems?

Stainless Steel Door Hinge PinsPoly Door Hinge BushingsDisc Brake Kits from ECGS

Reply
Unread 07-11-2013, 03:29 PM   #31
Jackal01
Moderator
 
Jackal01's Avatar
2012 WK 
 
Join Date: Jan 2012
Location: Houston, Texas, Texas
Posts: 2,248
There is no point in making a sticky. When the WK2 in 2010 there were issues and there was no need for a Sticky. Just add to this one. If we stickied every thread like this upon request the first page would be nothing but stuff like this. We already have 8 Stickies which already on the edge of being too many because it takes away from the new threads being started.

Edit: With this thread already started with the same issue there is no point in having another one.

__________________

'12 Laredo V6 ORA1|Terra Grappler 265-70-17|MB TKO 17x8.5|Silverstar Ultra low beams|Mopar Front and Rear WK2 slush mats|RRO 2.5" lift
BWoody extended sway bar links|K&N 77 Series Intake|Gibson Exhaust | Viair OBA | RRO Combo Winch mount| Q9000S winch| KC ProSport HID Hilites


Items for sale. See my thread for pictures. PM for details.


K&N 77 series cold air intake

Cobra 75 CB radio
Jackal01 is offline   Reply With Quote
Unread 07-13-2013, 06:39 PM   #32
blkvette94
Registered User
 
Join Date: Jul 2013
Location: Tampa, FL
Posts: 21
copy on the sticky.. Can we change the original title of this post to 2014 grand Cherokee issues or problems?
Many of these things might not be assumed as electrical only.
blkvette94 is offline   Reply With Quote
Unread 07-13-2013, 06:52 PM   #33
loveracing1988
Registered User
 
Join Date: Jan 2013
Posts: 660
Quote:
Originally Posted by blkvette94 View Post
copy on the sticky.. Can we change the original title of this post to 2014 grand Cherokee issues or problems?
Many of these things might not be assumed as electrical only.
I'm pretty sure this thread was created for electrical problems only, not every single problem your having with the vehicle...
loveracing1988 is offline   Reply With Quote
Unread 07-13-2013, 07:18 PM   #34
Jackal01
Moderator
 
Jackal01's Avatar
2012 WK 
 
Join Date: Jan 2012
Location: Houston, Texas, Texas
Posts: 2,248
Quote:
Originally Posted by blkvette94 View Post
copy on the sticky.. Can we change the original title of this post to 2014 grand Cherokee issues or problems?
Many of these things might not be assumed as electrical only.
I don't have a problem editing the title. I'll change it if the OP is ok with it. You should PM them.
__________________

'12 Laredo V6 ORA1|Terra Grappler 265-70-17|MB TKO 17x8.5|Silverstar Ultra low beams|Mopar Front and Rear WK2 slush mats|RRO 2.5" lift
BWoody extended sway bar links|K&N 77 Series Intake|Gibson Exhaust | Viair OBA | RRO Combo Winch mount| Q9000S winch| KC ProSport HID Hilites


Items for sale. See my thread for pictures. PM for details.


K&N 77 series cold air intake

Cobra 75 CB radio
Jackal01 is offline   Reply With Quote
Unread 07-13-2013, 08:11 PM   #35
gabbagabba
Registered User
2014 WK 
 
Join Date: Jan 2013
Location: Southwest, NH
Posts: 384
vote

please do not change the title. It does appear so far that the main issue with the very first generation of the 2014's is electrical issues. other people may bring up other issues which should be a different thread
gabbagabba is offline   Reply With Quote
Unread 07-13-2013, 08:16 PM   #36
Jackal01
Moderator
 
Jackal01's Avatar
2012 WK 
 
Join Date: Jan 2012
Location: Houston, Texas, Texas
Posts: 2,248
Quote:
Originally Posted by gabbagabba View Post
please do not change the title. It does appear so far that the main issue with the very first generation of the 2014's is electrical issues. other people may bring up other issues which should be a different thread
I agree with that more. Just throwing out the other option. It would actually be more work to go through and merge all the '14-problem threads than to just start new ones. I say leave everything as is.
__________________

'12 Laredo V6 ORA1|Terra Grappler 265-70-17|MB TKO 17x8.5|Silverstar Ultra low beams|Mopar Front and Rear WK2 slush mats|RRO 2.5" lift
BWoody extended sway bar links|K&N 77 Series Intake|Gibson Exhaust | Viair OBA | RRO Combo Winch mount| Q9000S winch| KC ProSport HID Hilites


Items for sale. See my thread for pictures. PM for details.


K&N 77 series cold air intake

Cobra 75 CB radio
Jackal01 is offline   Reply With Quote
Unread 07-14-2013, 08:51 AM   #37
ttk104
Registered User
2014 WK 
 
Join Date: Jul 2013
Location: Washington, D.C., DC
Posts: 6
Quote:
Originally Posted by JeepCares View Post
Here is a thread on the FUEL ECONOMY(ECO) MODE light color: http://www.jeepforum.com/forum/f309/eco-mode-1547090/
Maybe I am not going crazy then. Thanks. I'll move my discussion to the other thread.
ttk104 is offline   Reply With Quote
Unread 07-15-2013, 08:30 PM   #38
Quinnlindemann
Registered User
2014  
 
Join Date: Jun 2013
Location: Ocean, NJ
Posts: 2
Quote:
Originally Posted by mark090852 View Post
You mentioned that the backup camera stays on while in drive. How long does it stay on? There is a setting that you can enable or disable that keeps it on for about 10 seconds after switching into drive.
Totally understand that it stays on for a couple seconds after putting the car back in drive. My screen (before it was replaced) would have the camera on for a hour long drive and not turn off... At about a distraction!

For everyone having issues, I would recommend contact chrysler consumer care ( the number is in the owners manual) and opening tickets with all the issues that are going on. I called them several times and brought the car back to the dealership to get things worked out, but when I didn't see/ get results I was able to escalate the issues and finally get it repaired. I also was able to get my first month's payment reimbursed since it wasn't functioning properly.
Quinnlindemann is offline   Reply With Quote
Unread 07-23-2013, 03:43 AM   #39
petersara
Registered User
 
Join Date: Jul 2013
Location: sydney, nsw
Posts: 2
petersara

my 3 week old 2014 grand cherokee limited is about to be towed for the second time , Had total electronic and engine shut down while driving ,luckily wasnt on the f3 yet(with family) could have been fatal , they siad it was fixed and now now getting towed from armidale ,
Do not buy a new jeep , they are a death trap
petersara is offline   Reply With Quote
Unread 07-23-2013, 07:09 AM   #40
StaticFX
Registered User
 
Join Date: Jun 2013
Posts: 47
Quote:
Originally Posted by phatasswk View Post
Long-time Jeep owner, just bought a brand new 2014 WK2 Summit on 7/19/13. After two days of ownership, it is already at the dealership because I can no longer stand by and ignore the reality blaring in my face. The dealership has been great SO FAR in supporting me on this, but then, they should be when a vehicle with a $55k sticker price is off the road after two days. I'm now pimping a Chrysler 200... Seems like I'll be driving this indefinitely until all of the following is ironed out.

So far, my summary of issues are as follows:

Scratch on chrome under DS window

Scratch on PS front door by lock/unlock buttons

Scratch on rear bumper pad and chrome

Scratches on drivers-side lower door opening chrome trim

Grille inserts loose and rattling while driving

Drivers-side panel in cargo area improperly fastened and falling off

Pleather seat cover coming off bottom rear center cushion

Drivers-side rear door - dust in paint

Trim on center console misaligned, loose, and door on console is jammed

Adhesive attaching all painted cladding around wheel arches to the body is coming loose, and popping up

Sirius/XM mode on radio will stick on stations, cannot change channel on-screen or with steering wheel-mounted controls.

-

Absurd... I guess I just thought that the Fiat-Chrysler was reborn, as indicated in every other 2011+ Jeep I've owned, but yet here we are, another problem-riddled Chrysler product in my garage... Or, no, I'm sorry, another problem-riddled Chrysler product in the dealership's garage, and a POS rental car in MY garage. God, I can't wait for that inevitable call from Chrysler in the next few days asking how my new 'best of what they're made of' Jeep is working out for me. The word 'abortion' comes to mind...
Many of those items you should have seen and complained about before you even took the jeep, BUT.. in reality - it should not have left the factory like that. You buy a new car and you expect it to be perfect. Whether its a KIA or a Jeep or Lexus... its brand new! it should be perfect.

The radio needs the 13.19.0 update and that will fix the SXM issue as well as many other issues. MAKE SURE THEY DO THIS!!


I have had lots of radio issues. Freezing, blacked out, 911 screen, etc... I updated to 13.19.0 and it helped, but not completely. The dealer had me disconnect the battery for 20 mins as a last test. If that doesnt help, they are ordering a new one.


Heres what you need to know:

TSB: 08-049-13
NOTE: This bulletin applies to vehicles built on or before June 15, 2013 (MDH
0615XX) equipped with SMART TOUCH 3 AM/FM/SAT/BT/VOICE (sales code
RA3) or SMART TOUCH 4 AM/FM/SAT/BT/NAV/VOICE (sales code RA4).
SYMPTOM/CONDITION:
A customer may experience, one or more of the following conditions.
Radio reset, screen lockup, blank screen or sluggish system response time.
Loss of vehicle position on NAV map.
Compass indicator turns off.
Erratic changes to vehicle icon on NAV map.
Touch screen shut down message.
Radio surround sound will not stay ON.
Driver memory feature causes Sirius XM failure.
Loss of radio presets.
Battery drain - due to radio remains on.
Uconnect apps don't load.
AM/FM popping noises and/or static.
Backup camera display is blank.
StaticFX is offline   Reply With Quote
Unread 07-23-2013, 01:12 PM   #41
mwc3116
Registered User
2011 JK Wrangler 
 
Join Date: Jan 2012
Location: Shippenville, PA
Posts: 1
I purchased my 2014 Jeep Grand Cherokee Summit at the end of April. On the way home from purchasing it, the service engine soon light came on. I took it to the local dealership (not where I bought it) and they told me that a knock sensor wire was loose. It was fixed and the light was off for two weeks before it came on again along with the radio phone/911 error on the touchscreen. I then took it to the dealership I purchased it at. They reset the service engine light to turn it off and ran multiple tests to try to get it to come on. It remained off until I started it up to drive home. As far as the Radio/Phone problem, they didn't have an answer. They sent me home in a loaner. After about 3 days I went back to pick it up and found out that the service engine light was due to a bad coil pack and was fixed. For the radio problem, they said they were going to order a new one. About a week later, I went back to the purchasing dealership and they told me that Chrysler told them that only a software update was needed. After 2 hours of waiting, the update was completed but the radio/phone error kept coming up. Then again, they told me that a new radio was being ordered. I went down about a week later and the new radio was installed. On the way home, the radio/phone error came up. I live in a rural area and the dealership I have been going to is about a hour away. Saying that I am not happy is an understatement. One of the reasons for buying a new vehicle is to prevent from having problems to deal with. I know everything can't be perfect and I don't have a huge problem with the Service Engine Light being fixed. This radio error message problem is completely unacceptable.
mwc3116 is offline   Reply With Quote
Unread 07-23-2013, 03:58 PM   #42
kloubik
Registered User
2014 WK 
 
Join Date: Jan 2011
Location: Santa Clara, CA
Posts: 114
I traded my 2004 WJ for 2014 Grand Cherokee 2 weeks ago. I have to admitt I was expecting the facelift model to be more bug free as the car is at the second half of the product cycle now. I still like the car but man this car is Jeep's flagship. This should not happen.

So far I have been dealing with following issues:
- climate controls would sometimes randomly switch and control temperature at the opposite side of the car
- the bluetooth is constantly loosing connection with my Samsung Galaxy S3 making audio streaming almost impossible (no problem with the same phone in other cars)
- remote start will turn the climate off making this feature basically useless (no fix from chrysler after 4 months)
- the ECO mode that comes ON with every start is so frustrating.....it is so agressive that sometimes I feel like the engine will stall going uphill....and when you push more on gas nothing happens the trans stays in highest geer possible until the rev are like below 1k rpm
- transmission thud/jerk when stopping or shifting from 1st do 2nd gear
- the user guide lists Pandora and iHeart radio app as available in uconnect store but no apps available

I thought chrysler has been using this 8.4" unit in other cars for over a year now (at least in chrysler 300, maybe 200 or some Dodge models too). How come there are so many bugs?

Also, I wish it was possible to switch units to Metrics just for temperature and keep everything else (mpg, mileage, speed, etc.) in US units as in our other car but I guess I cannot have it all Hopefully the bugs above will be fixed soon.
kloubik is offline   Reply With Quote
Unread 07-23-2013, 09:07 PM   #43
ronfin44
Registered User
 
Join Date: Aug 2007
Location: Philadelphia
Posts: 8
Noticed right away that my backup camera has this weird shake and ghosting look to it. Images seem to flicker as I'm backing up? Normal, or is this a glitch they can fix?
ronfin44 is offline   Reply With Quote
Unread 07-24-2013, 05:57 AM   #44
jahlinux
Registered User
 
Join Date: Jul 2013
Location: Stonington, CT
Posts: 2
I just purchased my Grand Cherokee yesterday and it has software version 13.05.3. Hard to believe it would leave the lot brand new with outdated software. Can the the updates be installed by owners, or are they only installed by dealers?
jahlinux is offline   Reply With Quote
Unread 07-25-2013, 08:49 AM   #45
blkvette94
Registered User
 
Join Date: Jul 2013
Location: Tampa, FL
Posts: 21
I gave up. put a lawyer on retainer and filed the lemon law paperwork Monday. They knowingly sent out broken cars to the dealers. I'm not talking about a few scratches. I mean really broken stuff. Collision warnings systems inop, nav that takes me miles out into the water, park sense systems in op.. The list goes on for all of us.
With all the issues I can't recommend anyone do any software updates themselves. Make the dealers do their job.. It's what you paid for! plus that way when the problems still exist you can't be blamed for them.


I really think it's time for a class action lawsuit.

Any body else in?
blkvette94 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.