2014 Grand Cherokee - Electrical problems? - Page 2 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK2 Grand Cherokee Forum > 2014 Grand Cherokee - Electrical problems?

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineThe ULTIMATE "Selectable" Locker System! BroughFS: 2007-2013 Jeep Wrangler "HALO" Angel Eye Kit

Reply
Unread 06-20-2013, 08:21 AM   #16
MickinNY
Registered User
2013 WK 
 
Join Date: Sep 2012
Location: Churchville, NY
Posts: 450
Quote:
Originally Posted by chrisstarmont View Post
My 2014 Summit has had to have a new radio put in after 1200 miles. The bigger issue is the dealer can't get the radio and has had it for a week now! I traded my 2011 GC in on a 2014 and wish I had not. Why is Jeep selling product they can't back up?
OK, I have to ask. Why is the Jeep sitting at the dealer for a week if he can't get the radio? Wouldn't it be better to just drive the Jeep & set up the appointment when the radio comes in?

MickinNY is offline   Reply With Quote
Unread 06-22-2013, 03:54 AM   #17
picflight
Registered User
1996 ZJ 
 
Join Date: Jun 2010
Location: Los Angeles
Posts: 47
Quote:
Originally Posted by loveracing1988
My wife's also makes a popping noise, but it is only on one station which is kind of weak. I have also never heard static out of it either.
My wife too, but it is all stations and static is ALL I hear.

1996 Grand Cherokee 4x4 V8 5.2L Up Country Laredo
picflight is offline   Reply With Quote
Unread 06-22-2013, 12:26 PM   #18
Quinnlindemann
Registered User
2014  
 
Join Date: Jun 2013
Location: Ocean, NJ
Posts: 2
I purchased a 2014 GC limited with the luxury package on 5/14/13 and experienced issues with my touch screen the first day. After fighting with the dealership and chrysler consumer care for 4 weeks it was finally replaced. However, 6 days later its now not functioning again and I am livid!

Problems I have seen with mine :
Backup camera stays on while in drive
Climate controls are reversed ( ie passenger controls driver side)
Volume controls don't work
System resets itself randomly and multiple times
Clock doesn't keep time
Screen freezes and won't reset after car is turned off.
Touch screen when it is functioning, is severely delayed.
Quinnlindemann is offline   Reply With Quote
Unread 06-22-2013, 03:03 PM   #19
mark090852
Registered User
 
Join Date: Apr 2013
Location: Warriors Mark, PA
Posts: 18
Quote:
Originally Posted by Quinnlindemann View Post
I purchased a 2014 GC limited with the luxury package on 5/14/13 and experienced issues with my touch screen the first day. After fighting with the dealership and chrysler consumer care for 4 weeks it was finally replaced. However, 6 days later its now not functioning again and I am livid!

Problems I have seen with mine :
Backup camera stays on while in drive
Climate controls are reversed ( ie passenger controls driver side)
Volume controls don't work
System resets itself randomly and multiple times
Clock doesn't keep time
Screen freezes and won't reset after car is turned off.
Touch screen when it is functioning, is severely delayed.
You mentioned that the backup camera stays on while in drive. How long does it stay on? There is a setting that you can enable or disable that keeps it on for about 10 seconds after switching into drive.
mark090852 is offline   Reply With Quote
Unread 06-22-2013, 10:06 PM   #20
MIJGC
Registered User
2014 FSJ Cherokee 
 
Join Date: Jun 2013
Location: Seattle, Wa
Posts: 1
Exclamation Major electrical problem

I got my 2014 limited and drove it less than 500 miles before it started slipping gears and kicking in and out of 4wd. Twice the vehicle shifted itself into neutral while it was moving - very dangerous. I took it to the dealer and they kept it for almost a week. They told me they were arguing with "Chrysler engineers". Finally I got it back - they claim it was a loose ground wire, we will see. Even worse, they used 1/8 tank of gas and did not even wash the car. Not great service vs other dealers, I give a mediocre recommendation at best to Bellevue jeep...
MIJGC is offline   Reply With Quote
Unread 07-09-2013, 12:36 PM   #21
ttk104
Registered User
2014 WK 
 
Join Date: Jul 2013
Location: Washington, D.C., DC
Posts: 6
I bought a Limited V6 on Sunday. I was driving home from work last night with 40 miles on odometer. I felt a downshift, the engine light went on, and I could not get past 4th gear nor shift into Sport mode to change gears manually. I drove a couple more miles and turned car off for an hour. When I restarted the shifting seemed back to normal but the check engine light was still on and the Eco Mode button had turned orange.

I went to the dealer this morning and they upgraded the software. That seemed to fix the CEL but the Eco Boost button light is still orange. I can turn it off but it will not turn back to green, like it was for the first 40 miles. No one at the Dealer even knows what the orange light means let alone can get it to turn off. There is no mention of the button color in the manual.

Does anyone have an idea of what the orange light means. I'm guessing it means Eco Mode doesn't work. I am not sure if that is a sign of bigger problems or I just can't set that mode.
ttk104 is offline   Reply With Quote
Unread 07-09-2013, 12:54 PM   #22
jacko15
Registered User
2014 WK 
 
Join Date: Oct 2008
Location: Pennsylvania's North Shore
Posts: 659
Why isn't your dealer contacting Chrysler for tech support?
__________________
Hers: 2008 Jeep Compass Sport
Mine: 2014 Jeep Grand Cherokee Overland V/6 ORA II
Michelin LTX M/S 2's
jacko15 is offline   Reply With Quote
Unread 07-09-2013, 12:56 PM   #23
ttk104
Registered User
2014 WK 
 
Join Date: Jul 2013
Location: Washington, D.C., DC
Posts: 6
Quote:
Originally Posted by jacko15 View Post
Why isn't your dealer contacting Chrysler for tech support?
They are checking, I was hoping to find an answer more quickly.
ttk104 is offline   Reply With Quote
Unread 07-09-2013, 01:29 PM   #24
loveracing1988
Registered User
 
Join Date: Jan 2013
Posts: 560
Quote:
Originally Posted by ttk104 View Post
I bought a Limited V6 on Sunday. I was driving home from work last night with 40 miles on odometer. I felt a downshift, the engine light went on, and I could not get past 4th gear nor shift into Sport mode to change gears manually. I drove a couple more miles and turned car off for an hour. When I restarted the shifting seemed back to normal but the check engine light was still on and the Eco Mode button had turned orange.

I went to the dealer this morning and they upgraded the software. That seemed to fix the CEL but the Eco Boost button light is still orange. I can turn it off but it will not turn back to green, like it was for the first 40 miles. No one at the Dealer even knows what the orange light means let alone can get it to turn off. There is no mention of the button color in the manual.

Does anyone have an idea of what the orange light means. I'm guessing it means Eco Mode doesn't work. I am not sure if that is a sign of bigger problems or I just can't set that mode.
Ours has always been orange...
loveracing1988 is offline   Reply With Quote
Unread 07-09-2013, 04:42 PM   #25
mark090852
Registered User
 
Join Date: Apr 2013
Location: Warriors Mark, PA
Posts: 18
Quote:
Originally Posted by loveracing1988 View Post
Ours has always been orange...
Ours, too, has always been orange when it is on. The light goes out when we turn ECO off.
mark090852 is offline   Reply With Quote
Unread 07-10-2013, 08:23 AM   #26
ttk104
Registered User
2014 WK 
 
Join Date: Jul 2013
Location: Washington, D.C., DC
Posts: 6
Maybe I was in some state of new Jeep euphoria for a day and thought it was green. I will check another the next time I go to the dealer. Thanks for making me doubt my sanity.

Beyond the orange light, the software update seems to have cleared up the CEL and no more problems with the transmission.
ttk104 is offline   Reply With Quote
Unread 07-10-2013, 02:38 PM   #27
bilbo_28
Registered User
2014 WK 
 
Join Date: Oct 2006
Location: NJ, USA
Posts: 149
I've only ever had an orange "Eco" button light... unless I turn it off!
bilbo_28 is offline   Reply With Quote
Unread 07-10-2013, 11:11 PM   #28
blkvette94
Registered User
 
Join Date: Jul 2013
Location: Tampa, FL
Posts: 21
2014 Jeep Grand Cherokee summit, 5.7L with tow. Yep that is one step down from the Uber top of the line so I had expectations...

Nicknamed "Sybil"

Strange too. I know my Jeep isn't a Chrysler 300, but my parents have a 2012 300 with the same 8.4 Uconnect and all the same safety features. It works fine..

Less than 1000 Miles.
Wonky just about describes it. We are on the second radio with no changes.

Issues to date:
--Nav/radio randomly reboots
--Nav has completely lost me and put me in the middle of the harbor
--Randomly the check marks disappear. Randomly they reappear.
--AC doesn't come on when vehicle is remotely started.
--Radio settings don't change for occupant one or two-- then again sometimes it changes just cause!
--Xm service sometimes takes 30 seconds or more to load.. Even when sitting in a walmart parking lot. Whiles it's loading the reverse camera doesn't activate.
--The collision warning and adaptive cruise randomly say they are active or inactive.. Sometimes they don't do anything.
-- Gotten two vehicle needs service 911 messages
--On second message I had the vehicle call uconnect assist. The girl on the other end hung up on me after I refused to provide my VIN. I'm sorry but I'm driving I can't go digging for that info.. and PS the console said it was sending the vehicles information.. I guess Jeep isn't ready to get into the luxury market?? PS Jeep-- GO sit in a Cadillac and hit the Onstar button and see how you are greeted..just saying.

I am 1 more visit from telling the dealer I don't feel safe driving my family in the vehicle and giving them a very limited set of options.. I paid $48K for it and the dealer is giving me a dodge avenger POS with 50K miles on it to drive while they try to figure it out..Sad part is this is my first jeep and I sold my ford escape for it.. Beginning to feel like I am stuck.. Only saving grace is a dealer ship that is trying.. but with Jeep failing there is only so long I can be "understanding".

Anyone else want to look into a class action suit?
blkvette94@yahoo.com

Last edited by blkvette94; 07-10-2013 at 11:28 PM..
blkvette94 is offline   Reply With Quote
Unread 07-11-2013, 12:57 PM   #29
JeepCares
Registered User
 
Join Date: Jan 2012
Location: MOPAR World Headquarters, Chrysler Group LLC
Posts: 2,288
Quote:
Originally Posted by ttk104 View Post
Does anyone have an idea of what the orange light means. I'm guessing it means Eco Mode doesn't work. I am not sure if that is a sign of bigger problems or I just can't set that mode.
Quote:
Originally Posted by jacko15 View Post
Why isn't your dealer contacting Chrysler for tech support?
Quote:
Originally Posted by ttk104 View Post
They are checking, I was hoping to find an answer more quickly.
Here is a thread on the FUEL ECONOMY(ECO) MODE light color: http://www.jeepforum.com/forum/f309/eco-mode-1547090/
__________________
Lee
U.S. Top Care
Chrysler Group LLC
JeepCares is offline   Reply With Quote
Unread 07-11-2013, 03:05 PM   #30
blkvette94
Registered User
 
Join Date: Jul 2013
Location: Tampa, FL
Posts: 21
Can we get a sticky listing members and 2014 Grand Cherokee problems?

I think the issues many of us are having with our 2014 Jeep Grand Cherokees will need to go to court or arbitration. We need to have a single location to consolidate these issues so we can demand a recall. I have already started a NHTSA file. Please don't use foul language and keep it only to the facts as you would be willing to back up in court.

I'll start. We have had the vehicle in for service twice already...once for a software update. Second time for a new U connect unit. Nothing has changed.

Within a few days of delivery here is what I have had occur.
Issues to date:
--Nav/radio randomly reboots
--Nav has completely lost me and put me in the middle of the harbor
--Randomly the check marks disappear. Randomly they reappear.
--AC doesn't come on when vehicle is remotely started. It was set to auto and 74 on shut down.
--Radio settings don't change for occupant one or two-- then again sometimes it changes just cause!
--Xm service sometimes takes 30 seconds or more to load.. Even when sitting in a walmart parking lot. While it's loading the reverse camera doesn't activate. The delay timer is not checked.
--The collision warning and adaptive cruise randomly say they are active or inactive.. Sometimes they don't do anything. It doesn't matter if the manual button on the dash is illuminating as on/off or not.
-- Gotten two vehicle needs service 911 messages. First for an update second for vehicle phone inop.
-- On second message I had the vehicle call uconnect assist. The girl on the other end hung up on me after I refused to provide my VIN. Upon second Call I got a "manager" and they helped. But after several conversations calling U connect can't resolve this problem. They have to go through the star service order the dealer has set up.
blkvette94 is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.