2014 Grand Cherokee - Electrical problems? - Page 13 - JeepForum.com

LinkBack Thread Tools
post #181 of 190 Old 06-19-2014, 07:36 PM
Registered User
Join Date: Jun 2014
Location: Harrisburg
Posts: 1
Please help me

Did this fix your error? I'm on my third radio. My GC has 6000 miles. It's at dealership now - where it's been three days waiting for somebody at Chrysler to help. Every time they replace a radio I get the error message within 9 - 12 days again.

Any help would be appreciated. I want my car back!!

QUOTE=StaticFX;15720663]i would take that bet!!

go back and look at my post. These are known issues. there is a software update to fix many of these - but in a number of cases the software is not fixing it and anew radio is required. I am one of these people (radio finally on order)
for those of you with 13.05 - i'll bet you will need a new radio no matter what lol..

im going to start a new thread with this info too

You need to update to 13.19.0 you can find this out there on the net (or ask the dealer for it) and you CAN do this on your own.
then after you update.. wait a few days... then unhook the battery (negative) for 20-30 minutes (to reset) <Jeep will want you to do this also.. so might as well do it yourself. Battery is under the passenger seat

if you still have issues, you can now tell them you have done everything and its time to order a new radio.

any radio built before 6/15/2013 can have these issues. Many times the update will fix it.. but many times it wont.
I just went through a week of back and forth with my dealer, finally have a new radio on order.

also... if you get the 911 error "Vehicle Phone requires service" you have a bad Sierra Wireless card.. you will need a new radio (do the above just to save yourself time - the dealer will do the same thing first)[/QUOTE]

jerihunnell is offline  
Sponsored Links
post #182 of 190 Old 08-27-2014, 11:46 AM
Registered User
2014 WK 
Join Date: Mar 2014
Location: Phoenix
Posts: 5
2014 Grand Cherokee Screen Radio Issues

Hi All,

I was just curious if anyone else is still having issues with the 8.4" screen and radio. My screen has gone completely dead two times now and the dealer has replaced entire unit two times. I've only had my GC for 6 months...

I'm worried the issue is never going to be fixed and dealer never wants to determine the cause of the problem. They take vehicle for an hour then tell me screen needs to be replaced. Very frustrating.

cjgibbs1985 is offline  
post #183 of 190 Old 08-28-2014, 09:04 AM
Registered User
Join Date: Aug 2013
Location: Joplin
Posts: 8
I got rid of my Jeep in May. I just couldn't stand it any longer.

Now I periodically get emails and letters from Jeep or Jeep dealerships that have been servicing the vehicle. I guess the new owner is having the same problems I was. Poor sap.
Kamauxx is offline  
post #184 of 190 Old 09-07-2014, 11:13 AM
Registered User
1979 CJ7 
Join Date: Mar 2013
Location: Naples
Posts: 35
2014 Overland woes

The AC on my 2014 Grand Cherokee makes intermittent loud grinding noises accompanied by major vibrations. Additionally the electric engine cooling fan, that comes on @ 210 degrees, cycles up and down, and is audible inside the vehicle when stopped. Has anyone else experienced this ?
My JGC had a new transmission installed at 8,000 miles and has had the usual plethora of electronic bugs that seem to plague early build date units. Right now I have 3 factory recalls open (in addition to the prior ones).
Love the Jeep, but starting to seem like a lemon.....
baseball95 is offline  
post #185 of 190 Old 11-17-2014, 02:25 PM
Registered User
2014 WK 
Join Date: May 2011
Location: Winnipeg
Posts: 20
I have experienced #4 but only a few times. I have a bigger problem with my tranny. Only have 4600kms (2800m) on my GC Laredo. Go back to dealer.
LibertyJ is offline  
post #186 of 190 Old 11-20-2014, 09:01 PM
Registered User
Join Date: Dec 2013
Location: Bay Shore
Posts: 18
I finally contacted Jeep Corporate Customer service for help. 2014 JGC Summit and LOADS of electrical problems. The rep on the phone, using my VIN#, found all the service visits with both dealerships back starting June 2103 the second month I had owned it where they changed the entire gas tank and multiple gas fillers/pipes- 8 months having the same problem.
Basicly, ball is in their court. I'm done going back to service dept to fix ANOTHER problem. Now my interior fan blower motor hums LOUD inside. I don't know what they're going to do but I want to avoid hiring a lawyer and doing the legal route but I have a lemon the size of KING KONG.
aquabear is offline  
post #187 of 190 Old 12-18-2014, 06:23 PM
Registered User
Join Date: Dec 2014
Posts: 1

I bought my 14 Jeep cherokee limited 6 mths ago....always had horrible static in radio...just started having power issuees...when i pressed gas it hesitates....now my doors won't lock..only manually by me... Went to shop friday and they said the part f(dcw or soemthing) ....only one available in US??? and they will try and get there hand on it...yea sure.....the said if not it will be on BO prob till late jan....so he said come get your car it is safe to drive...take my horrible rental ( they only wll let us rent chrysler vehicles) back...and get in my car and seat wont move now!!!!! get into another rental...at my witts end...been a week w/o my car and chrysler Customer service is not very helpful....anyone had this issue yet??
christycadeb is offline  
post #188 of 190 Old 04-23-2015, 11:55 AM
Registered User
Join Date: Apr 2015
Location: Vancouver
Posts: 22
Is the 2014 Limited still having a lot of issues? Im looking to pick one up soon, anything I should know about? Is there any fix for these issues yet? Thanks!
jd100 is offline  
post #189 of 190 Old 05-27-2015, 03:35 PM
Registered User
Join Date: May 2015
Posts: 1
Originally Posted by ttk104 View Post
I bought a Limited V6 on Sunday. I was driving home from work last night with 40 miles on odometer. I felt a downshift, the engine light went on, and I could not get past 4th gear nor shift into Sport mode to change gears manually. I drove a couple more miles and turned car off for an hour. When I restarted the shifting seemed back to normal but the check engine light was still on and the Eco Mode button had turned orange.

I went to the dealer this morning and they upgraded the software. That seemed to fix the CEL but the Eco Boost button light is still orange. I can turn it off but it will not turn back to green, like it was for the first 40 miles. No one at the Dealer even knows what the orange light means let alone can get it to turn off. There is no mention of the button color in the manual.

Does anyone have an idea of what the orange light means. I'm guessing it means Eco Mode doesn't work. I am not sure if that is a sign of bigger problems or I just can't set that mode.
mine has always been orange, and it works.. not sure...
dg06 is offline  
post #190 of 190 Old 05-29-2015, 06:01 AM
Registered User
Join Date: May 2015
Location: Marlboro
Posts: 1
Are the problems also happening in 2015's? Anyone experience issues or care to share what's wrong with 2015 models.
ST2015 is offline  

Quick Reply

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome