2012 GJC smoking on startup - JeepForum.com

 
LinkBack Thread Tools
post #1 of 6 Old 05-11-2013, 05:44 PM Thread Starter
WeBeCinYa
Registered User
 
Join Date: Jan 2012
Location: Denver
Posts: 71
2012 GJC smoking on startup

Our 2012 Grand Cherokee Laredo is smoking on startup. This has happens twice that I have noticed when wife is backing out of garage. Smoke cloud is blue tint which says oil to me. Only 4k miles on the V6. Only 2 oil changes, last one 1k miles ago. Any thoughts? Will warranty cover?


2012 WK2 Laredo Stone White, QTII, Leather, 20" Overland wheels, 275/55/20, All weather pkg, towing pkg
1942 Ford GPW Military Jeep
WeBeCinYa is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 05-11-2013, 09:31 PM
AKHLK
Registered User
 
Join Date: Sep 2012
Location: Anchorage
Posts: 36
Search "Blue Smoke at Startup?"on this forum, or go to ********** and search "Major smoke out of exhaust" thread with 225 posts.
AKHLK is offline  
post #3 of 6 Old 05-11-2013, 09:32 PM
AKHLK
Registered User
 
Join Date: Sep 2012
Location: Anchorage
Posts: 36
Quote:
Originally Posted by AKHLK
Search "Blue Smoke at Startup?"on this forum, or go to ********** and search "Major smoke out of exhaust" thread with 225 posts.
Edit: wont let me post name of other major jeep forum.
AKHLK is offline  
post #4 of 6 Old 05-12-2013, 06:26 AM
ColdCase
My Reality Check Bounced
 
ColdCase's Avatar
2011 WK 
 
Join Date: Sep 2009
Location: New England
Posts: 7,696
Most of those posts were V8s and there is a fix for that... or did I miss the V6 part.

Check that the oil level is not overfilled... and I would report it to the dealer.

Current: 2011 Grand Cherokee Overland V8, 2009 Liberty Rocky Mt V6
Previous: 2000 Grand Cherokee Laredo I6, 1979 CJ7 I6 Quadratrac
ColdCase is offline  
post #5 of 6 Old 05-12-2013, 08:12 AM Thread Starter
WeBeCinYa
Registered User
 
Join Date: Jan 2012
Location: Denver
Posts: 71
I read the other thread and it seemed those were V8s, mine is the V6. Taking it to the dealer next week but I wanted to have the upper hand on possible causes as I figure the dealer will just do nothing.

2012 WK2 Laredo Stone White, QTII, Leather, 20" Overland wheels, 275/55/20, All weather pkg, towing pkg
1942 Ford GPW Military Jeep
WeBeCinYa is offline  
post #6 of 6 Old 05-12-2013, 01:53 PM
AKHLK
Registered User
 
Join Date: Sep 2012
Location: Anchorage
Posts: 36
Sorry, missed the V6 part. Hope it gets resolved.
AKHLK is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome