2011 Radio Issues - JeepForum.com

LinkBack Thread Tools
post #1 of 4 Old 04-16-2016, 06:03 PM Thread Starter
Registered User
2008 WK 
Join Date: Sep 2013
Location: Jenison
Posts: 36
2011 Radio Issues

Have an issue with my '11 that I can't seem to find any previous threads on. Hoping one of you can help..

My stereo every now and then will make an audible popping sound through the speakers and immediately following there will no longer be any volume control. The only way to get the sound to work again is to turn the vehicle off and wait a couple min and turn it back on. When I originally noticed it, it could go about 45 minutes before popping and turning off. Now that it's warmer it can only go about 15 minutes.

Any thoughts? Not sure if this is simply a head unit issue that's on it's way out and needs to be replaced or something more involved.

08GC21 is offline  
Sponsored Links
post #2 of 4 Old 04-16-2016, 06:29 PM
Registered User
2012 WK 
Join Date: Jul 2012
Location: Bucks County
Posts: 1,419
Identifying which system will help folks help you...430N or 730N? If the latter, it may still be on old firmware. The most current (and likely last) version is 2.60. I can't help if it's the former.

2012 JGC Summit Hemi
2016 Subaru Outback Limited
2011 Subaru Outback Limited
jim_in_PA is offline  
post #3 of 4 Old 04-16-2016, 06:38 PM Thread Starter
Registered User
2008 WK 
Join Date: Sep 2013
Location: Jenison
Posts: 36
Honestly not even sure how to tell. It's an '11 Laredo. I believe it's the RES 130S. Single disc MP3 w/ Sirius.
08GC21 is offline  
post #4 of 4 Old 04-16-2016, 07:19 PM
My Reality Check Bounced
ColdCase's Avatar
2011 WK 
Join Date: Sep 2009
Location: New England
Posts: 8,295
Sounds like a head unit issue, I don't think the base radio has any external amps. Perhaps check with the guys at www.navrepair.com or www.mygig-disk.com.

Current: 2011 Grand Cherokee Overland V8, 2009 Liberty Rocky Mt V6
Previous: 2000 Grand Cherokee Laredo I6, 1979 CJ7 I6 Quadratrac
ColdCase is offline  

Quick Reply

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome