'11 GC: TSB for Rough Shift From N-D (18-049-11) Not Fixed After Dealer Reflash?? - Page 3 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Grand Cherokee & Commander Forums > WK2 Grand Cherokee Forum > '11 GC: TSB for Rough Shift From N-D (18-049-11) Not Fixed After Dealer Reflash??

Labor day sale @ rockridge 4wd! 8/29-9/1 site wide..promo Rough Country Deals at JeepHut.comShocktober is here! Get new shocks for your Jeep!!!!

Reply
Unread 04-30-2013, 02:47 AM   #31
zamerzant
Registered User
2012 WK 
 
Join Date: Aug 2011
Location: As suleymaniah, Iraq/kurdistan
Posts: 22
i had a 2011 3.6L pentastar CG n it didnt have any of those problems but since i bought 2012 CG with hemi it started a week from driving it.
i contacted the dealer and he said its normal for hemi engines they all have the sound but no problems with it.

zamerzant is offline   Reply With Quote
Unread 04-30-2013, 06:08 PM   #32
txwest
Registered User
2012 WK 
 
Join Date: Apr 2010
Location: Texas
Posts: 434
There is a TSB fix. Had the tsb done on my '12 at about 15k. I'm at 33k, no noise, no issues. They replace the valve balls in the shift mechanism.

Sent from my S-III using JeepForum
__________________
Current:
'12 GC Overland 4x4 HEMI ORII QL Towing Red/Saddle

Past Jeeps:
'80 CJ-7 I6 4x4 Std
'86 Comanchee I4 4x4 Std
'99 WJ Laredo 4.0 4x4 AWD
txwest is offline   Reply With Quote
Unread 05-01-2013, 12:58 PM   #33
hobbie1
Registered User
2011 WK 
 
Join Date: May 2010
Location: Brentwood CA
Posts: 215
Quote:
Originally Posted by txwest View Post
There is a TSB fix. Had the tsb done on my '12 at about 15k. I'm at 33k, no noise, no issues. They replace the valve balls in the shift mechanism.

Sent from my S-III using JeepForum
Do you have the TSB# ?
__________________
2011 Overland 4X4 QDII QLII 5.7 - Adventure II
2012 RAM 2500 Cummins 4X4 Laramie Crew Cab
2005 Mercedes C-240 4-Matic
2013 Ford Mustang GT and 1966 Ford Mustang 289 5-SPD 289
hobbie1 is offline   Reply With Quote
Unread 05-01-2013, 01:06 PM   #34
txwest
Registered User
2012 WK 
 
Join Date: Apr 2010
Location: Texas
Posts: 434
http://www.wk2jeeps.com/tsb/tsb_wk2_2101012.pdf
__________________
Current:
'12 GC Overland 4x4 HEMI ORII QL Towing Red/Saddle

Past Jeeps:
'80 CJ-7 I6 4x4 Std
'86 Comanchee I4 4x4 Std
'99 WJ Laredo 4.0 4x4 AWD
txwest is offline   Reply With Quote
Unread 05-04-2013, 12:06 AM   #35
hobbie1
Registered User
2011 WK 
 
Join Date: May 2010
Location: Brentwood CA
Posts: 215
Quote:
Originally Posted by txwest View Post
They did the TSB on our Jeep today - was able to test it as it was close to 100 degrees today - The bang is gone - seems to be fixed!

Thanks for the tip!
__________________
2011 Overland 4X4 QDII QLII 5.7 - Adventure II
2012 RAM 2500 Cummins 4X4 Laramie Crew Cab
2005 Mercedes C-240 4-Matic
2013 Ford Mustang GT and 1966 Ford Mustang 289 5-SPD 289
hobbie1 is offline   Reply With Quote
Unread 05-04-2013, 12:07 AM   #36
hobbie1
Registered User
2011 WK 
 
Join Date: May 2010
Location: Brentwood CA
Posts: 215
Quote:
Originally Posted by zamerzant View Post
i had a 2011 3.6L pentastar CG n it didnt have any of those problems but since i bought 2012 CG with hemi it started a week from driving it.
i contacted the dealer and he said its normal for hemi engines they all have the sound but no problems with it.
FYI see below -the TSB fixed ours.....
__________________
2011 Overland 4X4 QDII QLII 5.7 - Adventure II
2012 RAM 2500 Cummins 4X4 Laramie Crew Cab
2005 Mercedes C-240 4-Matic
2013 Ford Mustang GT and 1966 Ford Mustang 289 5-SPD 289
hobbie1 is offline   Reply With Quote
Unread 05-04-2013, 08:03 AM   #37
txwest
Registered User
2012 WK 
 
Join Date: Apr 2010
Location: Texas
Posts: 434
Quote:
Originally Posted by hobbie1 View Post

They did the TSB on our Jeep today - was able to test it as it was close to 100 degrees today - The bang is gone - seems to be fixed!

Thanks for the tip!
Your very welcome!

I live in South Texas so I understand the high temps!

Sent from my S-III using JeepForum
__________________
Current:
'12 GC Overland 4x4 HEMI ORII QL Towing Red/Saddle

Past Jeeps:
'80 CJ-7 I6 4x4 Std
'86 Comanchee I4 4x4 Std
'99 WJ Laredo 4.0 4x4 AWD
txwest is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.