Yup, another sky slider problem... - JeepForum.com

Reply
 
LinkBack Thread Tools
post #1 of 16 Old 04-23-2013, 12:57 PM Thread Starter
88BlueGT
Registered User
 
Join Date: Jul 2011
Location: Hamilton
Posts: 33
Yup, another sky slider problem...

Hey guys,

So I've been having issues with wind noise with my sky slider that has been bugging the hell out of me but now that is the least of my worries.

So about a month ago I noticed that when I was driving my roof was lifting up and I could see outside the car, it obviously was not closed all the way. I stopped and wen't to close it. The motor is now making a noise that sounds like a machine gun and is stuck with no movement. I was able to 'lock' the roof down as it seems that one side (driver side rear) had come off the track and was not locked all the way. I thought that the motor was making this noise because it was not locked in but after locking it, nothing has changed.

Has anyone had this problem before? Sound like the motors shot? It's supposed to be going to the dealer next week but I'm very hesitant at $125/hr :/

Jeep is a 2008 KK.

Any help/suggestions is much appreciated!

88BlueGT is offline  
Sponsored Links
Advertisement
 
post #2 of 16 Old 04-23-2013, 02:47 PM
BettyHumpter
Registered User
2011 KK Liberty 
 
Join Date: Mar 2013
Location: Pittsburgh
Posts: 44
Sounds like the drive mechanism is shot.

Mine is a 2011 and i cleaned the tracks yesterday and i could not believe how much crap gets caught up in there. Do you clean the tracks often? I could see that crap building up and causing a problem.

I dont know of anyone else but the dealer that would want to look at that, unless you have some mechanical ability?
BettyHumpter is offline  
post #3 of 16 Old 04-23-2013, 04:36 PM
Gageraid
Registered User
2008 KK Liberty 
 
Join Date: May 2012
Location: Branchburg
Posts: 1,525
What did you use to clean the tracks? I should probably do this to mine A.S.A.P.
Gageraid is offline  
post #4 of 16 Old 04-24-2013, 09:23 AM
huntb
Registered User
2008 KK Liberty 
 
Join Date: Aug 2011
Location: Grand Haven
Posts: 630
Careful when "cleaning" the tracks. There is supposed to be grease in there so the roof slides easily
huntb is offline  
post #5 of 16 Old 04-29-2013, 10:55 AM Thread Starter
88BlueGT
Registered User
 
Join Date: Jul 2011
Location: Hamilton
Posts: 33
We'll, just a little update. I dropped it off at the dealer last night and was told that if the motor needs to be replaced I could be looking upwards of $3,000. Has anyone had to have this done before? If so, I would appreciate it if someone could give me some insight as to what they paid...parts, labor, etc. $3k seems extremely steep to me but I guess it really depends on the labor involved.
88BlueGT is offline  
post #6 of 16 Old 04-30-2013, 06:39 AM
huntb
Registered User
2008 KK Liberty 
 
Join Date: Aug 2011
Location: Grand Haven
Posts: 630
I imagine that to replace the motor all you need to do is lower the headliner in order to access it. I think there are a couple threads around here about how to remove the headliner IIRC
huntb is offline  
post #7 of 16 Old 04-30-2013, 11:25 AM Thread Starter
88BlueGT
Registered User
 
Join Date: Jul 2011
Location: Hamilton
Posts: 33
Well, the dealer contacted me and it's my luck that the issue would not be within the motor. The frame and cables need to be replaced at the cost of $2,800 + tax + fees :/

I contacted Chrysler looking for some assistance. I was assigned a case manager that is supposed to be in contact with me by the end of day today. The dealer is just holding my Jeep right now waiting for a response.

To be completely honest, I'm not sure if I should just take the hit, trade it in as is and buy a new vehicle or to fix it and be stuck wondering if the same problem is going to happen again some short time in the future. Damn man, problems problems problems.
88BlueGT is offline  
post #8 of 16 Old 04-30-2013, 01:23 PM Thread Starter
88BlueGT
Registered User
 
Join Date: Jul 2011
Location: Hamilton
Posts: 33
Quote:
Originally Posted by 88BlueGT View Post
Well, the dealer contacted me and it's my luck that the issue would not be within the motor. The frame and cables need to be replaced at the cost of $2,800 + tax + fees :/

I contacted Chrysler looking for some assistance. I was assigned a case manager that is supposed to be in contact with me by the end of day today. The dealer is just holding my Jeep right now waiting for a response.

To be completely honest, I'm not sure if I should just take the hit, trade it in as is and buy a new vehicle or to fix it and be stuck wondering if the same problem is going to happen again some short time in the future. Damn man, problems problems problems.
UPDATE: Chrysler contacted me and they informed me that they are going to try and help me anyway that they can. Waiting to hear back from the dealer by Thursday.
88BlueGT is offline  
post #9 of 16 Old 10-11-2013, 06:27 PM
Seadoodude
Registered User
2008 KK Liberty 
 
Join Date: Jan 2013
Location: Cypress
Posts: 10
AND, how did it go? Our 09 sky slider has now broken twice. The mechanism is very fragile. Currently the track cars that attach to the cable are not gripping the cable on the passenger side. Does anyone know of a better fix than the standard assembly?
Seadoodude is offline  
post #10 of 16 Old 06-19-2014, 09:56 AM
jasonreynolds94
Registered User
2008 KK Liberty 
 
Join Date: Jun 2009
Location: Ohio
Posts: 1
Same Problem

I know that this post is from awhile back, but I am now having the same issue. "Machine gun" sound coming from motor and the rear two "arms" are off the track.

How did your issue get resolved? Did you try to repair yourself?

Thanks in advance for your help!


Quote:
Originally Posted by 88BlueGT View Post
UPDATE: Chrysler contacted me and they informed me that they are going to try and help me anyway that they can. Waiting to hear back from the dealer by Thursday.
jasonreynolds94 is offline  
post #11 of 16 Old 06-20-2014, 09:25 AM
taylorgrandorf
Registered User
2008 KK Liberty 
 
Join Date: Jan 2013
Location: Spring
Posts: 141
I ad the same issue. $3000 later and four weeks in the dealer it still isn't done. They gave it back to me and said, "we don't know what to do to finish it"
taylorgrandorf is offline  
post #12 of 16 Old 06-20-2014, 10:41 AM Thread Starter
88BlueGT
Registered User
 
Join Date: Jul 2011
Location: Hamilton
Posts: 33
Quote:
Originally Posted by taylorgrandorf View Post
I ad the same issue. $3000 later and four weeks in the dealer it still isn't done. They gave it back to me and said, "we don't know what to do to finish it"
No f****** way! What now? I couldn't even begin to tell you how livid I would be.
88BlueGT is offline  
post #13 of 16 Old 06-20-2014, 10:43 AM
Seadoodude
Registered User
2008 KK Liberty 
 
Join Date: Jan 2013
Location: Cypress
Posts: 10
My dealer said they might be able to help with the repairs, but later after taking it in, they bailed and referred me to a 3rd party repair shop. They charged ~$3500 to fix it.

This was the second time the sky slider had to be replaced. A week later I took it to Carmax and sold it. I am done with Jeep and Chrysler.

As for the wind noise, which develops over time, I was able to fix that by adding a strip of door weather strip in the groove in the existing weather stripping.

Good luck with your repairs.

Quote:
Originally Posted by jasonreynolds94 View Post
I know that this post is from awhile back, but I am now having the same issue. "Machine gun" sound coming from motor and the rear two "arms" are off the track.

How did your issue get resolved? Did you try to repair yourself?

Thanks in advance for your help!
Seadoodude is offline  
post #14 of 16 Old 06-21-2014, 10:28 AM
taylorgrandorf
Registered User
2008 KK Liberty 
 
Join Date: Jan 2013
Location: Spring
Posts: 141
Quote:
Originally Posted by 88BlueGT View Post
No f****** way! What now? I couldn't even begin to tell you how livid I would be.
Yeah my dealer essentially brought in a 3rd party company who ran off with the money. I was under the impression that the Jeep dealer would be fixing it. Right now it works more than it did, but it still leaks everywhere.
taylorgrandorf is offline  
post #15 of 16 Old 06-23-2014, 03:27 PM
bradbb2005
Registered User
2008 WK 
 
Join Date: Dec 2007
Location: Plattsburgh, NY
Posts: 467
You guys are nuts for paying for repairs before the part is actually fixed. I wouldn't pay a dime til I saw it was fixed, and I wouldn't pay 3 grand to fix a sunroof. Seal it the best you can and trade it.

Current:
2008 WK Limited 5.7L HEMI
Mods: | JK Moabs | 245/70-17 General Grabber AT2 | 1.25" Wheel Spacers

2008 KK 3.7L V6
Mods: | 225/65-16 General Grabber AT2 |
bradbb2005 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome