Wrench Symbol - JeepForum.com

Reply
 
LinkBack Thread Tools
post #1 of 26 Old 12-22-2013, 01:41 PM Thread Starter
98ZJ SFD
Registered User
2012 KK Liberty 
 
Join Date: Sep 2006
Location: Vermont
Posts: 760
Wrench Symbol

As I was driving today, a green wrench symbol illuminated on the dash, just above the exterior temp display. It stayed on for a few seconds and went away.

I looked in the manual and didn't see an explanation for it. I searched here real quick and didn't see anything.

Any ideas? The only thing I had done just prior to it coming on was spray my windshield but the reservoir is still about half full.


Current
2012 KK Sport, Mopar skids, DuraTracs, Mopar Grille Guard

Previous
98 ZJ Laredo SE 4.0, 2" Skyjacker BB, JKS Quicker Discos, Goodyear Wrangler MT/Rs, K&N FIPK, Kolak cat & back exhaust, Westin Safari bar, KC lights
98ZJ SFD is offline  
Sponsored Links
Advertisement
 
post #2 of 26 Old 12-23-2013, 07:37 AM
Gageraid
Registered User
2008 KK Liberty 
 
Join Date: May 2012
Location: Branchburg
Posts: 1,525
Did some googling and can't find an answer either. Seen a variety of things it might be.
On a Ford forum, it was suggested it had something to do with limp mode,
another forum suggested the light came on when he needed an oil change.
Can you pull codes maybe?

EDIT: some more results show it's probably just a maintenance light. What maintenance might you need?

OME lift
Hypertech Max Energy
CAI, Gibson exhaust, 4.7L throttle body
Gageraid is offline  
post #3 of 26 Old 12-23-2013, 08:17 AM Thread Starter
98ZJ SFD
Registered User
2012 KK Liberty 
 
Join Date: Sep 2006
Location: Vermont
Posts: 760
If I'm going by the service manual - none. I'm at 13,3xx for miles and still have a couple to go before my next oil change. I've only seen the "change oil" notification once and this is different. Manual says I need my next check up at 16k or a year. Maybe it knows it's been on the road a year now? It hasn't come back since.

Current
2012 KK Sport, Mopar skids, DuraTracs, Mopar Grille Guard

Previous
98 ZJ Laredo SE 4.0, 2" Skyjacker BB, JKS Quicker Discos, Goodyear Wrangler MT/Rs, K&N FIPK, Kolak cat & back exhaust, Westin Safari bar, KC lights
98ZJ SFD is offline  
post #4 of 26 Old 12-23-2013, 09:01 AM
Gageraid
Registered User
2008 KK Liberty 
 
Join Date: May 2012
Location: Branchburg
Posts: 1,525
I'd check all these easy things for peace of mind, oil, filter, plugs, and coolant.
Also see if you can get it to happen again.

OME lift
Hypertech Max Energy
CAI, Gibson exhaust, 4.7L throttle body
Gageraid is offline  
post #5 of 26 Old 03-27-2014, 02:26 PM Thread Starter
98ZJ SFD
Registered User
2012 KK Liberty 
 
Join Date: Sep 2006
Location: Vermont
Posts: 760
This symbol has come back a couple times since I last posted. During a nasty snowstorm a couple weeks ago, the light came on and stayed on for a while. It shut off briefly but came back. I didn't notice any difference in performance or anything.

Current
2012 KK Sport, Mopar skids, DuraTracs, Mopar Grille Guard

Previous
98 ZJ Laredo SE 4.0, 2" Skyjacker BB, JKS Quicker Discos, Goodyear Wrangler MT/Rs, K&N FIPK, Kolak cat & back exhaust, Westin Safari bar, KC lights
98ZJ SFD is offline  
post #6 of 26 Old 03-27-2014, 09:50 PM
Gageraid
Registered User
2008 KK Liberty 
 
Join Date: May 2012
Location: Branchburg
Posts: 1,525
Quote:
Originally Posted by 98ZJ SFD View Post
This symbol has come back a couple times since I last posted. During a nasty snowstorm a couple weeks ago, the light came on and stayed on for a while. It shut off briefly but came back. I didn't notice any difference in performance or anything.
Ever had a check engine light since it happened?

OME lift
Hypertech Max Energy
CAI, Gibson exhaust, 4.7L throttle body
Gageraid is offline  
post #7 of 26 Old 03-28-2014, 09:20 AM Thread Starter
98ZJ SFD
Registered User
2012 KK Liberty 
 
Join Date: Sep 2006
Location: Vermont
Posts: 760
Nope, no issues whatsoever.

Current
2012 KK Sport, Mopar skids, DuraTracs, Mopar Grille Guard

Previous
98 ZJ Laredo SE 4.0, 2" Skyjacker BB, JKS Quicker Discos, Goodyear Wrangler MT/Rs, K&N FIPK, Kolak cat & back exhaust, Westin Safari bar, KC lights
98ZJ SFD is offline  
post #8 of 26 Old 03-31-2014, 10:44 AM
mrbeal
Registered User
2011 JK Wrangler 
 
Join Date: Apr 2013
Location: Norwell
Posts: 87
I just did a quick look in my iPhone Jeep manual... there is no Green Wrench symbol listed on the dash. Sure it's a wrench??
mrbeal is offline  
post #9 of 26 Old 03-31-2014, 12:09 PM
josworth
Registered User
2010 KK Liberty 
 
Join Date: Oct 2013
Location: Akron
Posts: 467
Quote:
Originally Posted by mrbeal View Post
I just did a quick look in my iPhone Jeep manual... there is no Green Wrench symbol listed on the dash. Sure it's a wrench??
I just read my manual too. No sign of any "Green Wrench" in either the dash lights or possible EVIC messages..

It is got me wondering what it is as well....

A picture maybe??? Please?????
josworth is offline  
post #10 of 26 Old 03-31-2014, 12:19 PM Thread Starter
98ZJ SFD
Registered User
2012 KK Liberty 
 
Join Date: Sep 2006
Location: Vermont
Posts: 760
I looked there too but didn't see anything.

Here's a pic.

Name:  image-4064181207.jpg
Views: 293
Size:  221.6 KB

Current
2012 KK Sport, Mopar skids, DuraTracs, Mopar Grille Guard

Previous
98 ZJ Laredo SE 4.0, 2" Skyjacker BB, JKS Quicker Discos, Goodyear Wrangler MT/Rs, K&N FIPK, Kolak cat & back exhaust, Westin Safari bar, KC lights
98ZJ SFD is offline  
post #11 of 26 Old 03-31-2014, 12:24 PM
nacheswheelin
Registered User
2000 TJ Wrangler 
 
Join Date: Sep 2011
Location: Selah
Posts: 672
Id vote on maintenance reminder , thats usually where they are located and green doesnt indicate problems like red or yellow.

Who ever said less is more never owned a jeep.
nacheswheelin is offline  
post #12 of 26 Old 03-31-2014, 03:13 PM Thread Starter
98ZJ SFD
Registered User
2012 KK Liberty 
 
Join Date: Sep 2006
Location: Vermont
Posts: 760
It just seems weird that it's been very intermittent (only happened 3 times since July with 2 of the occasions on the same day) with varying durations of the light being on.

Current
2012 KK Sport, Mopar skids, DuraTracs, Mopar Grille Guard

Previous
98 ZJ Laredo SE 4.0, 2" Skyjacker BB, JKS Quicker Discos, Goodyear Wrangler MT/Rs, K&N FIPK, Kolak cat & back exhaust, Westin Safari bar, KC lights
98ZJ SFD is offline  
post #13 of 26 Old 03-31-2014, 03:37 PM
Gageraid
Registered User
2008 KK Liberty 
 
Join Date: May 2012
Location: Branchburg
Posts: 1,525
Could it have anything to do with the change oil message?

OME lift
Hypertech Max Energy
CAI, Gibson exhaust, 4.7L throttle body
Gageraid is offline  
post #14 of 26 Old 03-31-2014, 08:43 PM
JeepLibertyKK
Registered User
2012 KK Liberty 
 
Join Date: Dec 2013
Location: Rohnert Park
Posts: 94
I can't find anything on the Internet so far, at least not specifying the green wrench as a warning light, but did find the following... just don't know i fit ties into the wrench light though.

Many Jeep Liberty models are equipped with a "Perform Maintenance" service light. This service light is turned on when the vehicle's ECU determines that the oil needs to be changed. At the specified oil change interval, your Jeep Liberty should also have other maintenance performed, such as changing the oil filter, replacing the air filter, replacing spark plugs, checking and replacing other fluids, and belt replacement. Specific maintenance required depends on the mileage of the vehicle as well as driving conditions. Check your owners manual for specific details.

Read more: http://www.ehow.com/how_7238921_rese...#ixzz2xawCpn61

A further search came up with:

It means that ecm has thown a mechanical code & should be taken to a local shop & let them diagnose the fault so repairs cam be made. But still can't find anything that shows the wrench warning light and then states any specifics to that warning light.

I'm looking forward to someone that has better information than me!

2012 Jeep Liberty Sport 4-wheel Drive
JeepLibertyKK is offline  
post #15 of 26 Old 04-01-2014, 04:09 AM
josworth
Registered User
2010 KK Liberty 
 
Join Date: Oct 2013
Location: Akron
Posts: 467
I've just wasted a ton of time looking around at stuff, too. I cannot find anything out there for either a 2012 or my 2010 that explains what the heck that is. Maybe find someone with Dealer experience to tell you. Trust me, mine is going in for the vibration on the 15th and if it hasn't been explained here, I'm going to ask.

Maybe it is some sort of service "Easter egg" left over from the Daimler days. I know they stashed "Easter eggs" in other EVIC systems. If, for example, you press the correct two buttons together in a LX (300,Charger) you get a whole bunch of hidden gauges and live data. I have already tried to find something like that in my Jeep's EVIC but haven't yet. I bring up the Daimler connection because of the service structure on my wife's R350. In order to fully clear the service reminder in her car you there are multiple menu levels you need to go through. You can get the light out in one shot, but if you don't go through the menus it thinks the services are incomplete and it will come back sooner.

Just thinking out loud. This is a strange one.

Hey another question.. when you change what is displayed on the EVIC, does it go away? If you display mileage, does the wrench disappear? Is it only present with the compass and temperature? Maybe unplug the temp sensor behind the grill? Try doing a manual calibration of the compass as well. Maybe it is related to the information displayed?
josworth is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome