Windshield Wash ..won't squirt ... - JeepForum.com

 
LinkBack Thread Tools
post #1 of 5 Old 02-17-2013, 10:29 PM Thread Starter
El_Jeepie
Registered User
2010 KK Liberty 
 
Join Date: Jul 2012
Location: miami
Posts: 11
Windshield Wash ..won't squirt ...

I believe that the WW fluid has frozen either in the tank or most likely has damaged the lines that go into the sprayer(s) .... it barely sprays out on the passenger side -&- nothing at all on the driver's side. What's my best course of action to get them working normally again ?? Or should wait for them to thaw out in the Springtime. ... Thanks in advance for your helpful responses.

El_Jeepie is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 02-17-2013, 10:38 PM
AtTheHelm
Registered User
 
Join Date: Nov 2012
Location: South Lake Tahoe
Posts: 863
Happened to me once and yes it froze up. Just parked it in the sun for a afternoon and it worked for me. Maybe try a hairdryer?
For profile says Miami though...
AtTheHelm is offline  
post #3 of 5 Old 02-18-2013, 04:09 PM Thread Starter
El_Jeepie
Registered User
2010 KK Liberty 
 
Join Date: Jul 2012
Location: miami
Posts: 11
Originally from Miami. .. currently living in Monticello, NY....
El_Jeepie is offline  
post #4 of 5 Old 02-18-2013, 04:44 PM
rescue575
Registered User
2011 KK Liberty 
 
Join Date: Feb 2012
Location: Franklin Square
Posts: 1,108
Quote:
Originally Posted by El_Jeepie
Originally from Miami. .. currently living in Monticello, NY....
Sullivan'er. I camp not to far from you. Keep your eye out for the Catskills Off Road Park they are trying to open (that probably never will).

Sent from my iPhone using JeepForum

2011 Liberty Sport
2 KC Slimlite[RIGHT] 130 Watt Long Range on JK Bar
TMS Aluminum Roof Rack Cross Bars
Cobra 75, Firestik Door Jam Mount, HD Spring, 2Ft Firestik
Dunlop Fierce Attitude M/T
rescue575 is offline  
post #5 of 5 Old 02-18-2013, 09:55 PM
TIJKK1220
Registered User
2008 KK Liberty 
 
Join Date: Apr 2012
Location: Magnolia
Posts: 127
When I purchased mine the passenger side wouldn't spray at all. The nozzle snapped

Try and spray it a couple of times and then pop your hood and look for wet spots on the hood liner. Super easy to remove and replace once you have the nozzle.
TIJKK1220 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome