Wierd sound from rear - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KK Liberty Forum > Wierd sound from rear

Savvy Billet LED Tail LightsLight up the holidays with LED lights from JeepHutIntroducing MONSTALINER™ UV Permanent DIY Roll On Bed Line

Reply
Unread 07-26-2013, 03:27 AM   #1
dawoodrocker
Registered User
2008 KK Liberty 
 
Join Date: Sep 2012
Location: Blainville, Québec
Posts: 23
Wierd sound from rear

Hi everyone, I juste notice a weird noise from the rear of my KK it sound like a piece of metal rubbing the road but there is nothing abnormal... Someone know where that noise can come from?
Please help!

dawoodrocker is offline   Reply With Quote Quick reply to this message
Unread 07-26-2013, 05:58 AM   #2
Ted15
Registered User
2010 KK Liberty 
 
Join Date: Jun 2011
Location: Akron, Ohio
Posts: 574
Does it sound like something dragging or ringing.
__________________
2010 KK Sport, Detoures Knucklebone & backbone, smittybilt XRC 10, rigid led lights, R/L sliders & rack, cb, EMT2, R/K 15x7, OME, JBA, mopar skids & hitch, headlight covers, 4.10's and TruTracs
Ted15 is offline   Reply With Quote Quick reply to this message
Unread 07-26-2013, 08:47 AM   #3
carlosburitica
Registered User
2010 KK Liberty 
 
Join Date: Feb 2013
Location: fort lauderdale, FLORIDA
Posts: 172
of is offroad maybe the traction control is kicking
carlosburitica is offline   Reply With Quote Quick reply to this message
Unread 07-26-2013, 09:01 AM   #4
Ted15
Registered User
2010 KK Liberty 
 
Join Date: Jun 2011
Location: Akron, Ohio
Posts: 574
It could be the parking brake. Have you been through mud lately?
__________________
2010 KK Sport, Detoures Knucklebone & backbone, smittybilt XRC 10, rigid led lights, R/L sliders & rack, cb, EMT2, R/K 15x7, OME, JBA, mopar skids & hitch, headlight covers, 4.10's and TruTracs
Ted15 is offline   Reply With Quote Quick reply to this message
Unread 07-26-2013, 11:35 AM   #5
dawoodrocker
Registered User
2008 KK Liberty 
 
Join Date: Sep 2012
Location: Blainville, Québec
Posts: 23
No i've never been offroad with. I only drive it on highway.
dawoodrocker is offline   Reply With Quote Quick reply to this message
Unread 07-26-2013, 12:56 PM   #6
Gageraid
Registered User
2008 KK Liberty 
 
Join Date: May 2012
Location: Branchburg, New Jersey
Posts: 1,413
Been on any rocky roads lately? A rock can be stuck in the rear rotors.
Gageraid is offline   Reply With Quote Quick reply to this message
Unread 07-27-2013, 07:55 AM   #7
RKK
Registered User
2012 KK Liberty 
 
Join Date: Apr 2013
Location: Ashburn, Virginia
Posts: 39
Beak shoe part may be rubbing the rotar
RKK is offline   Reply With Quote Quick reply to this message
Unread 07-27-2013, 10:12 AM   #8
MtBJet
Registered User
 
Join Date: Apr 2013
Posts: 87
Quote:
Originally Posted by dawoodrocker
Hi everyone, I juste notice a weird noise from the rear of my KK it sound like a piece of metal rubbing the road but there is nothing abnormal... Someone know where that noise can come from?
Please help!
How many miles since your last brake check? Could be the wear indicator.
MtBJet is offline   Reply With Quote Quick reply to this message
Unread 07-28-2013, 08:11 PM   #9
dawoodrocker
Registered User
2008 KK Liberty 
 
Join Date: Sep 2012
Location: Blainville, Québec
Posts: 23
I lift my KK yesterday to look under and I found the problem! It was the heat shield over the catalist! The 4 screws was all rusted so they broke... And the weird sound was create by the actual shiel over the catalyst rubbing on the axle shaft...
dawoodrocker is offline   Reply With Quote Quick reply to this message
Unread 07-28-2013, 09:53 PM   #10
Bmxer524
Registered User
2011 KK Liberty 
 
Join Date: Aug 2011
Location: Lindenhurst, NY
Posts: 1,208
Quote:
Originally Posted by dawoodrocker View Post
I lift my KK yesterday to look under and I found the problem! It was the heat shield over the catalist! The 4 screws was all rusted so they broke... And the weird sound was create by the actual shiel over the catalyst rubbing on the axle shaft...
I think there might have been a recall on that...
Bmxer524 is offline   Reply With Quote Quick reply to this message
Unread 07-28-2013, 10:24 PM   #11
Gageraid
Registered User
2008 KK Liberty 
 
Join Date: May 2012
Location: Branchburg, New Jersey
Posts: 1,413
Quote:
Originally Posted by Bmxer524 View Post
I think there might have been a recall on that...
Really? Never heard about that yet. Glad it's fixed now!
Gageraid is offline   Reply With Quote Quick reply to this message
Unread 07-29-2013, 01:08 PM   #12
huntb
Registered User
2008 KK Liberty 
 
Join Date: Aug 2011
Location: Grand Haven, MI
Posts: 597
Quote:
Originally Posted by Gageraid View Post
Really? Never heard about that yet. Glad it's fixed now!
It's for the 2WD models only
huntb is offline   Reply With Quote Quick reply to this message
Unread 07-29-2013, 03:54 PM   #13
Gageraid
Registered User
2008 KK Liberty 
 
Join Date: May 2012
Location: Branchburg, New Jersey
Posts: 1,413
Quote:
Originally Posted by huntb View Post
It's for the 2WD models only
Poor Jeep. Since it was a recall, does that mean people have died from this problem?
Gageraid is offline   Reply With Quote Quick reply to this message
Unread 07-30-2013, 08:57 AM   #14
huntb
Registered User
2008 KK Liberty 
 
Join Date: Aug 2011
Location: Grand Haven, MI
Posts: 597
Quote:
Originally Posted by Gageraid View Post
Poor Jeep. Since it was a recall, does that mean people have died from this problem?
No. It's preventative maintenance. It "could cause the drive shaft to break" but I don't think the chances of that are very high.
huntb is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.