Wierd sound from rear - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KK Liberty Forum > Wierd sound from rear

SYE Kits from CCOR! 706-207-4140*VOTE NOW Help Metalcloak Giveaway an XJ Suspension*Even Better Heim Pricing! From Ruffstuff

Reply
Unread 07-26-2013, 02:27 AM   #1
dawoodrocker
Registered User
2008 KK Liberty 
 
Join Date: Sep 2012
Location: Blainville, Québec
Posts: 23
Wierd sound from rear

Hi everyone, I juste notice a weird noise from the rear of my KK it sound like a piece of metal rubbing the road but there is nothing abnormal... Someone know where that noise can come from?
Please help!

dawoodrocker is offline   Reply With Quote
Unread 07-26-2013, 04:58 AM   #2
Ted15
Senior Member
 
Ted15's Avatar
2010 KK Liberty 
 
Join Date: Jun 2011
Location: Akron, Ohio
Posts: 509
Does it sound like something dragging or ringing.
__________________
2010 Liberty KK Sport, deep water blue, weathertech in channel vent visors, weathertech digital floor mats, Detoures backbone winch mount w/smittybilt XRC 10 comp winch, rigid industries dually led lights on smittybilt fairhead mount, Rocklizard skink supersliders and Gecko safari rack, cobra cb w/48" firestick antenna, general grabber at2 245/75-16, OME heavy duty springs, OME shocks, about 3" - 3 1/2" of lift, Detoures Knucklebone spare tire and Jerry can mount, mopar skids, class 3 hitch w/7 pin wire harness, headlight covers, 4.10's and Detroit TruTracs F&R
Ted15 is offline   Reply With Quote
Unread 07-26-2013, 07:47 AM   #3
carlosburitica
Registered User
2010 KK Liberty 
 
Join Date: Feb 2013
Location: fort lauderdale, FLORIDA
Posts: 165
of is offroad maybe the traction control is kicking
carlosburitica is offline   Reply With Quote
Unread 07-26-2013, 08:01 AM   #4
Ted15
Senior Member
 
Ted15's Avatar
2010 KK Liberty 
 
Join Date: Jun 2011
Location: Akron, Ohio
Posts: 509
It could be the parking brake. Have you been through mud lately?
__________________
2010 Liberty KK Sport, deep water blue, weathertech in channel vent visors, weathertech digital floor mats, Detoures backbone winch mount w/smittybilt XRC 10 comp winch, rigid industries dually led lights on smittybilt fairhead mount, Rocklizard skink supersliders and Gecko safari rack, cobra cb w/48" firestick antenna, general grabber at2 245/75-16, OME heavy duty springs, OME shocks, about 3" - 3 1/2" of lift, Detoures Knucklebone spare tire and Jerry can mount, mopar skids, class 3 hitch w/7 pin wire harness, headlight covers, 4.10's and Detroit TruTracs F&R
Ted15 is offline   Reply With Quote
Unread 07-26-2013, 10:35 AM   #5
dawoodrocker
Registered User
2008 KK Liberty 
 
Join Date: Sep 2012
Location: Blainville, Québec
Posts: 23
No i've never been offroad with. I only drive it on highway.
dawoodrocker is offline   Reply With Quote
Unread 07-26-2013, 11:56 AM   #6
Gageraid
Registered User
2008 KK Liberty 
 
Join Date: May 2012
Location: Branchburg, New Jersey
Posts: 1,246
Been on any rocky roads lately? A rock can be stuck in the rear rotors.
Gageraid is offline   Reply With Quote
Unread 07-27-2013, 06:55 AM   #7
RKK
Registered User
2012 KK Liberty 
 
Join Date: Apr 2013
Location: Ashburn, Virginia
Posts: 37
Beak shoe part may be rubbing the rotar
RKK is offline   Reply With Quote
Unread 07-27-2013, 09:12 AM   #8
MtBJet
Registered User
 
Join Date: Apr 2013
Posts: 87
Quote:
Originally Posted by dawoodrocker
Hi everyone, I juste notice a weird noise from the rear of my KK it sound like a piece of metal rubbing the road but there is nothing abnormal... Someone know where that noise can come from?
Please help!
How many miles since your last brake check? Could be the wear indicator.
MtBJet is offline   Reply With Quote
Unread 07-28-2013, 07:11 PM   #9
dawoodrocker
Registered User
2008 KK Liberty 
 
Join Date: Sep 2012
Location: Blainville, Québec
Posts: 23
I lift my KK yesterday to look under and I found the problem! It was the heat shield over the catalist! The 4 screws was all rusted so they broke... And the weird sound was create by the actual shiel over the catalyst rubbing on the axle shaft...
dawoodrocker is offline   Reply With Quote
Unread 07-28-2013, 08:53 PM   #10
Bmxer524
Registered User
2011 KK Liberty 
 
Join Date: Aug 2011
Location: Lindenhurst, NY
Posts: 1,071
Quote:
Originally Posted by dawoodrocker View Post
I lift my KK yesterday to look under and I found the problem! It was the heat shield over the catalist! The 4 screws was all rusted so they broke... And the weird sound was create by the actual shiel over the catalyst rubbing on the axle shaft...
I think there might have been a recall on that...
Bmxer524 is offline   Reply With Quote
Unread 07-28-2013, 09:24 PM   #11
Gageraid
Registered User
2008 KK Liberty 
 
Join Date: May 2012
Location: Branchburg, New Jersey
Posts: 1,246
Quote:
Originally Posted by Bmxer524 View Post
I think there might have been a recall on that...
Really? Never heard about that yet. Glad it's fixed now!
Gageraid is offline   Reply With Quote
Unread 07-29-2013, 12:08 PM   #12
huntb
Registered User
2008 KK Liberty 
 
Join Date: Aug 2011
Location: Grand Haven, MI
Posts: 559
Quote:
Originally Posted by Gageraid View Post
Really? Never heard about that yet. Glad it's fixed now!
It's for the 2WD models only
huntb is offline   Reply With Quote
Unread 07-29-2013, 02:54 PM   #13
Gageraid
Registered User
2008 KK Liberty 
 
Join Date: May 2012
Location: Branchburg, New Jersey
Posts: 1,246
Quote:
Originally Posted by huntb View Post
It's for the 2WD models only
Poor Jeep. Since it was a recall, does that mean people have died from this problem?
Gageraid is offline   Reply With Quote
Unread 07-30-2013, 07:57 AM   #14
huntb
Registered User
2008 KK Liberty 
 
Join Date: Aug 2011
Location: Grand Haven, MI
Posts: 559
Quote:
Originally Posted by Gageraid View Post
Poor Jeep. Since it was a recall, does that mean people have died from this problem?
No. It's preventative maintenance. It "could cause the drive shaft to break" but I don't think the chances of that are very high.
huntb is offline   Reply With Quote




Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.