post #1636 of Old 08-21-2013, 07:57 AM
carlosburitica
Registered User
2010 KK Liberty 
 
Join Date: Feb 2013
Location: fort lauderdale
Posts: 173
dropper the kk to the dealer ship again. lost my steering........ they have to replace the steering rack,




carlosburitica is offline  
post #1637 of Old 08-21-2013, 07:59 AM
_benjammin
Registered User
2012 KK Liberty 
 
Join Date: Mar 2012
Location: Wilmington
Posts: 335
Got an alignment yesterday and day dreamed about new tires.
_benjammin is offline  
post #1638 of Old 08-21-2013, 09:26 AM
Gageraid
Registered User
2008 KK Liberty 
 
Join Date: May 2012
Location: Branchburg
Posts: 1,525
Quote:
Originally Posted by xtremzj View Post
It's a thousand dollar option from the factory, it cost these people 3 times that.
Ouch.
Gageraid is offline  
post #1639 of Old 08-21-2013, 09:28 AM
Gageraid
Registered User
2008 KK Liberty 
 
Join Date: May 2012
Location: Branchburg
Posts: 1,525
Quote:
Originally Posted by carlosburitica View Post
dropper the kk to the dealer ship again. lost my steering........ they have to replace the steering rack,


I thought this was only a problem with the 2008 model. Hopefully it happened in a safe place.
Gageraid is offline  
post #1640 of Old 08-21-2013, 02:17 PM
carlosburitica
Registered User
2010 KK Liberty 
 
Join Date: Feb 2013
Location: fort lauderdale
Posts: 173
Quote:
Originally Posted by Gageraid View Post
I thought this was only a problem with the 2008 model. Hopefully it happened in a safe place.
i left the car for 5 days parked at the airport and once i started the steering was completely hard, i drove it to the nearest auto parts to refill the steering reservoir and nothing happened, drove straight to the dealer and..........
new steering rack... no ready yet. only need to pay for aliment.
carlosburitica is offline  
post #1641 of Old 08-21-2013, 02:48 PM
Ted15
Registered User
2010 KK Liberty 
 
Join Date: Jun 2011
Location: Akron
Posts: 578
Quote:
Originally Posted by carlosburitica

i left the car for 5 days parked at the airport and once i started the steering was completely hard, i drove it to the nearest auto parts to refill the steering reservoir and nothing happened, drove straight to the dealer and..........
new steering rack... no ready yet. only need to pay for aliment.
If the alignment is part of a covered repair I would think the alignment is also covered.

2010 KK Sport, Detoures Knucklebone & backbone, smittybilt XRC 10, rigid led lights, R/L sliders & rack, cb, EMT2, R/K 15x7, OME, JBA, mopar skids & hitch, headlight covers, 4.10's and TruTracs
Ted15 is offline  
post #1642 of Old 08-21-2013, 02:50 PM
jumpthis
Registered User
2012 KK Liberty 
 
Join Date: Aug 2012
Location: wantagh
Posts: 44
Installed my K&N Intake today
Attached Thumbnails
555539_10200455783982056_481780429_n.jpg  
jumpthis is offline  
post #1643 of Old 08-21-2013, 03:27 PM
Gageraid
Registered User
2008 KK Liberty 
 
Join Date: May 2012
Location: Branchburg
Posts: 1,525
Quote:
Originally Posted by jumpthis View Post
Installed my K&N Intake today
Check your throttle body soon. They get a little oily from the filter. You can easily clean the throttle body in about 10 minutes. Little precautions you have to take when running with this kind of filter. I've had mine on for a year now with no problems.
Gageraid is offline  
post #1644 of Old 08-21-2013, 03:28 PM
Gageraid
Registered User
2008 KK Liberty 
 
Join Date: May 2012
Location: Branchburg
Posts: 1,525
Quote:
Originally Posted by carlosburitica View Post
i left the car for 5 days parked at the airport and once i started the steering was completely hard, i drove it to the nearest auto parts to refill the steering reservoir and nothing happened, drove straight to the dealer and..........
new steering rack... no ready yet. only need to pay for aliment.
Keep us posted if you have any additional info about this. Glad to hear no one was hurt.
Gageraid is offline  
post #1645 of Old 08-21-2013, 04:35 PM
Ted15
Registered User
2010 KK Liberty 
 
Join Date: Jun 2011
Location: Akron
Posts: 578
Quote:
Originally Posted by Gageraid

Check your throttle body soon. They get a little oily from the filter. You can easily clean the throttle body in about 10 minutes. Little precautions you have to take when running with this kind of filter. I've had mine on for a year now with no problems.
Are you oiling the filter with the spray or drip bottle? I've been using a K&N drop in filter since my first replacement and haven't seen even the slightest but of residue. I had one on another vehicle and didn't see it there either. (?)

2010 KK Sport, Detoures Knucklebone & backbone, smittybilt XRC 10, rigid led lights, R/L sliders & rack, cb, EMT2, R/K 15x7, OME, JBA, mopar skids & hitch, headlight covers, 4.10's and TruTracs
Ted15 is offline  
post #1646 of Old 08-21-2013, 05:26 PM
Gageraid
Registered User
2008 KK Liberty 
 
Join Date: May 2012
Location: Branchburg
Posts: 1,525
Quote:
Originally Posted by Ted15 View Post
Are you oiling the filter with the spray or drip bottle? I've been using a K&N drop in filter since my first replacement and haven't seen even the slightest but of residue. I had one on another vehicle and didn't see it there either. (?)
The aerosol. I think mine just gets dirty in the throttle body since I baby it too much and a buttload of cold starts. I may have a different idea of what is dirty compared to you, too. I like my throttle body 100 percent clean so any bit of dirt on it or black is probably from the filter, but I'm not positive. Nothing I'm worried about, but not something I'll let slip my mind. Routine maintenance.

Edit: I'm using a cold air intake, and not the drop in filter.
Gageraid is offline  
post #1647 of Old 08-21-2013, 07:00 PM
jumpthis
Registered User
2012 KK Liberty 
 
Join Date: Aug 2012
Location: wantagh
Posts: 44
Thank you for the heads up!!! First time jeep owner my previous car I had a intake but this time I installed it myself not bad for a female haha
jumpthis is offline  
post #1648 of Old 08-21-2013, 10:18 PM
Gageraid
Registered User
2008 KK Liberty 
 
Join Date: May 2012
Location: Branchburg
Posts: 1,525
Quote:
Originally Posted by jumpthis View Post
Thank you for the heads up!!! First time jeep owner my previous car I had a intake but this time I installed it myself not bad for a female haha
Also I've had to retighten it a few times. Just check everything next time you have the hood open. Enjoy the grunt it will have now.
Gageraid is offline  
post #1649 of Old 08-22-2013, 06:45 PM
Ted15
Registered User
2010 KK Liberty 
 
Join Date: Jun 2011
Location: Akron
Posts: 578
Quote:
Originally Posted by Gageraid

The aerosol. I think mine just gets dirty in the throttle body since I baby it too much and a buttload of cold starts. I may have a different idea of what is dirty compared to you, too. I like my throttle body 100 percent clean so any bit of dirt on it or black is probably from the filter, but I'm not positive. Nothing I'm worried about, but not something I'll let slip my mind. Routine maintenance.

Edit: I'm using a cold air intake, and not the drop in filter.
The throttle body is going to get dirty with any filter. I've been checking the intake tube after the filter for oil film. I haven't found any yet. I doubt that the oil from the filter has contributed to the throttle body, especially if the tube is clean.

2010 KK Sport, Detoures Knucklebone & backbone, smittybilt XRC 10, rigid led lights, R/L sliders & rack, cb, EMT2, R/K 15x7, OME, JBA, mopar skids & hitch, headlight covers, 4.10's and TruTracs
Ted15 is offline  
post #1650 of Old 08-22-2013, 09:53 PM
bstephens_kk
Registered User
2012 KK Liberty 
 
Join Date: Apr 2013
Posts: 41
Quote:
Originally Posted by carlosburitica
dropper the kk to the dealer ship again. lost my steering........ they have to replace the steering rack,

Love the Reese hitch plug....one of my babies...I work for Cequent Consumer Products...the makers of Reese (amongst other products)

Sent from my iPad using JeepForum
bstephens_kk is offline  
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Received my Rusty's 2.5" lift today but??? help onegoodpunk KK Liberty Forum 4 09-29-2014 02:49 PM
Lifetime Membership and Gift Certificate Contest Ends Today - Get Involved! Keith KK Liberty Forum 0 04-05-2010 11:18 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome