weird tranny issue - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KK Liberty Forum > weird tranny issue

FS: Wrangler RGB Multicolor Fog Light LEDs: Awesome EffectFS: 2007-2013 Jeep Wrangler "HALO" Angel Eye KitRockridge 4WD IS Taking Zone Offroad Suspension Lift Kits

Reply
Unread 07-19-2010, 06:35 AM   #1
VMF
Registered User
2008 KK Liberty 
 
Join Date: Jan 2009
Location: New York
Posts: 579
weird tranny issue

im not sure if its the tranny or if its the software problem or a feature but it never hurts to ask. it usually happens when i drive around 20-30 mph and i need to accelerate rapidly, when i push the accelerator almost all the way sometimes engine revs almost to 5k but the car does not accelerate, i have to release the accelerator, let the rpms drop and do it again, more slowly this time, then the accelerates. it almost feels like the torque converter is slipping....
any of you guys experienced this issue?

VMF is offline   Reply With Quote
Unread 07-19-2010, 10:39 PM   #2
richd
Registered User
2008 KK Liberty 
 
Join Date: Jun 2008
Location: Arizona
Posts: 1,104
Here are 3 TSBs for your tranny,see which one is seems to match your problem:

http://sites.google.com/site/gravedi...attredirects=0

http://sites.google.com/site/gravedi...attredirects=0

http://sites.google.com/site/gravedi...attredirects=0
richd is offline   Reply With Quote
Unread 07-20-2010, 07:56 AM   #3
VMF
Registered User
2008 KK Liberty 
 
Join Date: Jan 2009
Location: New York
Posts: 579
i had 2out of these 3 TSBs done on my tranny, one regarding the AC and TC and the other one was just the tranny programming one. i dont have the drone noise problem so that one was not done. but the other 2 were. still the same thing. its either slipping or not locking
VMF is offline   Reply With Quote
Unread 07-20-2010, 12:35 PM   #4
richd
Registered User
2008 KK Liberty 
 
Join Date: Jun 2008
Location: Arizona
Posts: 1,104
Quote:
Originally Posted by VMF View Post
i had 2out of these 3 TSBs done on my tranny, one regarding the AC and TC and the other one was just the tranny programming one. i dont have the drone noise problem so that one was not done. but the other 2 were. still the same thing. its either slipping or not locking
The one with the drone does change when the TC locks up,and others on here had it done with good results.I also had the 2 TSBs you had done,and so far tranny seems good.Plus you should have lifetime warranty on your KK if there is another problem.
richd is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.