Transmission Slow To Engage First Thing in the Morning - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KK Liberty Forum > Transmission Slow To Engage First Thing in the Morning

Engo winches available at www.rockridge4wd.com! Free shippJeep speedometer gears at rockridge4wdDana 30 Truss for your TJ, LJ, ZJ, and XJ

Reply
Unread 08-26-2010, 06:41 AM   #1
Elt31987
Senior Member
 
Elt31987's Avatar
2008 KK Liberty 
 
Join Date: Mar 2009
Location: Stoneham, Massachusetts
Posts: 945
Transmission Slow To Engage First Thing in the Morning

So my house is on a hill. When i leave in the morning and i back out of the driveway i drive up the hill. So i back out, cut the wheel, put it in drive, wait a second then try to go but the vehicle doesn't move until the RPM is about 2000 then it then lazily engages then goes on its way. This is the only time this happens. Is it because the transmission fluid isn't warmed up and because I'm on a hill? Since there is not dipstick i cant even check the fluid. tjkj2002 where are you? lol

__________________
---------------------------------------------------
2008 KK Liberty
Inferno Red
Daystar 2" Spacer Lift With SkyJacker Hydro Shocks
JBA Gen 5.5 Upper Control Arms
Rokmen Riddler 8.25 Differential Cover
2 KC Slimlite 100 Watt Driving Lights on JK Light Bar
245/75/16 All Terrains
Mopar Front Tow Hooks
Mopar Rear Tow Hook
Mopar Skids
Elt31987 is offline   Reply With Quote
Unread 08-26-2010, 10:59 PM   #2
richd
Registered User
2008 KK Liberty 
 
Join Date: Jun 2008
Location: Arizona
Posts: 1,101
Quote:
Originally Posted by Elt31987 View Post
So my house is on a hill. When i leave in the morning and i back out of the driveway i drive up the hill. So i back out, cut the wheel, put it in drive, wait a second then try to go but the vehicle doesn't move until the RPM is about 2000 then it then lazily engages then goes on its way. This is the only time this happens. Is it because the transmission fluid isn't warmed up and because I'm on a hill? Since there is not dipstick i cant even check the fluid. tjkj2002 where are you? lol
How many miles on this.I know there is no dipstick,but fluid level would be the first thing to check.If you havent seen any leaks,then assume its OK.Next could be restricted filter,bad or leaking valve body,transmissiom pressure line,shift solenoid.You might need a trip to the dealer.
richd is offline   Reply With Quote
Unread 08-27-2010, 03:45 AM   #3
Elt31987
Senior Member
 
Elt31987's Avatar
2008 KK Liberty 
 
Join Date: Mar 2009
Location: Stoneham, Massachusetts
Posts: 945
34K, Ya i just hate having to wait for them to look at it, and they always find nothing wrong.
__________________
---------------------------------------------------
2008 KK Liberty
Inferno Red
Daystar 2" Spacer Lift With SkyJacker Hydro Shocks
JBA Gen 5.5 Upper Control Arms
Rokmen Riddler 8.25 Differential Cover
2 KC Slimlite 100 Watt Driving Lights on JK Light Bar
245/75/16 All Terrains
Mopar Front Tow Hooks
Mopar Rear Tow Hook
Mopar Skids
Elt31987 is offline   Reply With Quote
Unread 08-27-2010, 10:16 AM   #4
Nosights
Registered User
2000 WJ 
 
Join Date: Dec 2009
Location: West Michigan
Posts: 121
Definitely a dealer only serviceable item (well shops such as mine can check as well but they have to be set up to service these newer Chryslers (need a StarScan and a trans dip rod).

I would have the fluid level checked as it sounds like it is starved for oil. What happens when you set in park or neutral for a minute and see if then it will take off normally once you have sat on level ground for a minute first. Also, does it only do it before warm up or will it do it when you do the same thing after full warm up?

Dan
Nosights is offline   Reply With Quote
Unread 08-27-2010, 10:47 AM   #5
Elt31987
Senior Member
 
Elt31987's Avatar
2008 KK Liberty 
 
Join Date: Mar 2009
Location: Stoneham, Massachusetts
Posts: 945
I remote start my KK for about 2 minutes before i leave, but my driveway is pretty flat, so when i put it in reverse to back onto the hill it does that fine. But when i put it in drive from reverse(At this point I'm on the hill) it will not go and i need to put the RPM up to about 2000 and it slowly will engage and go. I know its not Hill start Assist because i know how that feels. Ill try it when i leave work today, ill pull in the driveway, put it in park, back out and put in drive and see what happens and let you know.
__________________
---------------------------------------------------
2008 KK Liberty
Inferno Red
Daystar 2" Spacer Lift With SkyJacker Hydro Shocks
JBA Gen 5.5 Upper Control Arms
Rokmen Riddler 8.25 Differential Cover
2 KC Slimlite 100 Watt Driving Lights on JK Light Bar
245/75/16 All Terrains
Mopar Front Tow Hooks
Mopar Rear Tow Hook
Mopar Skids
Elt31987 is offline   Reply With Quote
Unread 08-27-2010, 10:48 AM   #6
swtrucker
Registered User
2011 JK Wrangler 
 
Join Date: Dec 2008
Location: waco, Tx
Posts: 34
Sounds like a dirty filter.
__________________
Quote:
Originally Posted by CCGRUNT0331 View Post
Last night I was staring at her basking in the moon light, I glanced at her, she grinned back and I thought... Man! I Freakin Love My Jeep!
swtrucker is offline   Reply With Quote
Unread 08-27-2010, 10:51 AM   #7
Elt31987
Senior Member
 
Elt31987's Avatar
2008 KK Liberty 
 
Join Date: Mar 2009
Location: Stoneham, Massachusetts
Posts: 945
I wonder if this will be covered under my 3/36K or my Lifetime Powertrain. Hopefully. I know the filter is like 30 bucks but i bet the tranny will have to be drained etc to replace it.
__________________
---------------------------------------------------
2008 KK Liberty
Inferno Red
Daystar 2" Spacer Lift With SkyJacker Hydro Shocks
JBA Gen 5.5 Upper Control Arms
Rokmen Riddler 8.25 Differential Cover
2 KC Slimlite 100 Watt Driving Lights on JK Light Bar
245/75/16 All Terrains
Mopar Front Tow Hooks
Mopar Rear Tow Hook
Mopar Skids
Elt31987 is offline   Reply With Quote
Unread 08-27-2010, 11:57 AM   #8
richd
Registered User
2008 KK Liberty 
 
Join Date: Jun 2008
Location: Arizona
Posts: 1,101
Quote:
Originally Posted by Elt31987 View Post
I wonder if this will be covered under my 3/36K or my Lifetime Powertrain. Hopefully. I know the filter is like 30 bucks but i bet the tranny will have to be drained etc to replace it.
The manual calls for fluid and filter change at 60k severe service and 120k normal service so this could be under warranty.34k seems to early for this to happen,unless it is just low on fluid.
richd is offline   Reply With Quote
Unread 08-27-2010, 12:42 PM   #9
Elt31987
Senior Member
 
Elt31987's Avatar
2008 KK Liberty 
 
Join Date: Mar 2009
Location: Stoneham, Massachusetts
Posts: 945
ya cuz i change all my fluids under severe and i knew i was only 1/2 way for the tranny. It seems like its low the way its acting but i don't see any fluid on the ground at home or work
__________________
---------------------------------------------------
2008 KK Liberty
Inferno Red
Daystar 2" Spacer Lift With SkyJacker Hydro Shocks
JBA Gen 5.5 Upper Control Arms
Rokmen Riddler 8.25 Differential Cover
2 KC Slimlite 100 Watt Driving Lights on JK Light Bar
245/75/16 All Terrains
Mopar Front Tow Hooks
Mopar Rear Tow Hook
Mopar Skids
Elt31987 is offline   Reply With Quote
Unread 08-27-2010, 05:07 PM   #10
richd
Registered User
2008 KK Liberty 
 
Join Date: Jun 2008
Location: Arizona
Posts: 1,101
Quote:
Originally Posted by Elt31987 View Post
ya cuz i change all my fluids under severe and i knew i was only 1/2 way for the tranny. It seems like its low the way its acting but i don't see any fluid on the ground at home or work
It looks like you wont have a choice but to bring it into the dealer,like someone mentioned you need starscan and special dipstick to check fluid.
richd is offline   Reply With Quote
Unread 08-27-2010, 09:45 PM   #11
Elt31987
Senior Member
 
Elt31987's Avatar
2008 KK Liberty 
 
Join Date: Mar 2009
Location: Stoneham, Massachusetts
Posts: 945
So when i got home i pulled in the driveway, put it in park, put it in reverse and put it in driveway just like when i leave in the morning but the transmission engaged just fine. So i went in the house for like 1 hour, came out to leave and it was slow to engage but not as bad as when it sits over night. I have to drop it off monday night with the dealer.
__________________
---------------------------------------------------
2008 KK Liberty
Inferno Red
Daystar 2" Spacer Lift With SkyJacker Hydro Shocks
JBA Gen 5.5 Upper Control Arms
Rokmen Riddler 8.25 Differential Cover
2 KC Slimlite 100 Watt Driving Lights on JK Light Bar
245/75/16 All Terrains
Mopar Front Tow Hooks
Mopar Rear Tow Hook
Mopar Skids
Elt31987 is offline   Reply With Quote
Unread 08-31-2010, 05:10 PM   #12
richd
Registered User
2008 KK Liberty 
 
Join Date: Jun 2008
Location: Arizona
Posts: 1,101
Quote:
Originally Posted by Elt31987 View Post
So when i got home i pulled in the driveway, put it in park, put it in reverse and put it in driveway just like when i leave in the morning but the transmission engaged just fine. So i went in the house for like 1 hour, came out to leave and it was slow to engage but not as bad as when it sits over night. I have to drop it off monday night with the dealer.
Did you get your KK back?What was the problem?
richd is offline   Reply With Quote
Unread 08-31-2010, 07:55 PM   #13
Elt31987
Senior Member
 
Elt31987's Avatar
2008 KK Liberty 
 
Join Date: Mar 2009
Location: Stoneham, Massachusetts
Posts: 945
Dropped it off Monday night for Tuesday and the dealer said they needed it for one more day, they probably didnt look at it yet. So hopefully they will call tomorrow and i can go get it, then ill post up whatever it is they found or more likely didnt find.
__________________
---------------------------------------------------
2008 KK Liberty
Inferno Red
Daystar 2" Spacer Lift With SkyJacker Hydro Shocks
JBA Gen 5.5 Upper Control Arms
Rokmen Riddler 8.25 Differential Cover
2 KC Slimlite 100 Watt Driving Lights on JK Light Bar
245/75/16 All Terrains
Mopar Front Tow Hooks
Mopar Rear Tow Hook
Mopar Skids
Elt31987 is offline   Reply With Quote
Unread 09-02-2010, 05:36 AM   #14
Elt31987
Senior Member
 
Elt31987's Avatar
2008 KK Liberty 
 
Join Date: Mar 2009
Location: Stoneham, Massachusetts
Posts: 945
As i said ill post the lack of problems they found. They said the fluid was fine and they were unable to replicate the issue. They put the transmission into relearn and said to see if it improves. This morning it did not feel sluggish so we will see what happens.
__________________
---------------------------------------------------
2008 KK Liberty
Inferno Red
Daystar 2" Spacer Lift With SkyJacker Hydro Shocks
JBA Gen 5.5 Upper Control Arms
Rokmen Riddler 8.25 Differential Cover
2 KC Slimlite 100 Watt Driving Lights on JK Light Bar
245/75/16 All Terrains
Mopar Front Tow Hooks
Mopar Rear Tow Hook
Mopar Skids
Elt31987 is offline   Reply With Quote
Unread 09-02-2010, 01:07 PM   #15
richd
Registered User
2008 KK Liberty 
 
Join Date: Jun 2008
Location: Arizona
Posts: 1,101
I hope it works out.I hate dealers when they say they cant replicate the issue.Good Luck.
richd is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.