Transmission Issues - Can't shift up past 2nd - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KK Liberty Forum > Transmission Issues - Can't shift up past 2nd

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineOconeeoffroad.com Prothane bushing sale Blowing out inventPoison spyder items @ oconee off road 706 534 9955

Reply
Unread 01-14-2012, 12:06 AM   #1
Poncherello
Moderator
2010 KK Liberty 
 
Join Date: Apr 2011
Location: Paterson, New Jersey
Posts: 996
Transmission Issues - Can't shift up past 2nd

Hey Fellas,

I have 2010 LIB Sport Auto, 4wd, with Command Track and 22.4K on the clock. I was driving home tonight my engine light on and next thing you know the trans would not shift up to drive or overdrive. At 40mph I was at about 3G on the tach.

- The transfer case was in 2WD mode
- Tow-Haul Switch is off as well.
- 1st, 2nd and reverse work.

Anyway, I have the "Gold" 5 year 60K warranty on it and will be calling the dealership tomorrow morning insisting them to tow it and loan me a car.

Driving home from Long Island wasn't fun, being only able to drive at 40mph with my flashers on

Any ideas on what it is? I don't have a coder. Is the 42RLE a crap transmission?

Poncherello is offline   Reply With Quote
Unread 01-18-2012, 06:04 PM   #2
rFREESEr
Registered User
 
Join Date: Jan 2012
Posts: 12
Locking out 3rd and OD in conjunction with the engine light sounds like the while went in to "limp home" mode. Basically when the computer detects a problem it will go in to that mode to protect the vehicle from further damage until it can be serviced.
rFREESEr is offline   Reply With Quote
Unread 01-18-2012, 06:51 PM   #3
Poncherello
Moderator
2010 KK Liberty 
 
Join Date: Apr 2011
Location: Paterson, New Jersey
Posts: 996
I think you're right. The next day when I drove to the dealership, the trans shifted fine, then the engine light finally turned off. My EGR valve had to be replaced and computer was reflashed/updated. Now, it runs great juat hope it doesn't happen again
Poncherello is offline   Reply With Quote
Unread 01-18-2012, 09:27 PM   #4
jonrjen
Registered User
2011 KK Liberty 
 
Join Date: Apr 2010
Location: Texas
Posts: 1,077
I was thinking speed sensor either at one of the wheels or the transmission imput sensor.
__________________
"If you have a difficult job to do....Give it to a lazy man....He'll find the easy way to do it."
jonrjen is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.