Transmission Issues - Can't shift up past 2nd -

LinkBack Thread Tools
post #1 of 4 Old 01-14-2012, 12:06 AM Thread Starter
2010 KK Liberty 
Join Date: Apr 2011
Location: Paterson
Posts: 1,128
Transmission Issues - Can't shift up past 2nd

Hey Fellas,

I have 2010 LIB Sport Auto, 4wd, with Command Track and 22.4K on the clock. I was driving home tonight my engine light on and next thing you know the trans would not shift up to drive or overdrive. At 40mph I was at about 3G on the tach.

- The transfer case was in 2WD mode
- Tow-Haul Switch is off as well.
- 1st, 2nd and reverse work.

Anyway, I have the "Gold" 5 year 60K warranty on it and will be calling the dealership tomorrow morning insisting them to tow it and loan me a car.

Driving home from Long Island wasn't fun, being only able to drive at 40mph with my flashers on

Any ideas on what it is? I don't have a coder. Is the 42RLE a crap transmission?

Poncherello is offline  
Sponsored Links
post #2 of 4 Old 01-18-2012, 06:04 PM
Registered User
Join Date: Jan 2012
Posts: 12
Locking out 3rd and OD in conjunction with the engine light sounds like the while went in to "limp home" mode. Basically when the computer detects a problem it will go in to that mode to protect the vehicle from further damage until it can be serviced.
rFREESEr is offline  
post #3 of 4 Old 01-18-2012, 06:51 PM Thread Starter
2010 KK Liberty 
Join Date: Apr 2011
Location: Paterson
Posts: 1,128
I think you're right. The next day when I drove to the dealership, the trans shifted fine, then the engine light finally turned off. My EGR valve had to be replaced and computer was reflashed/updated. Now, it runs great juat hope it doesn't happen again
Poncherello is offline  
post #4 of 4 Old 01-18-2012, 09:27 PM
Registered User
2011 KK Liberty 
Join Date: Apr 2010
Location: Texas
Posts: 1,077
I was thinking speed sensor either at one of the wheels or the transmission imput sensor.

"If you have a difficult job to do....Give it to a lazy man....He'll find the easy way to do it."
jonrjen is offline  

Quick Reply

Register Now

In order to be able to post messages on the forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
Transmission issues on a 2009 Jeep Liberty Limited csell KK Liberty Forum 10 05-08-2015 07:44 PM
Alarm Issues BrendonR KK Liberty Forum 0 01-16-2011 02:32 PM
kk gear shift knob jeepster09 KK Liberty Forum 5 01-01-2011 11:01 AM
Won't shift out of park otlip KK Liberty Forum 2 10-27-2010 03:45 PM
SkySlider - any issues YellowDuck KK Liberty Forum 21 05-18-2010 02:55 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome