Trailer wiring harness - JeepForum.com

 
LinkBack Thread Tools
post #1 of 5 Old 04-29-2013, 05:58 PM Thread Starter
bullettm
Registered User
 
Join Date: Feb 2011
Location: Clifton Park
Posts: 3
Trailer wiring harness

I have a 2011 Liberty Jet. I installed the hitch and wiring myself about a year and a half ago. Last week I bought a boat and when I plugged the wire from the trailer into my hitch, I popped the fuse attached to the power wire next to the battery. The 4 prong plug on the boat trailer was pretty corroded so I replaced it along with the fuse by the battery but now the trailer lights don't work right. One light constantly stays on whether the key is in the ignition or not and the other one doesn't work at all. I tried plugging in my atv trailer and its the same thing, but opposite lights. Does anyone know whats wrong here? Thanks in advance

bullettm is offline  
Sponsored Links
Advertisement
 
post #2 of 5 Old 04-30-2013, 01:53 AM
Drednot
Registered User
1991 YJ Wrangler 
 
Join Date: Aug 2005
Location: Phoenix
Posts: 3,370
Can we assume that the ATV trailer worked correctly for the last year?

91 YJ Sahara, 4.0L, AX-15/NP231, D30/D35@3.07
12 Cherokee 4x4,3.7L,42RLE/MP1522, D30M/8.25@3.73
Emission test=YES
"Non Vi Sed, Arte"
Drednot is offline  
post #3 of 5 Old 04-30-2013, 06:36 AM
huntb
Registered User
2008 KK Liberty 
 
Join Date: Aug 2011
Location: Grand Haven
Posts: 630
Did you install the factory wire harness or an aftermarket harness?
huntb is offline  
post #4 of 5 Old 04-30-2013, 07:55 AM Thread Starter
bullettm
Registered User
 
Join Date: Feb 2011
Location: Clifton Park
Posts: 3
Everything worked fine for over a year before this. I believe the.harness is made by Curt
bullettm is offline  
post #5 of 5 Old 04-30-2013, 08:30 PM
12SilverKK
Registered User
 
Join Date: Apr 2013
Posts: 1
Did you hide the harness is flexible plastic tubing? If not thr wires might have worn thru rubbing on the frame and then shorted out.
12SilverKK is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.



Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome