Trailer wiring harness - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KK Liberty Forum > Trailer wiring harness

Introducing MONSTALINER™ UV Permanent DIY Roll On Bed LineSavvy Billet LED Tail LightsCurrie

Reply
Unread 04-29-2013, 06:58 PM   #1
bullettm
Registered User
 
Join Date: Feb 2011
Location: Clifton Park, NY
Posts: 3
Trailer wiring harness

I have a 2011 Liberty Jet. I installed the hitch and wiring myself about a year and a half ago. Last week I bought a boat and when I plugged the wire from the trailer into my hitch, I popped the fuse attached to the power wire next to the battery. The 4 prong plug on the boat trailer was pretty corroded so I replaced it along with the fuse by the battery but now the trailer lights don't work right. One light constantly stays on whether the key is in the ignition or not and the other one doesn't work at all. I tried plugging in my atv trailer and its the same thing, but opposite lights. Does anyone know whats wrong here? Thanks in advance

bullettm is offline   Reply With Quote Quick reply to this message
Unread 04-30-2013, 02:53 AM   #2
Drednot
Registered User
1991 YJ Wrangler 
 
Join Date: Aug 2005
Location: phoenix, az
Posts: 1,443
Can we assume that the ATV trailer worked correctly for the last year?
__________________
91 YJ Sahara, 4.0L, AX-15/NP231, D30/D35
12 Cherokee 4x4,3.7L,
"Non Vi Sed, Arte"
Drednot is offline   Reply With Quote Quick reply to this message
Unread 04-30-2013, 07:36 AM   #3
huntb
Registered User
2008 KK Liberty 
 
Join Date: Aug 2011
Location: Grand Haven, MI
Posts: 597
Did you install the factory wire harness or an aftermarket harness?
huntb is offline   Reply With Quote Quick reply to this message
Unread 04-30-2013, 08:55 AM   #4
bullettm
Registered User
 
Join Date: Feb 2011
Location: Clifton Park, NY
Posts: 3
Everything worked fine for over a year before this. I believe the.harness is made by Curt
bullettm is offline   Reply With Quote Quick reply to this message
Unread 04-30-2013, 09:30 PM   #5
12SilverKK
Registered User
 
Join Date: Apr 2013
Posts: 1
Did you hide the harness is flexible plastic tubing? If not thr wires might have worn thru rubbing on the frame and then shorted out.
12SilverKK is offline   Reply With Quote Quick reply to this message
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the JeepForum.com forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.
Note: All free e-mails have been banned due to mis-use. (Yahoo, Gmail, Hotmail, etc.)
Don't have a non-free e-mail address? Click here for a solution: Manual Account Creation
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.


Thread Tools






Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.