Start issues with 08 - JeepForum.com
Search  
Sign Up   Today's Posts
User: Pass: Remember?
Advertise Here
Jeep Home Jeep Forum Jeep Classifieds Jeep Registry JeepSpace Jeep Reviews Jeep Gallery Jeep Clubs Jeep Groups Jeep Videos Jeep Events Jeep Articles
Go Back JeepForum.com > Models > Jeep Liberty Forums > KK Liberty Forum > Start issues with 08

Engo winches available at www.rockridge4wd.com! Free shippRockridge 4WD IS Taking Zone Offroad Suspension Lift Kits ZONE 4.25" combo lift for TJ available at Rockridge4w

Reply
Unread 11-03-2010, 01:39 PM   #1
RafaelSmith
Registered User
2008 JK Wrangler 
 
Join Date: Mar 2005
Location: Orlando, Fl
Posts: 207
Start issues with 08

My girlfriend has a 2008 Liberty and has been having problems when starting the engine. At first it was only every few days but now its starting to be more regular.

We took it to the dealer back when the problem first started but they "said" they could not reproduce the problem. They did some computer updates and for while there were not problems.

But now its back.

She goes to start the Libby in the morning and it will startup, the RPMS rise then as its about settle on idle it quits. After about 3 or 4 times of trying eventually it will not even start at all...doesnt even try. Wait 5-10min then boom engine starts fine and is good to go until next morning

Curious if any other Libby owners ever experienced this?. Might try taking it to another dealer...not sure .

__________________
2008 Silver JK 2DR X, 4sp auto, 3.73 gears
Rubicon Express 2" Coil Spacer w/Shocks
285/70/17 BFG AT
Rear Trac-Lock
Sunrider softtop.
RafaelSmith is offline   Reply With Quote
Unread 11-03-2010, 09:08 PM   #2
richd
Registered User
2008 KK Liberty 
 
Join Date: Jun 2008
Location: Arizona
Posts: 1,104
One possibility is the IAC is sticking,thats what controls the idle.
richd is offline   Reply With Quote
Unread 11-04-2010, 08:19 AM   #3
SuperRliBerty
Registered User
2008 KK Liberty 
 
Join Date: Jan 2010
Location: Florida
Posts: 1,442
Quote:
Originally Posted by RafaelSmith View Post
My girlfriend has a 2008 Liberty and has been having problems when starting the engine. At first it was only every few .
Similar problems. I had hard starting in the morning with erratic idling.My mitsubishi diamante did the same thing. Took it to a mechanic friend. said the throttle body was dirty. Cleaned it. Ran beautifully.

I cleaned the throttle body (butterfly) on mine with Valvoline throttlebody.
The second pic is a throttlebody from a 2002 libby.

The first pic is a what needs to be cleaned.
iac7.jpg   0701_4wd_05_z-2002_jeep_liberty-removed_stock_intake.jpg   7670004_vlv_602333_pri_larg.jpg  
__________________
2008 Sport Liberty
Cold air intake*Trush (magnaflow) turbo muffler* Hypertech power program*
Hood Prop mod. Battery Quick Release mod.
Resonator removed (sounds like a V8 on start up)
SuperRliBerty is offline   Reply With Quote
Reply
Thread Tools


Suggested Threads





Jeep, Wrangler, Cherokee, Grand Cherokee, and other models are copyrighted and trademarked to Jeep/Chrysler Corporation. JeepForum.com is not in any way associated with Jeep or the Chrysler Corp.