Start issues with 08 -

LinkBack Thread Tools
post #1 of 3 Old 11-03-2010, 01:39 PM Thread Starter
Registered User
2008 JK Wrangler 
Join Date: Mar 2005
Location: Orlando
Posts: 207
Start issues with 08

My girlfriend has a 2008 Liberty and has been having problems when starting the engine. At first it was only every few days but now its starting to be more regular.

We took it to the dealer back when the problem first started but they "said" they could not reproduce the problem. They did some computer updates and for while there were not problems.

But now its back.

She goes to start the Libby in the morning and it will startup, the RPMS rise then as its about settle on idle it quits. After about 3 or 4 times of trying eventually it will not even start at all...doesnt even try. Wait 5-10min then boom engine starts fine and is good to go until next morning

Curious if any other Libby owners ever experienced this?. Might try taking it to another dealer...not sure .

2008 Silver JK 2DR X, 4sp auto, 3.73 gears
Rubicon Express 2" Coil Spacer w/Shocks
285/70/17 BFG AT
Rear Trac-Lock
Sunrider softtop.
RafaelSmith is offline  
Sponsored Links
post #2 of 3 Old 11-03-2010, 09:08 PM
Registered User
2008 KK Liberty 
Join Date: Jun 2008
Location: Arizona
Posts: 1,110
One possibility is the IAC is sticking,thats what controls the idle.
richd is offline  
post #3 of 3 Old 11-04-2010, 08:19 AM
Registered User
2008 KK Liberty 
Join Date: Jan 2010
Location: Florida
Posts: 1,442
Originally Posted by RafaelSmith View Post
My girlfriend has a 2008 Liberty and has been having problems when starting the engine. At first it was only every few .
Similar problems. I had hard starting in the morning with erratic idling.My mitsubishi diamante did the same thing. Took it to a mechanic friend. said the throttle body was dirty. Cleaned it. Ran beautifully.

I cleaned the throttle body (butterfly) on mine with Valvoline throttlebody.
The second pic is a throttlebody from a 2002 libby.

The first pic is a what needs to be cleaned.
Attached Thumbnails
IAC7.jpg   0701_4wd_05_z+2002_jeep_liberty+removed_stock_intake.jpg   7670004_vlv_602333_pri_larg.jpg  

2008 Sport Liberty
Cold air intake*Trush (magnaflow) turbo muffler* Hypertech power program*
Hood Prop mod. Battery Quick Release mod.
Resonator removed (sounds like a V8 on start up)
SuperRliBerty is offline  

Quick Reply

Register Now

In order to be able to post messages on the forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid e-mail address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page

Similar Threads
Thread Thread Starter Jeep Forums Replies Last Post
2008 Liberty Skyslider Issues JFK2218 KK Liberty Forum 39 04-05-2012 11:31 AM
2009 Jeep Liberty Issues JBWrangler2000 KK Liberty Forum 10 09-29-2010 09:55 AM
Liftgate Window Latch issues mai-ling KK Liberty Forum 14 08-23-2010 11:59 AM
Cold start engine problem. Please help Steve16999 KK Liberty Forum 7 05-21-2010 10:43 PM
SkySlider - any issues YellowDuck KK Liberty Forum 21 05-18-2010 02:55 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome